Welcome

REAL-TIME TRADING
QUOTES, TICKS, HISTORY
Developing with eSignal ™
Developer Reference Guide
eSignal Desktop Trading API Edition

eSignal Developer Reference, eSignal Desktop Trading API
Copyright © 2014 eSignal, a division of Interactive Data Corporation

All rights reserved. This book may not be duplicated in any way without the expressed written consent of eSignal. The information contained herein is for the personal use of the reader and may not be incorporated in any commercial programs, other books, databases, or any kind of software without written consent from eSignal.

Disclaimer eSignal has made its best effort to prepare this book, the code contained in it, and the sample application(s) that accompanies it. Development of these applications may continue, in which case, there may be some discrepancies between the book and the sample application(s). To avoid discrepancies, ensure that you have the latest copy of this book and the most recent version of the sample application(s).


API Overview

eSignal Desktop Trading Plug-in SDK Documentation
API Overview

This topic explains eSignal Desktop Trading API usage and the developed add-in integration.

Usages

eSignal Desktop Trading API is intended for developers who need to implement an integration between eSignal Desktop and a broker.

Functionality

The following functionality can be developed using eSignal Desktop Trading API:

  • Transmission of placing/canceling/replacing order commands from eSignal Desktop to a broker.

  • Delivering real-time quote and market depth data from a broker to eSignal Desktop

  • Delivering updates from a broker to eSignal Desktop for orders, positions, executions, accounts, etc.

Add-In Conformance Testing and Certification

After a new add-in is developed and tested, it has to be certified. Only after the certification your add-in can be loaded to the application by end-users. See Conformance Testing and Certification topic for details.

Users who would like to use your add-in have to contact eSignal Customer Service and add an entitlement to their eSignal accounts.

Add-In Updates

Each update of your add-in should be confirmed by eSignal before users can load it in the eSignal Desktop. Only tested and approved versions of add-ins will be available for end-users.

It means that after you developed an update and tested it on your end, this release candidate of your add-in should be send to eSignal for conformance testing before users can install it.

See Also

Other Resources

What Is in This SDK?
API Guide
Glossary


What Is in This SDK?

What Is in This SDK?

This topic contains general information about eSignal Desktop Trading API SDK

What Is Included in the SDK?

eSignal Desktop Trading API SDK is a development package, it contains the following items:

  • eSignal Desktop Trading API libraries

  • Trading Plug-in SDK Samples

    You can load this solution to MS Visual Studio 2012 and use its two sample add-ins as examples of working test plug-ins.

    See Trading Plug-In Samples topic for details.

  • Test Runner application

    See Test Runner topic for details.

  • Runtime libraries

See Also

Other Resources

SDK Installation and Setup
Trading Plug-In Samples
Test Runner


Installation and Setup

Installation and Setup

This topic contains the following sections.

  • Installing the eSignal Desktop Trading API SDK
  • Setting Up the Development Environment
Installing the eSignal Desktop Trading API SDK

Installation requirements:

  • Microsoft .NET 4.0 or higher.

Installation process:

  1. Launch the installer.

  2. Choose installation directory. It MUST allow write access to it.

  3. Install to selected directory.

Setting Up the Development Environment

The SDK only supports development in Microsoft Visual Studio 2012 and higher. Supported languages are:

  • C#

  • VB.NET

  • F#

  • C++\CLI

Note Note

All the instructions below are given for a C# project.

When creating an add-in from scratch, do the following:

  1. Create new Class Library project in Microsoft Visual Studio 2012.

  2. Add reference to InteractiveData.EsignalDesktop.Trading.dll assembly.


Trading Plug-In Samples

Trading Plug-In Samples

Sample Plug-in is an example of a working add-in that can be compiled and loaded to the Test Runner or to eSignal Desktop.

General Concepts

Trading Plug-in SDK Samples solution demonstrates best practices in add-in development. It is well-commented and it shows sample implementation of basic methods of the IPlugin interface. The solution contains two projects for the supported languages C# and C++.

The projects can be extended.

What Functionality Does the Sample Plug-In Illustrate?

In the C# and C++ Sample Plug-ins you can find examples of:

  • Connecting

  • Sending historical data

  • Symbol mapping

  • Subscribing on market data (quote and market depth)

  • Placing orders

  • Replacing orders

  • Canceling orders

  • Customizing controls in the Order Ticket

Functionality of both add-ins is identical.

Usage

  1. Open file Trading Plug-in SDK Samples.sln from the SDK installation directory in Microsoft Visual Studio 2012 or higher.

    You can review code implementation of the functionality above and extend it if you want to check some other aspects of the integration with eSignal Desktop.

  2. Compile and run the solution.

    The add-in runs loaded in the external Test Runner application where you can perform some basic tests on Sample Plug-in and on your add-in. See Test Runner topic for details.

    Note Note

    CSharpSamplePlugin is selected as single startup project in the solution properties, if you want to work with CppCLISamplePlugin, you should set it instead.

  3. Load Sample Plug-in to eSignal Desktop:

    1. Depending on the language you are working with, copy the following files from \CSharpSamplePlugin\PluginDeploymentPath or \CppCLISamplePlugin\PluginDeploymentPath to the add-in directory:

      • CSharpSamplePlugin.dll or CppCLISamplePlugin.dll

      • CSharpSamplePlugin.manifest or CppCLISamplePlugin.manifest

      • InteractiveData.EsignalDesktop.Bridge.dll

      • InteractiveData.EsignalDesktop.Trading.dll

      Tip Tip

      An add-in must be installed to its own directory. Base path can be found under HKEY_CURRENT_USER\Software\Interactive Data\eSignal\ThirdParty\Trading registry key path. String parameter named 'AddinsPath' points to a directory under which the add-in must be installed.

      See Add-in Deployment topic for details.

    2. Run eSignal Desktop

    3. Open Broker Manager from the Trade menu and add your plug-in to the connection list. See glossary for details.

    4. Connect the created connection.

    When the add-in is connected you can test how it interracts with eSignal Desktop Trading functionality.

    Important note Important

    1. eSignal Desktop version 11.6 or higher must be installed.

    2. Your eSignal account must have Trading API Developer entitlement. Otherwise the add-in will not appear in the Broker list.

See Also

Other Resources

SDK Installation and Setup
Test Runner
Add-In Deployment


Test Runner

Test Runner

Test Runner is an application that can be used for the following purposes:

  1. Validating implementations, declarations and behavior

  2. Initial testing of the add-in


Add-in Deployment

Add-in Deployment

This page describes a process of deploying the add-in to end-user.

General Concepts

  • An add-in must be installed to its own directory. Base path can be found under HKEY_CURRENT_USER\Software\Interactive Data\eSignal\ThirdParty\Trading registry key path. String parameter named 'AddinsPath' points to a directory under which the add-in must be installed.

  • Add-in directory is made up of the following: add-in ID, add-in version.

    For example: if an add-in ID that was issued to you by eSignal is "STOCKBROKER" and the current version is "1.2.3.4", destination directory name will be STOCKBROKER\1.2.3.4\<...>

The following SDK libraries need to be installed with every add-in:

  • InteractiveData.EsignalDesktop.Trading.dll

  • InteractiveData.EsignalDesktop.Bridge.dll

  • msvcr110.dll

  • msvcp110.dll

  • Your add-in library (DLL)

  • Your add-in manifest file (.manifest)

  • Any modules that the add-in implementation depends on

You have to create a different build for Windows XP, if you develop your add-in on C++\CLI in Microsoft Visual Studio 2012 Update 2 or earlier version:

  1. Install the Update 3 (or later) for Microsoft Visual Studio 2012. The latest update is available here

  2. Set Platform Toolset to Visual Studio 2012 - Windows XP (v110_xp) in the project properties (Configuration/General/Platform Toolset)

  3. Rebuild the project

See Visual C++ Team Blog for more information.

Note Note

eSignal Desktop only supports Trading API add-ins in versions 11.6 and higher.

  • You would need to add an EntitlementBit to your add-in. This would provide users with access to the add-in. Contact eSignal to know your Entitlement bit.

  • The add-in installer should have your digital signature.


API Guide

API Guide

This page describes all the main concepts of the API.

This topic contains the following sections.

  • IPlugin Implementation
  • IPluginHost
  • Meta-Information
  • Add-In Manifest
  • Data Types
  • See Also
IPlugin Implementation

Any add-in must implement this interface.

For additional reference see IPlugin.

IPluginHost

This object is passed via implementation's overridden method OnHostAttach(IPluginHost) and serves as a communication channel between the add-in and the application.

For additional reference see IPluginHost.

Meta-Information

API relies on a wide range of attributes that provide meta-information about the add-in.

  • PluginAttribute

  • SupportedSymbolTypesAttribute

  • CustomFieldAttribute

Add-In Manifest

Each add-in must have a manifest file. Mainfest file is an XML file with .manifest extension. See glossary for details.

Data Types

The following data types are used when providing data to application:

  • ConnectionStateData

  • OrderData

  • PositionData

  • AccountData

  • ExecutionData

  • SymbolData

There's also one distinct data type that is used for passing and storing connection settings:

  • ConnectionSettings

See Also

Other Resources

Extending Built-In Types


Extending Built-In Types

Extending Built-In Types

This topics describes why it is needed to extend built-in classes and how it is done.

Concept of Extending Built-In Types

In order for add-in to provide non-standard field values (that do not present in data structures initially), built-in types such as OrderData and PositionData must be extended. The other types are not necessary to extend (and actually, this is not possible).

Note Note

There must be entities in your code that inherit these two types. This is done because nearly every broker has its own specific data that needs to be provided to user.

Also, there are OrderDefaultsAttribute and OrderInputsAttribute attributes, that need to be applied to particular OrderData implementation. See glossary for details.

For example:

C#
C++
Copy
// The following two types must be declared in order the add-in
// meta-information to be treated as valid.

public sealed class StockBrokerOrderData : OrderData
{
    public StockBrokerOrderData(String Id, String Symbol)
        : base(Id, Symbol)
    {
    }
}

public sealed class StockBrokerPositionData : PositionData
{
    public StockBrokerPositionData(String Id, String Symbol)
        : base(Id, Symbol)
    {
    }
}
// The following two types must be declared in order the add-in
// meta-information to be treated as valid.

public ref class StockBrokerOrderData sealed : OrderData
{
public:
    StockBrokerOrderData(String^ Id, String^ Symbol)
        : OrderData(Id, Symbol)
    {
    }
};

public ref class StockBrokerPositionData sealed : PositionData
{
public:
    StockBrokerPositionData(String^ Id, String^ Symbol)
        : PositionData(Id, Symbol)
    {
    }
};

Extension is done via inheriting base type and adding properties to it. The following code shows an example of extending order data type to employ additional standard fields:

C#
C++
Copy
public sealed class StockBrokerOrderData : OrderData
{
    public StockBrokerOrderData(String Id, String Symbol)
        : base(Id, Symbol)
    {
    }

    [OrderGoodTillDate]
    public DateTime? GoodTillDate { get; set; }

    [OrderExpiry]
    public OrderExpiry Expiry { get; set; }
}
public ref class StockBrokerOrderData sealed : OrderData
{
public:
    StockBrokerOrderData(String^ Id, String^ Symbol)
        : OrderData(Id, Symbol)
    {
    }

    [OrderGoodTillDate]
    property Nullable<DateTime> GoodTillDate;

    [OrderExpiry]
    property OrderExpiry Expiry;
};

You can have fields that are not covered by pre-defined standard fields. In this case, CustomFieldAttribute should be used in conjunction with additional properties.

C#
C++
Copy
public sealed class StockBrokerOrderData : OrderData
{
    public StockBrokerOrderData(String Id, String Symbol)
        : base(Id, Symbol)
    {
    }

    [CustomField("CustomString", "Custom String")]
    public string CustomString { get; set; }
}
public ref class StockBrokerOrderData sealed : OrderData
{
public:
    StockBrokerOrderData(String^ Id, String^ Symbol)
        : OrderData(Id, Symbol)
    {
    }

    [CustomField("CustomString", "Custom String")]
    property String^ CustomString;
};

Now, you can use this for providing an additional field value:

C#
C++
Copy
StockBrokerOrderData Order = new StockBrokerOrderData(...);

Order.CustomString = "Some Important Value";

PluginHost.SendOrder(Order);
SampleOrderData^ Order = gcnew SampleOrderData(...);

Order->CustomString = "Some important value";

PluginHost->SendOrder(Order);
Types That Need to Be Extended?

  • OrderData

  • PositionData

  • ConnectionSettings

  • AccountData

Creating Connection Settings Data Type

You must create your own connection settings type based on ConnectionSettings base class. Typical implementation looks like the following:

C#
C++
Copy
public sealed class StockBrokerConnectionSettings : ConnectionSettings
{
    public string Login { get; set; }

    public string Password { get; set; }
}
public ref class StockBrokerConnectionSettings sealed : ConnectionSettings
{
public:
    property String^ Login;

    property String^ Password;
};

And usage:

C#
C++
Copy
public void Connect(ConnectionSettings ConnectionSettings)
{
    var MySettings = (StockBrokerConnectionSettings) ConnectionSettings;

    if (!String.IsNullOrEmpty(MySettings.Login))
    {
        ...
    }

    if (!String.IsNullOrEmpty(MySettings.Password))
    {
        ...
    }
}
void StockBrokerPlugin::Connect(ConnectionSettings^ ConnectionSettings)
{
    StockBrokerConnectionSettings^ MySettings = (StockBrokerConnectionSettings^) ConnectionSettings;

    if (!String::IsNullOrEmpty(MySettings->Login))
    {
        ...
    };

    if (!String::IsNullOrEmpty(MySettings->Password))
    {
        ...
    };
};


Establishing Connection

Establishing Connection

This topic explains how to establish a connection.

This topic contains the following sections.

  • Connection Process
  • Add-In Initialization
  • Connection Settings
  • Connect Method
  • Samples
Connection Process

The following diagram explains the connection process:

Add-In Initialization

When a user selects to connect the connection via eSignal Desktop GUI, plug-in's OnHostAttach(IPluginHost) method is called first. This method supplies your add-in with IPluginHost object that serves as a communication channel between the add-in and eSignal Desktop. You need to override this method in order to subscribe on events and send messages and data to the application.

For example:

C#
C++
Copy
public void OnHostAttach(IPluginHost Host)
{
    PluginHost = Host;

    // Tell the application where this add-in's logs are located.
    // In case of unrecoverable error, this directory content is going to be
    // sent to error reporting server to be analyzed.
    PluginHost.SetCustomLogsDirectory("my-logs");

    // Subscribe for additional events.
    PluginHost.SymbolSubscribed += OnSymbolSubscribed;
    PluginHost.SymbolUnsubscribed += OnSymbolUnsubscribed;

    // Subscribe for events to be able to handle quote (level I) requests.
    PluginHost.SymbolQuoteSubscribed += OnSymbolQuoteSubscribed;
    PluginHost.SymbolQuoteUnsubscribed += OnSymbolQuoteUnsubscribed;

    // Subscribe for events to be able to handle market depth (level II) requests.
    PluginHost.SymbolMarketDepthSubscribed += OnSymbolMarketDepthSubscribed;
    PluginHost.SymbolMarketDepthUnsubscribed += OnSymbolMarketDepthUnsubscribed;
}
void CppCLISamplePlugin::OnHostAttach(IPluginHost^ Host)
{
    PluginHost = Host;

    // Tell the application where this add-in's logs are located.
    // In case of unrecoverable error, this directory content is going to be
    // sent to error reporting server to be analyzed.
    PluginHost->SetCustomLogsDirectory("my-logs");

    // Subscribe for additional events.
    PluginHost->SymbolSubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolSubscribed);
    PluginHost->SymbolUnsubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolUnsubscribed);

    // Subscribe for events to be able to handle quote (level I) requests.
    PluginHost->SymbolQuoteSubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolQuoteSubscribed);
    PluginHost->SymbolQuoteUnsubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolQuoteUnsubscribed);

    // Subscribe for events to be able to handle market depth (level II) requests.
    PluginHost->SymbolMarketDepthSubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolMarketDepthSubscribed);
    PluginHost->SymbolMarketDepthUnsubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolMarketDepthUnsubscribed);
}
Connection Settings

The next step is creating an instance of plug-in-defined connection settings.

You have to define connection settings class inherited from ConnectionSettings before your add-in can be built.

You also need to implement IConnectionSettingsPage interface. This page appears when a user selects Connection Settings in the Broker Manager. See glossary for details.

Connect Method

After the plug-in-defined connection settings object is ready, it is passed to the Connect(ConnectionSettings) method. In this method you need to initiate a connecting process to the broker's servers using the supplied settings.

Connection States

The add-in must report its state via SendConnectionState(ConnectionStateData) method.

Enumeration ConnectionState contains the supported states.

Use the following rules for sending states when establishing a connection:

  • Send Connecting right before connecting to the broker servers.

  • Send Connected when connection to the broker servers is established.

  • Send Blocked when connection is not established at the broker servers. For example plug-in cannot connect because of invalid connection settings.

  • Send InternalError when connection cannot be established by any other reason.

You can send messages during the connecting process:

C#
C++
Copy
PluginHost.SendMessage("Could not connect due to the following reason: " + reason);
PluginHost->SendMessage("Could not connect due to the following reason: " + reason);

When reporting the connection state as Connected you have to send the type of environment where connection is established if this information is avaliable: DEMO or LIVE.

For example:

C#
C++
Copy
PluginHost.SendConnectionState(new ConnectionStateData(ConnectionState.Connected, ConnectionEnvironment.Demo));
PluginHost->SendConnectionState(gcnew ConnectionStateData(ConnectionState::Connected, ConnectionEnvironment::Demo));

If the type of environment is not specified, it is considered in the application as LIVE. This information is used in the eSignal Desktop and indicates to a user whether it is allowed to trade for real money or not with the current connection settings.

Sending Historical Data

After the connection state reported as Connected you can start sending historical data to the application: accounts, orders, positions and executions.

For example:

C#
C++
Copy
private void SendSomeHistoricalDataAsAnExample()
    {
        // Create object to do some randomization.
        //
        var Random = new Random();

        // Hard-code account name to be used. In real-life, accounts usually come from the server.
        //
        const String AccountName = "Demo USD Account";

        // Account, check Accounts Tab in AM.
        //
        PluginHost.SendAccount(new SampleAccountData(AccountName)
        {
            // Add some random account balance value. In real-life add-in this value
            // is going to be taken from the network, servers, etc.
            //
            Balance = 100000.0 * Random.NextDouble()
        });

        // Position, check Positions Tab in AM.
        //
        // An open (active) position:
        //
        PluginHost.SendPosition(new SamplePositionData(Guid.NewGuid().ToString(), "VOD-LON")
        {
            Account = AccountName,

            Quantity = 990,

            // Average price must be filled properly for open positions!
            //
            AveragePrice = 100 * Random.NextDouble(),

            RealizedProfitLoss = 500 - (1000 * new Random().NextDouble())
        });

        // Let's talk to user a little bit.
        //
        PluginHost.SendMessage("Dear developer! Historical data is ready. Have a nice debugging.");
 }
void CppCLISamplePlugin::SendSomeHistoricalDataAsAnExample()
{
    // Hard-code account name to be used. In real-life, accounts usually come from the server.
    //
    String^ AccountName = "Demo USD Account";

    // Account, check Accounts Tab in AM.
    //
    SampleAccountData^ accountData = gcnew SampleAccountData(AccountName);

    // Add hard-code account balance value. In real-life add-in this value
    // is going to be taken from the network, servers, etc.
    //
    accountData->Balance = 100000.0;

    PluginHost->SendAccount(accountData);

    // Position, check Positions Tab in AM.
    //
    // An open (active) position:
    //
    SamplePositionData^ openPositionData = gcnew SamplePositionData(Guid::NewGuid().ToString(), "VOD-LON");

    openPositionData->Account = AccountName;

    openPositionData->Quantity = 990;

    // Average price must be filled properly for open positions!
    //
    openPositionData->AveragePrice = 100;

    openPositionData->RealizedProfitLoss = 500;

    PluginHost->SendPosition(openPositionData);

    // Let's talk to user a little bit.
    //
    PluginHost->SendMessage(gcnew MessageData("Dear developer! Historical data is ready. Have a nice debugging."));
}

After confirming established connection and loading the historical data, make sure you either call PluginHostExtensionsEndOfAllHistory(IPluginHost) or all of the IPluginhost.End[XXXX]History(). This means that the add-in has finished receiving historical data from its servers and ready to go real-time processing. If you miss the call, the add-in will never get green status in the application.

For example:

C#
Copy
PluginHost.EndOfAllHistory();

or

C#
C++
Copy
PluginHost.EndAccountHistory();
PluginHost.EndOrderHistory();
PluginHost.EndPositionHistory();
PluginHost.EndExecutionHistory();
PluginHost->EndAccountHistory();
PluginHost->EndOrderHistory();
PluginHost->EndPositionHistory();
PluginHost->EndExecutionHistory();
Note Note

Please notice that the actual connection to your broker does not necessarily have to be established within this method. If your broker API is asynchronous, it is ok to change connection state to Connecting, leave this method and update connection state once you have response from your own API.

Samples

Sample implementation of the Connect(ConnectionSettings) method:

C#
C++
Copy
public void Connect(ConnectionSettings ConnectionSettings)
{
    var Settings = (SampleConnectionSettings) ConnectionSettings;

    PluginHost.SendConnectionState(ConnectionState.Connecting);

    PluginHost.SendConnectionState(new ConnectionStateData(ConnectionState.Connected, ConnectionEnvironment.Demo));

    // Now we can send some data to the application.
    //
    SendSomeHistoricalDataAsAnExample();

    PluginHost.EndOfAllHistory();
}
void CppCLISamplePlugin::Connect(ConnectionSettings^ ConnectionSettings)
{
    SampleConnectionSettings^ Settings = (SampleConnectionSettings^) ConnectionSettings;

    PluginHost->SendConnectionState(gcnew ConnectionStateData(ConnectionState::Connecting));

    PluginHost->SendConnectionState(gcnew ConnectionStateData(ConnectionState::Connected, ConnectionEnvironment::Demo));

    // Now we can send some data to the application.
    //
    SendSomeHistoricalDataAsAnExample();

    PluginHost->EndAccountHistory();
    PluginHost->EndOrderHistory();
    PluginHost->EndPositionHistory();
    PluginHost->EndExecutionHistory();
}

For the case of the asynchronous broker API:

C#
Copy
// Take the following interface as an example of broker API interface:
//
 interface IStockBrokerAPI
 {
     void Connect();          // Asynchronous. Reports its result via the two events below.

     event Action Connected;

     event Action<String> Error;
 }

// In this case,SamplePlugin.Connect() method could look like:
//
 public void Connect(ConnectionSettings ConnectionSettings)
 {
     PluginHost.SendConnectionState(ConnectionState.Connecting);

     IStockBrokerAPI API = /* get it somewhere */;

     API.Connected += delegate
     {
         PluginHost.SendConnectionState(ConnectionState.Connected);
     };

     API.Error += delegate(String reason)
     {
         PluginHost.SendMessage("Could not connect due to the following reason: " + reason);

         PluginHost.SendConnectionState(ConnectionState.Blocked);
     };

     API.Connect();
 }


Symbol Mapping

Symbol Mapping

This topic is about symbol mapping process.

This topic contains the following sections.

  • Symbol Mapping Process
  • Exchanges
  • eSignal Symbology
Symbol Mapping Process

The following diagram explains the symbol mapping process:

Symbol mapping process is initiated each time when a user types in a symbol to windows that allow trading. It starts from IPluginMapSymbolFrom(IInputSymbol) call. You can use this method if you need to convert symbol between eSignal representation and your broker representation. As the result you should either return a string representation (identifier) of the symbol in a form that is appropriate for you or an empty string if it is impossible to do such a conversion and you want to force user to select the symbol manually via Lookup dialog.

In the field IInputSymbolSymbol the passed parameter contains symbol as a raw string exactly like it was entered by the user. If the symbol is valid eSignal Desktop symbol, another field IInputSymbolESignalSymbol contains reference to IESignalSymbol structure with extended symbol information such as

  • Symbol underlying (root)

  • Exchange

  • Symbol type

  • Expiration parameters

  • Option parameters (call or put, strike)

  • Forex parameters (Base and quote currencies)

etc.

For example, Forex symbols are represented by something like 'EUR A0-FX' in eSignal, while more appropriate representation could be 'EUR/USD':

C#
C++
Copy
public string MapSymbolFrom(IInputSymbol symbol)
{
    // That's what originally was typed.
    //
    var UserSymbol = symbol.Symbol;

    // Example of conversion:
    //
    if (symbol.ESignalSymbol != null)
    {
        if (symbol.ESignalSymbol.Type == SymbolType.Forex)
        {
            return String.Format("{0}/{1}",
                symbol.ESignalSymbol.BaseCurrency,
                symbol.ESignalSymbol.QuoteCurrency);
        }

        // At the same time, stocks could be returned without conversion:

        if (symbol.ESignalSymbol.Type == SymbolType.Stock)
        {
            return symbol.Symbol;
        }
    }

    // Finally, let's ban everything that is not Forex or stock.
    //
    return String.Empty;
}
String^ CppCLISamplePlugin::MapSymbolFrom(IInputSymbol^ symbol)
{
    // That's what originally was typed.
    //
    String^ UserSymbol = symbol->Symbol;

    // Example of conversion:
    //
    if (symbol->ESignalSymbol != nullptr)
    {
        if (symbol->ESignalSymbol->Type == SymbolType::Forex)
        {
            return String::Format("{0}/{1}",
                symbol->ESignalSymbol->BaseCurrency,
                symbol->ESignalSymbol->QuoteCurrency);
        }

        // At the same time, stocks could be returned without conversion:
        //
        if (symbol->ESignalSymbol->Type == SymbolType::Stock)
        {
            return symbol->Symbol;
        }
    }

    // Finally, let's ban everything that is not Forex or stock.
    //
    return String::Empty;
}

If IPluginMapSymbolFrom(IInputSymbol) has returned an empty string, Symbol Lookup dialog appears.

If the returned string is not empty, it is passed to the plug-in via IPluginHostSymbolSubscribed event. Your add-in must subscribe on this event in the very beginning of the add-in work, for example in IPluginOnHostAttach(IPluginHost) method:

C#
C++
Copy
public void OnHostAttach(IPluginHost Host)
{
    PluginHost = Host;

    // Subscribe for events to be able to handle symbol information requests.
    PluginHost.SymbolSubscribed += OnSymbolSubscribed;
    PluginHost.SymbolUnsubscribed += OnSymbolUnsubscribed;
}
void CppCLISamplePlugin::OnHostAttach(IPluginHost^ Host)
{
    PluginHost = Host;

    // Subscribe for events to be able to handle symbol information requests.
    PluginHost->SymbolSubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolSubscribed);
    PluginHost->SymbolUnsubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolUnsubscribed);
}

Then start a network request in SymbolSubscribed event handler or send the information right away.

Construct SymbolData object and prepare symbol information for sending in to the application.

Important note Important

Notice that SymbolDataValid field needs to be set explicitly in order to show that the information is supposed to be correct. If you fail to retrieve the symbol information for some reason, set this field to 'false'. This will allow the application to treat this symbol as invalid.

For sending information to the application, use method IPluginHostSendSymbol(String, SymbolData):

C#
C++
Copy
private void OnSymbolSubscribed(string symbolId)
{
    // Construct the object. Notice that correct id must always be specified.
    var SymbolInformation = new SymbolData(symbolId);

    SymbolInformation.Valid = true;

    SymbolInformation.Type = SymbolType.Stock;

    SymbolInformation.MinMovement = 1;

    SymbolInformation.PriceScale = 100;

    SymbolInformation.PointValue = 1.0;

    SymbolInformation.PriceType = SymbolPriceType.Neutral;

    PluginHost.SendSymbol(symbolId, SymbolInformation);
}
void CppCLISamplePlugin::OnSymbolSubscribed(String^ SymbolId)
{
    // Construct the object. Notice that correct id must always be specified.
    SymbolData^ SymbolInformation = gcnew SymbolData(SymbolId);

    SymbolInformation->Valid = true;

    SymbolInformation->Type = SymbolType::Stock;

    SymbolInformation->MinMovement = 1;

    SymbolInformation->PriceScale = 100;

    SymbolInformation->PointValue = 1.0;

    SymbolInformation->PriceType = SymbolPriceType::Neutral;

    PluginHost->SendSymbol(SymbolId, SymbolInformation);
}

All the following work is made using the plug-in's symbol representation and user will see eSignal representation in the application. For example:

C#
C++
Copy
PluginHost.SendPosition(new SamplePositionData(Guid.NewGuid().ToString(), "EUR/USD")
{
    Account = AccountName,

    Quantity = 10000,

    AveragePrice = 1.3,

    RealizedProfitLoss = 130
});
SamplePositionData^ forexPositionData = gcnew SamplePositionData(Guid::NewGuid().ToString(), "EUR/USD");

forexPositionData->Account = AccountName;

forexPositionData->Quantity = 10000;

forexPositionData->AveragePrice = 1.3;

forexPositionData->RealizedProfitLoss = 130;

PluginHost->SendPosition(forexPositionData);

As the result, you will see the following in the eSignal Desktop:

As you see, the application uses symbol name "EUR A0-FX" that was entered by user, and not your internal symbol representation that you use in the add-in.

If you send an order, position or execution for a symbol that is not mapped in the Broker Manager, it will be added to the dictionary automatically. In this case the internal add-in symbol name will be assigned to eSignal symbol name. And if it is inappropriate for the user, he can change it in the Broker Manager.

Exchanges

Exchange name for eSignal symbol can be represented in codes that might differ from the actual exchange names and codes that are used for the exchanges at the Broker end. And one exchange can have different codes in eSignal Desktop, depending on additional parameters such as symbol type. Using eSignal exchange code only, it is not always easy to say what the generally used name is for the symbol's exchange or trading floor. So, the API provides two fields that you can use if you need to know the exchange:

  • Property IESignalSymbolExchangeName contains a string with eSignal symbol's exchange code in the same representation like it is used in eSignal Desktop. Most likely, this code is not equal to the actual exchange name.

  • Property IESignalSymbolExchange contains a member of enumeration Exchange. The field has value, if eSignal exchange code of the symbol is matched to a member of the enumeration, and it takes null for codes that are not matched to any of the enumeration members. One item of the enumeration can correspond to several exchange codes that are used in the application.

If you need to add more eSignal exchange codes to the enumeration, send a request to eSignal Desktop Trading API Support. The request should contain eSignal exchange code and example of a symbol from this exchange.

eSignal Symbology

Detail information about eSignal symbology can be found in eSignal Knowledge Base.


Subscribing Market Data

Subscribing Market Data

This section explains how to send data from broker to the eSignal Desktop.

This topic contains the following sections.

  • General Information
  • Data Streaming Support
  • Handling Quote Data Requests
  • Handling Market Depth Data Requests
General Information

eSignal Desktop has a set of windows and other entities that can subscribe on market data from the Broker. For example, Trade Manager has an option to display Quote and Market Depth data from the Broker.

Your plug-in can provide real-time data for the application using IPluginHost interface. This interface has event members that allow you to handle subscribe events for different types of data requests that can come from the application. You must implement handlers for these events in your plug-in.

Within these handlers you should initiate data subscription at the Broker's side. Use IPluginHost.SendXXX methods for sending the subscribed data back to the application.

Unsubscribe events occur after the market data are no longer needed for the application. For example, when user closes Trade Manager window, events IPluginHostSymbolQuoteUnsubscribed and IPluginHostSymbolMarketDepthUnsubscribed occur. You must implement handlers for these events as well. In these handlers your add-in should stop data flow from broker API.

Data Streaming Support

By default add-in is considered as a data provider for trading windows. But there is an option not to support data streaming for brokers that do not have their own data feed.

If you are not going to support data streaming from the broker, you have to set PluginAttributeDataStreamingSupported property to false. For example,

C#
C++
Copy
namespace CSharpSamplePlugin
{
    // This attribute marks add-in implementation and sets values of some additional properties.
    //
    [Plugin(DataStreamingSupported = false)]

    public sealed class CSharpSamplePlugin : IPlugin
    {
        ...
    }
}
namespace CppCLISamplePlugin
{
    // This attribute marks add-in implementation and sets values of some additional properties.
    //
    [Plugin(DataStreamingSupported = false)]

    public ref class CppCLISamplePlugin
        : InteractiveData::eSignalDesktop::Trading::IPlugin
    {
        ...
    };
}

Another option is to specify data streaming support flag when connecting for each particular session. You can use it if your add-in's ability to support data streaming depends on session parameters such as account, type of environment, connected servers, etc.

In this case you should set ConnectionStateDataDataStreamingSupported to required value and send it to the application, when reporting Connected state. For example,

C#
C++
Copy
public void Connect(ConnectionSettings ConnectionSettings)
{
    var Settings = (SampleConnectionSettings) ConnectionSettings;

    PluginHost.SendConnectionState(ConnectionState.Connecting);

    if (Settings.Login == "DEMOUSER")
    {
        PluginHost.SendConnectionState(new ConnectionStateData(ConnectionState.Connected)
        {
            DataStreamingSupported = false
        });
    }
    else
    {
        PluginHost.SendConnectionState(new ConnectionStateData(ConnectionState.Connected)
        {
            DataStreamingSupported = true
        });
    }
    ...
}
void CppCLISamplePlugin::Connect(ConnectionSettings^ ConnectionSettings)
{
    SampleConnectionSettings^ Settings = (SampleConnectionSettings^) ConnectionSettings;

    PluginHost->SendConnectionState(gcnew ConnectionStateData(ConnectionState::Connecting));

    ConnectionStateData^ connectionStateData = gcnew ConnectionStateData(ConnectionState::Connected);

    if (Settings->Login == "DEMOUSER")
    {
        connectionStateData->DataStreamingSupported = false;
    }
    else
    {
        connectionStateData->DataStreamingSupported = true;
    }

    PluginHost->SendConnectionState(connectionStateData);

    ...
}
Important note Important

Notice that session's value has higher priority than the add-in's attribute: no matter what the attribute is, the specified value for this particular session will be more important.

After this your add-in will not receive any data requests from the application. Events IPluginHostSymbolQuoteUnsubscribed and IPluginHostSymbolMarketDepthUnsubscribed will not occur, and you do not need to handle them.

If you do not support data, the application will use eSignal data feed for all needs. For the user it will look like always green icon eSignal Market Data eSignal Market Data Icon in all trading windows.

Handling Quote Data Requests

If you want to handle quote requests from the eSignal Desktop, first of all, you would need a subscription on the following events:

  • IPluginHostSymbolQuoteSubscribed

  • IPluginHostSymbolQuoteUnsubscribed

Subscribe on these events somewhere before your add-in gets connected. IPluginOnHostAttach(IPluginHost) is a good place for it.

For example:

C#
C++
Copy
public void OnHostAttach(IPluginHost Host)
{
    PluginHost = Host;

    // Subscribe for events to be able to handle quote (level I) requests.
    PluginHost.SymbolQuoteSubscribed += OnSymbolQuoteSubscribed;
    PluginHost.SymbolQuoteUnsubscribed += OnSymbolQuoteUnsubscribed;
}
void CppCLISamplePlugin::OnHostAttach(IPluginHost^ Host)
{
    PluginHost = Host;

    // Subscribe for events to be able to handle quote (level I) requests.
    PluginHost->SymbolQuoteSubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolQuoteSubscribed);
    PluginHost->SymbolQuoteUnsubscribed += gcnew SymbolEventHandler(this, &CppCLISamplePlugin::OnSymbolQuoteUnsubscribed);
}
Note Note

Make sure that you subscribed on these events. Otherwise the application will not receive data from the add-in and such values as Open PL, Pull Back and some others might not be calculated properly.

Start a network request in IPluginHostSymbolQuoteSubscribed event handler or send the information right away.

C#
C++
Copy
private void OnSymbolQuoteSubscribed(String symbolId)
{
    // This method is called when application needs Level One (or Daily, or Quote) data for given symbol.
    //
    var Data = new QuoteData(symbolId);

    Data.TradePrice = ...
    Data.TradeSize = ...

    Data.AskPrice = ...
    Data.AskSize = ...

    Data.BidPrice = ...
    Data.BidSize = ...

    PluginHost.SendQuote(Data);
}
void CppCLISamplePlugin::OnSymbolQuoteSubscribed(String^ SymbolId)
{
    // This method is called when application needs Level One (or Daily, or Quote) data for given symbol.
    //

    QuoteData^ Data = gcnew QuoteData(SymbolId);

    Data->TradePrice = ...
    Data->TradeSize = ...

    Data->AskPrice = ...
    Data->AskSize = ...

    Data->BidPrice = ...
    Data->BidSize = ...

    PluginHost->SendQuote(Data);
}

For sending information back, use method IPluginHostSendQuote(QuoteData).

Important note Important

Notice that you should only send data for the Symbol IDs that are subscribed on data. Otherwise you will get a data validation exception.

After Quote data are no longer needed for the application, IPluginHostSymbolQuoteUnsubscribed event occurs. In its handler you need to terminate the network request on Quote data for the passed Symbol ID.

Handling Market Depth Data Requests

Dealing with Market Depth data requests is quite the same.

  1. Subscribe on events IPluginHostSymbolMarketDepthSubscribed and IPluginHostSymbolMarketDepthUnsubscribed

  2. In IPluginHostSymbolMarketDepthSubscribed event handler start a network request for Market Depth data at the Broker.

  3. On receiving data from the Broker send them to the application using method IPluginHostSendMarketDepth(MarketDepthData)

  4. Handle event IPluginHostSymbolMarketDepthUnsubscribed and stop the network Market Depth data request at the Broker for the passed Symbol ID.

Here is an example of handling Market Depth data requests:

C#
C++
Copy
private void OnSymbolMarketDepthSubscribed(String symbolId)
{
    // This method is called when application needs Level Two (or Market Depth) data for given symbol.
    //
    var Data = new MarketDepthData(symbolId);

    var Asks = new List<MarketDepthData.Entry>();

    var Bids = new List<MarketDepthData.Entry>();

    // Add some levels to the price ladder. For example, 5:
    //
    for (var i = 0; i < 5; ++i)
    {
        Asks.Add(new MarketDepthData.Entry()
        {
            Price = ...

            Size = ...
        });

        Bids.Add(new MarketDepthData.Entry()
        {
            Price = ...

            Size = ...
        });
    }

    Data.Asks = Asks.ToArray();

    Data.Bids = Bids.ToArray();

    PluginHost.SendMarketDepth(Data);
}
void CppCLISamplePlugin::OnSymbolMarketDepthSubscribed(String^ SymbolId)
{
    // This method is called when application needs Level Two (or Market Depth) data for given symbol.
    //
    MarketDepthData^ Data = gcnew MarketDepthData(SymbolId);

    List<MarketDepthData::Entry>^ Asks = gcnew List<MarketDepthData::Entry>();

    List<MarketDepthData::Entry>^ Bids = gcnew List<MarketDepthData::Entry>();

    // Add some levels to the price ladder. For example, 5:
    //
    for (int i = 0; i < 5; ++i)
    {
        MarketDepthData::Entry ask;

        ask.Price = ...

        ask.Size = ...

        Asks->Add(ask);

        MarketDepthData::Entry bid;

        bid.Price = ...

        bid.Size = ...

        Bids->Add(bid);
    }

    Data->Asks = Asks->ToArray();

    Data->Bids = Bids->ToArray();

    PluginHost->SendMarketDepth(Data);
}


Populating Unrealized Profit/Loss

Populating Unrealized Profit/Loss

This topic explains how to send Unrealized (Open) Profit/Loss for positions.

This topic contains the following sections.

  • General Information
  • Sending Unrealized PL with Position Data
  • Calculating Unrealized PL
    • Calculating Unrealized PL from Custom Closing Price
    • Calculating Unrealized PL from Broker's Bid and Ask
    • Calculating Unrealized PL from eSignal's Bid and Ask
  • See Also
General Information

eSignal has three types of Unrealized (Open) Profit/Loss:

  • Unrealized PL in currency shows how much money would you gain or lose, if you closed this position right now.

  • Unrealized PL in min point terms shows how many min points (min ticks) would you gain or lose, if you closed this position right now.

  • Unrealized PL in percentage terms shows how many percent would you gain or lose in comparison to initial position cost, if you closed this position right now.

You can see these values in the Chart, Trade Manager, Positions tab in Account Manager and some other windows. When clicking in Profit/Loss area in the Chart or Trade Manager, first it switches displayed values from currency to min points, then to percentage terms and then back to currency. Account Manager has separate columns for each type of value.

Image below illustrates Unrealized PL in min points in the Chart:

Unrealized PL in currency and in min points can be sent to the application from your add-in or calculated on eSignal side.

Unrealized PL in percent is always calculated on eSignal side by formula:

To get Unrealized (Open) Profit/Loss for position populated in eSignal you can

  • calculate Unrealized PL in the add-in and send values with position data when updating it, or

  • get Unrealized PL calculated using your custom closing price, or

  • get Unrealized PL calculated using Bid and Ask from the Broker's data as closing price, or

  • get Unrealized PL calculated on the application side using Bid and Ask from eSignal's data as closing price.

Better practice is to send Unrealized PL with position data, because the add-in can receive it from broker servers or you can calculate Unrealized PL using the same algorithms and data like in your broker's software. Ideally, users should be able to see equal values for Unrealized PL in broker's software and in eSignal.

The following diagram illustrates possible alternatives depending on the add-in abilities and features:

Sending Unrealized PL with Position Data

If you have ready-to-use Unrealized PL, in order to provide it to the application you need to extend type PositionData by a field with attribute PositionUnrealizedProfitLossAttribute for Unrealized PL in currency and another field with attribute PositionUnrealizedProfitLossInPointsAttribute for Unrealized PL in min points:

C#
C++
Copy
public sealed class SamplePositionData : PositionData
{
    public SamplePositionData(String Id, String Symbol)
        : base(Id, Symbol)
    {
    }

    [PositionUnrealizedProfitLoss]
    public double UnrealizedPL { get; set; }

    [PositionUnrealizedProfitLossInPoints]
    public long UnrealizedPLnPoints { get; set; }
}
public ref class SamplePositionData sealed : PositionData
{
public:

    SamplePositionData(String^ Id, String^ Symbol)
        : PositionData(Id, Symbol)
    {
    }

    [PositionUnrealizedProfitLoss]
    property double UnrealizedPL;

    [PositionUnrealizedProfitLossInPoints]
    property INT64 UnrealizedPLInPoints;
};

Instead of both fields, you can define only the field for Unrealized PL in currency, but Unrealized PL in min points will not have value in this case. Having only Unrealized PL in min points is not an option because eSignal has no information if these fields are strongly associated at the Broker. Strictly speaking, one cannot calculate Unrealized PL in currency from Unrealized PL in min points because of possible commission fees included.

After you defined the fields, you should send position updates to the application using IPluginHostSendPosition(PositionData):

C#
C++
Copy
PluginHost.SendPosition(new SamplePositionData(PositionId, "MSFT")
{
    Account = "DEMO",

    Quantity = 200,

    // Average price must be filled properly for open positions!
    //
    AveragePrice = 10.00,

    UnrealizedPL = 100,

    UnrealizedPLPoints = 50,

    RealizedProfitLoss = 0.00
});
SamplePositionData^ openPositionData = gcnew SamplePositionData(PositionId, Symbol);

openPositionData->Account = "DEMO";

openPositionData->Quantity = 200;

// Average price must be filled properly for open positions!
//
openPositionData->AveragePrice = 10.00;

openPositionData->UnrealizedPL = 100.00;

openPositionData->UnrealizedPLInPoints = 50;

openPositionData->RealizedProfitLoss = 0.00;

PluginHost->SendPosition(openPositionData);
Note Note

If you defined fields with these attributes, but the add-in does not send position updates with their values, Unrealized PL will not be populated anywhere in the application.

Calculating Unrealized PL

eSignal calculates Unrealized PL using the following formulas:

Longs:

UnrealizedPL = (ClosingPrice - AveragePrice) × ǀQtyǀ × LotSize × PointValue

UnrealizedPLInPoints = Round( (ClosingPrice - AveragePrice) / TickSize )

Shorts:

UnrealizedPL = (AveragePrice - ClosingPrice) × ǀQtyǀ × LotSize × PointValue

UnrealizedPLInPoints = Round( (AveragePrice - ClosingPrice) / TickSize ),

where ClosingPrice is a hypothetic price where your position will close (see glossary for details).

Unrealized PL in min points calculated as a difference between Average Price and Closing Price, divided by tick size and rounded to the next tick. For example, if mathematically you are in profit for 10.35 min points, eSignal will round it to 11.

Unrealized PL is updating in eSignal each time when Closing Price updates.

As closing price you can use one of the following:

  • custom closing price calculated by your add-in;

  • broker's Bid and Ask sent by your add-in;

  • eSignal's Bid and Ask.

Calculating Unrealized PL from Custom Closing Price

Custom closing prices are useful if you prefer to use Last, or (Bid + Ask) / 2 or something else instead of just Bid and Ask.

For start using custom closing price you need to extend type PositionData by a field with attribute PositionClosingPriceAttribute:

C#
C++
Copy
public sealed class SamplePositionData : PositionData
{
    public SamplePositionData(String Id, String Symbol)
        : base(Id, Symbol)
    {
    }

    [PositionClosingPrice]
    public double ClosingPrice { get; set; }
}
public ref class SamplePositionData sealed : PositionData
{
public:

    SamplePositionData(String^ Id, String^ Symbol)
        : PositionData(Id, Symbol)
    {
    }

    [PositionClosingPrice]
    property double ClosingPrice;
};

Then, you should send position updates with Closing Price value using IPluginHostSendPosition(PositionData) each time when Unrealized PL needs to be updated:

C#
C++
Copy
PluginHost.SendPosition(new SamplePositionData(PositionId, "MSFT")
{
    Account = "DEMO",

    Quantity = 200,

    // Average price must be filled properly for open positions!
    //
    AveragePrice = 10.00,

    RealizedProfitLoss = 0.00,

    ClosingPrice = 10.50
});
SamplePositionData^ openPositionData = gcnew SamplePositionData(PositionId, Symbol);

openPositionData->Account = "DEMO";

openPositionData->Quantity = 200;

// Average price must be filled properly for open positions!
//
openPositionData->AveragePrice = 10.00;

openPositionData->RealizedProfitLoss = 0.00;

openPositionData->ClosingPrice = 10.50;

PluginHost->SendPosition(openPositionData);
Note Note

If you defined a field with PositionClosingPriceAttribute, but the add-in does not send position updates with Closing Price value, Unrealized PL will not be populated anywhere in the application.

Important note Important

If you want to send custom closing prices, you should not have fields with attributes PositionUnrealizedProfitLossAttribute and PositionUnrealizedProfitLossInPointsAttribute defined in your add-in, because in this case the application will be awaiting for Unrealized PL coming from your side.

Calculating Unrealized PL from Broker's Bid and Ask

If your add-in provides Quote data and does not provide Unrealized PL and custom Closing Price, the application will calculate Unrealized PL using your Quote data. It will use Bid as closing price for Longs and Ask for Shorts.

Longs:

UnrealizedPL = (Bid - AveragePrice) × ǀQtyǀ × LotSize × PointValue

UnrealizedPLInPoints = Round( (Bid - AveragePrice) / TickSize )

Shorts:

UnrealizedPL = (AveragePrice - Ask) × ǀQtyǀ × LotSize × PointValue

UnrealizedPLInPoints = Round( (AveragePrice - Ask) / TickSize )

For this option you must handle quote requests from the application and send quote updates (see Subscribing Market Data for details).

Important note Important

If you want to use Bid and Ask as closing price, you should not have fields with attributes PositionUnrealizedProfitLossAttribute, PositionUnrealizedProfitLossInPointsAttribute and PositionClosingPriceAttribute defined in your add-in, because in this case the application will be awaiting for the corresponding values coming from your side.

Calculating Unrealized PL from eSignal's Bid and Ask

If your add-in does not provide Unrealized PL, custom Closing Price and Quote data, the application will calculate Unrealized PL using eSignal's Bid and Ask.

Longs:

UnrealizedPL = (Bid - AveragePrice) × ǀQtyǀ × LotSize × PointValue

UnrealizedPLInPoints = Round( (Bid - AveragePrice) / TickSize )

Shorts:

UnrealizedPL = (AveragePrice - Ask) × ǀQtyǀ × LotSize × PointValue

UnrealizedPLInPoints = Round( (AveragePrice - Ask) / TickSize )

For this option you must set PluginAttributeDataStreamingSupported property to false, otherwise the application will be expecting Quote data from the add-in (see Subscribing Market Data for detailed instructions). For example,

C#
C++
Copy
namespace CSharpSamplePlugin
{
    // This attribute marks add-in implementation and sets values of some additional properties.
    //
    [Plugin(DataStreamingSupported = false)]

    public sealed class CSharpSamplePlugin : IPlugin
    {
        ...
    }
}
namespace CppCLISamplePlugin
{
    // This attribute marks add-in implementation and sets values of some additional properties.
    //
    [Plugin(DataStreamingSupported = false)]

    public ref class CppCLISamplePlugin
        : InteractiveData::eSignalDesktop::Trading::IPlugin
    {
        ...
    };
}

After this eSignal knows that you do not have the Broker's data and it will use its own data to calculate Unrealized PL for the add-in.

Important note Important

If you want to use Bid and Ask as closing price, you should not have fields with attributes PositionUnrealizedProfitLossAttribute, PositionUnrealizedProfitLossInPointsAttribute and PositionClosingPriceAttribute defined in your add-in, because in this case the application will be awaiting for the corresponding values coming from your side.

See Also

Other Resources

Extending Built-In Types
Subscribing Market Data


Breaking When a Trading Exception is Thrown

Breaking When a Trading Exception is Thrown

This topic explains how to break execution of your trading plug-in when trading exception is thrown.

The debugger can break execution of your application immediately when an exception occurs, giving you a chance to debug the exception.

To add a Trading exception to the Exceptions dialog box:

  1. Go to Exceptions dialog box.

    Exceptions Menu Item

  2. Click Add button, New Exception dialog box will appear.

  3. Enter InteractiveData.eSignalDesktop.Trading.Exceptions.ObjectFieldValidationException into Name box.

  4. Select Common Language Runtime Exceptions in Type box and click OK button.

  5. Repeat previous step for InteractiveData.eSignalDesktop.Trading.Exceptions.SupportedOrderTypesValidationException and InteractiveData.eSignalDesktop.Trading.Exceptions.AddInLoaderException if needed.

  6. Select Thrown for InteractiveData.eSignalDesktop.Trading.Exceptions.Exception and click OK button.

Now you can debug trading exception and see the exception message in Exception Assistant.

Code Sample With Exception
See Also

Reference

ObjectFieldValidationException
SupportedOrderTypesValidationException
AddInLoaderException


Debugging Plug-in

Debugging Plug-in

This topic explains how to debug your trading plug-in.

You can debug your trading plug-in in two ways:

  • Using TestRunner.exe provided with this API.

  • Within esignaltradinghost.exe process that is used by eSignal Desktop Application as a container for running third party plug-ins.

To debug without eSignal Desktop Application:

  1. Right-click on your plug-in project in Solution Explorer.

  2. Click on Properties item.

  3. Go to Debug property sheet.

  4. Check Start external program under Start Action.

  5. Choose location of TestRunner.exe in Start external program under Start Action. Default location of TestRunner.exe is 'C:\Users\Public\Documents\Interactive Data\eSignal Desktop Trading Plug-in SDK\Bin\TestRunner.exe'.

    Start External Process

  6. Right-click on your plug-in project in Solution Explorer and select Set as StartUp project.

Now you can develop your plug-in without using heavyweight eSignal Desktop Application.

To debug with eSignal Desktop Application:

  1. Launch eSignal Desktop Application and connect your plug-in in Broker Manager. Unload other plug-ins.

  2. Switch back to Visual Studio. Select Tools and then Attach to process item.

  3. Find esignaltradinghost.exe in Attach to Process dialog and click Attach button.

    Attach to Process

Now you can debug your plug-in while working in the real eSignal environment.

A first approach is more suitable for an active plug-in development phase. Use second approach for the final phase to debug complex bugs.

See Also

Other Resources

Broker Manager
How to: Launch the Debugger Automatically


Placing Orders

Placing Orders

This article describes the process of placing orders in the plug-in and the structures involved in that process.

This topic contains the following sections.

  • Process of Placing Orders
  • OrderData Type, Extending OrderData Type
  • Order Types
  • Order Defaults and Inputs
  • Order Ticket
  • Placing Orders
  • Updating Orders and Order States
  • Placing Orders on Hedging Accounts
Process of Placing Orders
OrderData Type, Extending OrderData Type

Before placing orders an appropriate data structure describing them must be created in the plug-in. OrderData type is a built-in type describing Order.

Important note Important

Notice, that your add-in must contain an entity inherited from OrderData. Otherwise the add-in will not be loaded into the application.

OrderData type contains a set of standard fields that exist for any order and cannot be omitted. Each standard field is also present in the Order Ticket UI and as a column in Account Manager. All appropriate values are populated by these fields and should not be duplicated.

See OrderData for properties that are mandatory fields for any order in the system. The following table describes optional standard fields that can be designated for orders.

Additional Standard Order Fields
Attribute | Description
OrderExpiryAttribute | Designates order expiration field (time-in-force).
OrderGoodTillDateAttribute | Designates date of order expiry field in case of using "Good Till Date" or similar expiration type.
OrderTimeAttribute | Designates time field of an order entry or modification. Time must be in UTC.
OrderPositionIdAttribute | Marks a field with the position id. Valid and necessary for positions opened on accounts which allow hedging.

You can extend this type by inheriting from it and adding optional standard fields or/and custom broker-specific fields. Optional standard fields should be specified with appropriate existing attribute, while for custom fields you should create custom attributes.

C#
Copy
public sealed class SampleOrderData : OrderData
{
    public SampleOrderData(String Id, String Symbol)
        : base(Id, Symbol)
    {
    }

    //
    // Add declarations for some standard fields to make them available.
    //

    [OrderGoodTillDate]
    public DateTime? GoodTillDate { get; set; }

    [OrderExpiry]
    public OrderExpiry Expiry { get; set; }

    //
    // Add declarations for some custom fields  to make them available.
    //

    [CustomField("custom-string-id", "Custom String")]
    public string CustomString { get; set; }

    [CustomField("custom-int-id", "Custom Integer Field")]
    public int CustomInt { get; set; }

    [CustomField("custom-double-id", "Custom Double Field")]
    public double CustomDouble { get; set; }

    [CustomField("custom-datetime-id", "Custom DateTime Field", Format = FormatType.Date)]
    public DateTime? CustomDateTime { get; set; }
}
Order Types

There are 4 standard order types introduced in StandardOrderType enumeration: Market, Limit, Stop, StopLimit. If your broker does not support any non-standard order types, and there is no need in changing their names (i.e. "Market" is acceptable for naming market orders, "StopLimit" for stop-limit orders and so forth), you can declare them as shown in the following example. Note, that if there are some order types, that your broker does not support, you need to omit the declarations for such order types. StopLimit order type declaration has been omitted in the example:

C#
Copy
public OrderTypeDeclaration[] GetSupportedOrderTypes =
{
    new OrderTypeDeclaration(StandardOrderType.Market),
    new OrderTypeDeclaration(StandardOrderType.Limit),
    new OrderTypeDeclaration(StandardOrderType.Stop)
};

It is also possible to change the displayed names of the standard and create custom order types.

C#
Copy
// Declare enumeration that will be used for the plugin's order types.
//
internal enum MySupportedOrderTypes
{
    Market,
    Limit,
    Stop,
    StopLimit,
    TrailingStop,
    MarketIfTouched,
    LimitIfTouched
}

public OrderTypeDeclaration[] GetSupportedOrderTypes()
{
    return new []
    {
        // You can customize any order's value by which it is referenced.
        //
        new OrderTypeDeclaration(StandardOrderType.Market, new OrderType(MySupportedOrderTypes.Market)),
        new OrderTypeDeclaration(StandardOrderType.Limit, new OrderType(MySupportedOrderTypes.Limit)),

        // You can customize any order's display name and value by which it is referenced.
        //
        new OrderTypeDeclaration(StandardOrderType.Stop, "STP", new OrderType(MySupportedOrderTypes.Stop)),
        new OrderTypeDeclaration(StandardOrderType.StopLimit, "STP-LMT", new OrderType(MySupportedOrderTypes.StopLimit)),

        // You can declare custom order type, and assign a reference value of 'MySupportedOrderTypes.TrailingStop' to it.
        //
        new OrderTypeDeclaration("Trailing Stop", new OrderType(MySupportedOrderTypes.TrailingStop))
    };
}
Order Defaults and Inputs

Use OrderInputsAttribute to specify the fields which you want to be available in Order Ticket dialog. You may list any additional standard or custom attributes that you defined in your own OrderData type.

Use OrderDefaultsAttribute to specify the fields which you want be available in Order Defaults dialog.

Note Note

Notice, that all fields available for user's input must be also available in Order Defaults. This must be done in order to be able to place orders without confirmations, that is without popping up Order Ticket dialog. MMS orders are always placed this way. In such case for any missing parameters Order Defaults are used for the order.

C#
Copy
[OrderInputs(
    OrderExpiryAttribute.Id,
    GoodTillDate.Id)]
[OrderDefaults(OrderExpiryAttribute.Id)]
public sealed class SampleOrderData : OrderData
{
// Proper orderdata class here
}
Order Ticket

Order Ticket is a dialog which will appear if user selects New Order from the Trade menu, clicks one of the trade buttons in Chart or Trade Manager windows, or selects one of the trade options from the right-click menu. The Order Ticket can also be considered as the Order Confirmation window which allows verification of orders before they are submitted. In API an abstraction of the Order Ticket exists: IOrderTicket. It represents a dialog and its controls (and their respective values) that can be enabled, disabled or their possible values can be modified based on custom add-in logic.

UpdateControls(IOrderTicket) method is called each time update of Order Ticket is necessary, that is Order Ticket dialog has been opened or any of its controls or values has been changed. An instance of Order Ticket is passed as a parameter to this method.

Order Ticket dialog is provided with two possible types of controls:

  1. Drop-down control which contains a limited number of values available for the user's selection. These controls can be accessed through appropriate interfaces:

    Drop-down Controls Interfaces

    Interface Name

    Description

    ITextControl Interface

    Gives access to account or position field.

    IOrderActionControl Interface

    Gives access to action field (Buy/Sell/Sell Short/Buy To Cover).

    IOrderExpiryControl Interface

    Gives access to order expiry field.

    IOrderTypeControl Interface

    Gives access to order type field.

    Such type of control has a Domain property (e.g. Domain) which can be set to an array of an appropriate type and updated when necessary.

    C#
    Copy
    // Return different set of time in force depending on order type
private static OrderExpiry[] ExpiryDomain(IOrderTicket orderTicket)
{
    // For Market orders:
    if ((StandardOrderType)orderTicket.Type.Value.Value == StandardOrderType.Market)
    {
        return new[]
        {
            OrderExpiry.GoodTillCancel,
            OrderExpiry.DayOrder,
            OrderExpiry.FillOrKill,
            OrderExpiry.ImmediateOrCancel
        };
    }
    // For all other order types:
    return new[]
    {
        OrderExpiry.GoodTillCancel,
        OrderExpiry.DayOrder
    };
}

    You can read values from these controls through Value property (e.g. Value)

  2. Input control which contains one value of appropriate type. You can access these controls through appropriate interfaces:

    Input Controls Interfaces

    Interface Name

    Description

    IDateTimeControl Interface

    Gives access to good till date field.

    IPriceControl Interface

    Gives access to limit and stop price field.

    IIntegerNumberControl Interface

    Gives access to quantity field.

    Such type of control has a Value property only (e.g. Value), from which you can read values input in the appropriate controls.

All these interfaces are inherited from the IOrderTicketControl Interface, which means its properties are also available for usage.

You can create custom controls using GetCustomControl(String) method.

C#
Copy
// Add custom field name, which will be used for a custom control
//
internal struct AdditionalOrderFields
{
    public const String CustomString = "custom-string-id";
}

// You should make this control available in order ticket by listing it in OrderInputs attribute
//
[OrderInputs
(
    AdditionalOrderFields.CustomString
)]
public sealed class SampleOrderData : OrderData
{
    public SampleOrderData(String Id, String Symbol)
        : base(Id, Symbol)
    {
    }
    // This control should be declared in your OrderData type
    [CustomField(AdditionalOrderFields.CustomString, "Custom String")]
    public string CustomString { get; set; }
}

public void UpdateControls(IOrderTicket orderTicket)
{
    // Proper implementation of method omitted
    //
    // Custom control can be added and updated here
    var customStringControl = (ITextControl) orderTicket.GetCustomControl(AdditionalOrderFields.CustomString);
    customStringControl.IsReadonly = true;
}

Order Ticket updates must be properly implemented in UpdateControls(IOrderTicket) method:

  • Limit Price control must become unavailable if the selected order type does not allow limit price.

  • Stop Price control must become unavailable if the selected order type does not allow stop price.

  • All associated controls must become available or unavailable depending on the selected values.

  • Only valid values must be available in drop-down controls.

  • When modifying (replacing) order, controls which are restricted for modification must become unavailable.

Placing Orders

PlaceOrder(OrderData, IMethodRequest) method is called whenever order request comes into the add-in. Along with OrderData object which contains parameters of a new order, IMethodRequest object is passed. It is used for the unique identification of the order until a unique Id is asigned to that order, and for reporting back the result of placing operation. Until IMethodRequest is called new order is displayed in eSignal grayed out with a status 'Placing'.

If the placing operation has failed (e.g. Broker rejected the order), plug-in should call IMethodRequest.Failed(System.String) method with error message as an argument.

If the placing operation has succeeded (e.g. Broker accepted the order), plug-in should call IMethodRequest.Succeeded(System.String) method with the identifier of the new order.

Important note Important

The identifier of the order passed with IMethodRequest.Succeeded(System.String) method is used for the identification of the order between plug-in and application. It is supposed to be for internal use only and must be unique throughout the connection.

OrderData has a BrokerID property, which may or may not be equal to the above mentioned identifier at your decision. BrokerID is displayed in eSignal application for the user to be able to reference the order in communication with the broker. There is no restrictions on the uniqueness of this identifier.

You can use IMethodRequest.Succeeded(System.String) before you receive response from the broker and give order state 'Queue'. However, in this case it is also the responsibility of the plug-in to create a unique identifier and pass it as a parameter of this method.

Updating Orders and Order States

Order updates should be made through SendOrder(OrderData) method. If the order was partially or completely filled FilledQuantity must be updated to an appropriate value. At the same time with each fill of the order, AveragePrice of the order must be updated accordingly.

A proper state should be provided when the plug-in sends OrderData to the application. Use SendOrder(OrderData) with updated OrderData, containing appropriate State. Do not provide state when placing order with PlaceOrder(OrderData, IMethodRequest).

There are 5 standard order states introduced in OrderState enumeration: Queue, Working, Rejected, Canceled, Filled.

'Placing' state can be seen in the eSignal application for an order which has been accepted by the plug-in, but which has not been yet notifyed as approved. That is success of placing order has not been yet confirmed by calling IMethodRequest.Succeeded(System.String) method.

You can not create create custom order states, but a custom state name can be displayed in eSignal UI. Use StateText property for that purpose. If not set, it coincides with order state name from State property.

All possible valid transitions of order state updates can be found in the table below. Any other transitions are invalid.

Order State Valid Transitions
Current State | Updated State
Queue | Working
Queue | Rejected
Working | Filled
Working | Canceled
Working | Rejected

When the order is partially or completely filled an update on a position must be sent using SendPosition(PositionData) method.

Placing Orders on Hedging Accounts

Using this trading API your plug-in can implement support for hedging accounts. Such accounts are considered not to follow NFA Compliance Rule 2-43(b), so it would be possible to close individual positions on such accounts. To enable hedging on an account set AllowHedging property to True. Use PositionDisplayedIdAttribute to mark position identifier. For hedging accounts this identifier will be shown in Order Ticket 'Position Id' combobox and thus can be used by user as a reference for closing specific positions.


Glossary

Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Account Manager

A window in eSignal where you can find information about accounts, orders, position, execution reports and service messages from connected add-ins. See eSignal Knowledge Base for more information.

B

Broker Manager

The Broker Manager is the central hub for all the broker plug-ins. Each broker plug-in is configured individually through the Broker Manager. Here you can set up your add-in and configure its symbol dictionary and Order Defaults.

See Also: Order Defaults

C

Chart Trading

It is possible to conveniently place trades directly from the chart window using Chart Trading panel. See eSignal Knowledge Base for more information.

Closing Price

A hypothetic price where your position will close. It is used in Unrealized P/L calculations:

Long: UnrealizedPL = (ClosingPrice - AveragePrice) × ǀQtyǀ × LotSize × PointValue

Short: UnrealizedPL = (AveragePrice - ClosingPrice) × ǀQtyǀ × LotSize × PointValue

In eSignal, Closing Price is Bid for a long position and Ask for a short position. You can define a property with attribute PositionClosingPriceAttribute in PositionData and send this value to eSignal within position info. In this case the application will calculate Unrealized P/L using your closing price.

Connection Settings

Connection Settings dialog is a window for displaying and editing connection settings for a particular broker connection. The dialog appears when a user selects Connection Settings in the Broker Manager window.

D

Domain

A list of possible values of a field (typically, of order field). Used primarily when dealing with possible control values in UpdateControls(IOrderTicket) method override.

E

Entitlement Bit

A codename that permits usage of a feature. Issued by eSignal. Must be specified via EntitlementBit and is used to control usage of the add-in.

I

Add-In Identifier, ID

A codename that identifies an add-in. Usually consists of capital letters and is at maximum 5-10 characters long. Issued by eSignal and must be specified via manifest file.

Integrated Trading

Trading through integrated trading plugins of eSignal partners. An overview of the Integrated Trading components and features can be found in this eSignal Knowledge Base article.

L

Lookup, Lookup Dialog, Symbol Lookup, Symbol Lookup Dialog

Symbol Lookup Dialog allows you to find symbol. Usually it provides available lists of exchanges, contract types and other contract parameters to help user to find desired symbol.

You can open this dialog from the Add/Edit Symbol dialog.

M

Add-In Manifest File, Manifest File

An XML file which has .manifest extension. Typically, the file name matches your add-in executable module file name. For example: if your executable module name is StockBrokerAddin.dll, manifest file name could be StockBrokerAddin.manifest.

A typical structure of manifest file is as the following:

Copy
      <?xml version="1.0" encoding="utf-8"?>
  <Plugin Id="STOCKBROKER" Name="Stock Broker">
    <Path>StockBrokerAddin.dll</Path>
</Plugin>
Money Management

Feature that in combination with the Trade Manager and Chart Trading allows traders to apply predefined, sophisticated, and automated money management strategies to a position when it is opened. See eSignal Knowledge Base for more information.

O

Order Confirmation

The Order Ticket is considered the confirmation before an order is executed. The confirmation prompt can be disabled in Application Properties. Click Trade, Trade Settings; remove the check from the box for Confirm Order Before Submitting.

Defaults, Order Defaults

A list of order fields that should be stored as pre-defined order settings. Defined with help of OrderDefaultsAttribute attribute applied to own OrderData implementation.

All the listed fields (plus some standard) will be available for modification and further storing in a form of the following dialog:

Inputs, Order Inputs

A list of order fields that should be available when placing an order via order ticket. Defined with help of OrderInputsAttribute attribute applied to own OrderData implementation.

Order Ticket

A dialog that is used for creating new or modifying existing order. There's an abstraction for it in the API: IOrderTicket. It represents a dialog with controls (and their respective values) that can be enabled, disabled or their possible values can be modified based on custom add-in logic.

R

Realized PL, Realized Profit/Loss

A profit or loss that exists for a closed position. Unrealized PL becomes realized once the position is closed for a profit or loss. Realized PL is one of default properties of PositionData and you should send it to the application within position info.

T

Trade Manager

Trade Manager is a trading window in eSignal application that enables user to quickly place or modify orders with a single mouse click while viewing real-time market depth on a DOM (Depth of Market) display. See eSignal Knowledge Base for more information.

U

Open PL, Open Profit/Loss, Unrealized PL, Unrealized Profit/Loss

A hypothetic profit or loss that exists for an opened position. Unrealized PL is calculated from formulas:

Long: UnrealizedPL = (ClosingPrice - AveragePrice) × ǀQtyǀ × LotSize × PointValue

Short: UnrealizedPL = (AveragePrice - ClosingPrice) × ǀQtyǀ × LotSize × PointValue

Built-in type PositionData can be extended with Unrealized PL fields with attributes PositionUnrealizedProfitLossAttribute and PositionUnrealizedProfitLossInPointsAttribute. You should these values to eSignal within position info and the application will display your values of Unrealized PL in currency and in points.


Reference

Reference
Namespaces
Namespace | Description
InteractiveData.eSignalDesktop.Trading |
InteractiveData.eSignalDesktop.Trading.Attributes |
InteractiveData.eSignalDesktop.Trading.Exceptions |


InteractiveData.eSignalDesktop.Trading Namespace

InteractiveData.eSignalDesktop.Trading Namespace
Classes
 | Class | Description
Public class | AccountData | Designates account data structure.
Public class | ConnectionSettings | Base class for implementing connection settings for add-in. Inherit and extend with properties. The class is capable of serializing and deserializing its public get/set properties.
Public class | ConnectionStateData | Structure used for passing connection state.
Public class | ExecutionData | Designates execution data structure.
Public class | MarketDepthData | Structure for providing 'depth of market' data.
Public class | MessageData | Designates message data structure.
Public class | OrderData | Designates order data structure.
Public class | OrderTypeDeclaration | Describes single order type supported by the broker.
Public class | PluginHostExtensions | Class contains extensions of some IPluginHost methods for processing multiple objects in one command.
Public class | PositionData | Designates position data structure.
Public class | QuoteData | Represents quote data (or 'daily data') to be provided by the add-in.
Public class | SymbolBasedData | Base class that is inherited by symbol data based classes.
Public class | SymbolData | Designates symbol data structure.
Structures
 | Structure | Description
Public structure | MarketDepthDataEntry | Represents single ladder level.
Public structure | OrderType | Specifies order type.
Public structure | SpreadLeg | Contains properties of legs for spead symbols.
Interfaces
 | Interface | Description
Public interface | IConnectionSettingsPage | Custom connection settings page creator.
Public interface | IDateTimeControl | Gives access to good till date field. Should be used inside of IOrderTicket interface.
Public interface | IESignalSymbol | Extended symbol information.
Public interface | IInputSymbol | Represents symbol entered by user.
Public interface | IIntegerNumberControl | Gives access to quantity field. Should be used inside of IOrderTicket interface.
Public interface | IMethodRequest | Object for reporting back operation result.
Public interface | IOrderActionControl | Gives access to action field (Buy/Sell/Sell Short/Buy To Cover). Should be used inside of IOrderTicket interface.
Public interface | IOrderExpiryControl | Gives access to order expiry field. Should be used inside of IOrderTicket interface.
Public interface | IOrderTicket | Represents order ticket window. See glossary article Order Ticket for more details.
Public interface | IOrderTicketControl | Gives access to custom fields in Order Ticket defined by the add-in. Should be used inside of IOrderTicket interface.
Public interface | IOrderTypeControl | Gives access to order type field. Should be used inside of IOrderTicket interface.
Public interface | IPlugin | Main interface of the add-in.
Public interface | IPluginHost | Interface for communication between eSignal and add-in.
Public interface | IPriceControl | Gives access to limit and stop price field. Should be used inside of IOrderTicket interface.
Public interface | ISettingsPage | Base interface for creating settings pages, such as Symbol Lookup dialog, Connection Settings dialog.
Public interface | ISymbolLookupPage | Custom connection settings page creator.
Public interface | ITextControl | Gives access to account or position field. Should be used inside of IOrderTicket interface.
Delegates
 | Delegate | Description
Public delegate | PumpMessagesEventHandler |
Public delegate | SymbolEventHandler |
Enumerations
 | Enumeration | Description
Public enumeration | ConnectionEnvironment | Designates either Demo or Live environment. Used for distinction between simulated and real environments.
Public enumeration | ConnectionState | Represents plug-in connection state.
Public enumeration | Currency | List of currencies available in eSignal Desktop.
Public enumeration | Exchange | List of available exchanges.
Public enumeration | OrderAction | Represents action of an order.
Public enumeration | OrderExpiry | Represents order expiration types (time-in-force).
Public enumeration | OrderState | Represents state of an order.
Public enumeration | OrderTicketMode | A mode that the order ticket can be in.
Public enumeration | StandardOrderType | Enumeration representing standard order types.
Public enumeration | SymbolOptionPutCall | Enumeration of available options types.
Public enumeration | SymbolPriceType | Enumeration of all the symbol price formatting methods available.
Public enumeration | SymbolType | Enumeration of all the symbol types that eSignal supports.


AccountData Class

AccountData Class
Designates account data structure.
Inheritance Hierarchy
SystemObject
RecordData
InteractiveData.eSignalDesktop.TradingAccountData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public class AccountData : RecordData
public ref class AccountData : public RecordData

The AccountData type exposes the following members.

Constructors
 | Name | Description
Public method | AccountData | Initializes a new instance of the AccountData class.
Top
Properties
 | Name | Description
Public property | AllowHedging | Marks an account which allows hedging on it. False by default.
Public property | Balance | Active balance of the account.
Public property | Currency | Currency in which the balance of the account is expressed.
Top
Remarks

In eSignal Desktop application information on Accounts is displayed in the Account Manager window, in the 'Accounts' tab.

Account must be specified for all orders, executions, positions.
See Also

Reference

InteractiveData.eSignalDesktop.Trading Namespace


AccountData Constructor

AccountData Constructor
Initializes a new instance of the AccountData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public AccountData(
    string id
)
public:
AccountData(
    String^ id
)

Parameters

id
Type: SystemString
Identifier that is used in the application to recognize the account.

This identifire is displayed in 'Account ID' column.

See Also

Reference

AccountData Class


AccountData Properties

AccountData Properties

The AccountData type exposes the following members.

Properties
 | Name | Description
Public property | AllowHedging | Marks an account which allows hedging on it. False by default.
Public property | Balance | Active balance of the account.
Public property | Currency | Currency in which the balance of the account is expressed.
Top
See Also

Reference

AccountData Class


AccountData.AllowHedging Property

AccountDataAllowHedging Property
Marks an account which allows hedging on it. False by default.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool AllowHedging { get; set; }
public:
property bool AllowHedging {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

Set this field to True for those accounts which allow hedging. Such accounts will allow sending multiple positions on the same symbol, including in opposite directions. This would also set necessary limitations on the behavior of eSignal application, such as: MMS orders shall be prohibited on such accounts. For each account that allows hedging OrderPositionIdAttribute attribute is to be used for positions on that account, to be able distinguish which positions must be closed.

See Also

Reference

AccountData Class


AccountData.Balance Property

AccountDataBalance Property
Active balance of the account.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public double Balance { get; set; }
public:
property double Balance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AccountData Class


AccountData.Currency Property

AccountDataCurrency Property
Currency in which the balance of the account is expressed.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<Currency> Currency { get; set; }
public:
property Nullable<Currency> Currency {
    Nullable<Currency> get ();
    void set (Nullable<Currency> value);
}

Property Value

Type: Nullable Currency
See Also

Reference

AccountData Class


ConnectionEnvironment Enumeration

ConnectionEnvironment Enumeration
Designates either Demo or Live environment. Used for distinction between simulated and real environments.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum ConnectionEnvironment
public enum class ConnectionEnvironment
Members
Member name | Value | Description
Demo | 0 | DEMO environment, no trading for real money.
Live | 1 | LIVE environment, trading for real money is supposed.
See Also

Reference


ConnectionSettings Class

ConnectionSettings Class
Base class for implementing connection settings for add-in. Inherit and extend with properties.

The class is capable of serializing and deserializing its public get/set properties.

Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.TradingConnectionSettings

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public abstract class ConnectionSettings
public ref class ConnectionSettings abstract

The ConnectionSettings type exposes the following members.

Constructors
 | Name | Description
Protected method | ConnectionSettings | Initializes a new instance of the ConnectionSettings class
Top
See Also

Reference


ConnectionSettings Constructor

ConnectionSettings Constructor
Initializes a new instance of the ConnectionSettings class

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
protected ConnectionSettings()
protected:
ConnectionSettings()
See Also

Reference

ConnectionSettings Class


ConnectionState Enumeration

ConnectionState Enumeration
Represents plug-in connection state.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum ConnectionState
public enum class ConnectionState
Members
Member name | Value | Description
InternalError | 0 | Unrecoverable error.
Reconnecting | 1 | Designates that the plug-in wants to be automatically reconnected shortly.
Blocked | 2 | Connection or environment settings block the plug-in from establishing the connection.
Disconnected | 3 | Plug-in is disconnected. Typically is a response to Disconnect call.
Connecting | 4 | Plug-in is in the process of establishing a connection. Typically is a response to Connect(ConnectionSettings) call.
Connected | 5 | Plug-in is connected. Typically a response to establishing a connection over the network.
See Also

Reference


ConnectionStateData Class

ConnectionStateData Class
Structure used for passing connection state.
Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.TradingConnectionStateData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class ConnectionStateData : IRecordData
public ref class ConnectionStateData sealed : IRecordData

The ConnectionStateData type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStateData(ConnectionState) | Initializes a new instance of ConnectionStateData class. Note that the class is initialized with ConnectionEvironment set to Demo.
Public method | ConnectionStateData(ConnectionState, ConnectionEnvironment) | Initializes a new instance of ConnectionStateData class.
Public method | ConnectionStateData(ConnectionState, String) | Initializes a new instance of ConnectionStateData class. Note that the class is initialized with ConnectionEvironment set to Live.
Public method | ConnectionStateData(ConnectionState, String, ConnectionEnvironment) | Initializes a new instance of ConnectionStateData class.
Top
Properties
 | Name | Description
Public property | Broker | Represents actual broker name that is being currently accessed via this add-in in this particular session.
Public property | DataStreamingSupported | Indicates whether the connection supports data streaming or not. 'Data streaming' includes daily quotes and market depth data.
Public property | Environment | Indicates whether the connection is in DEMO or LIVE mode, i.e. allowing to trade for real money or not.
Public property | Id | Identifier that is used in the application to recognize the connection.
Public property | State | New state of the connection.
Public property | StateText | Optional state comment.
Public property | StrategiesCanOnlyApply | Sets limitations on the usage of the Money Management system by the plugin.
Top
See Also

Reference


ConnectionStateData Constructor

ConnectionStateData Constructor
Overload List
 | Name | Description
Public method | ConnectionStateData(ConnectionState) | Initializes a new instance of ConnectionStateData class. Note that the class is initialized with ConnectionEvironment set to Demo.
Public method | ConnectionStateData(ConnectionState, ConnectionEnvironment) | Initializes a new instance of ConnectionStateData class.
Public method | ConnectionStateData(ConnectionState, String) | Initializes a new instance of ConnectionStateData class. Note that the class is initialized with ConnectionEvironment set to Live.
Public method | ConnectionStateData(ConnectionState, String, ConnectionEnvironment) | Initializes a new instance of ConnectionStateData class.
Top
See Also

Reference

ConnectionStateData Class


ConnectionStateData Constructor (ConnectionState)

ConnectionStateData Constructor (ConnectionState)
Initializes a new instance of ConnectionStateData class. Note that the class is initialized with ConnectionEvironment set to Demo.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public ConnectionStateData(
    ConnectionState state
)
public:
ConnectionStateData(
    ConnectionState state
)

Parameters

state
Type: InteractiveData.eSignalDesktop.TradingConnectionState
See Also

Reference

ConnectionStateData Class
ConnectionStateData Overload


ConnectionStateData Constructor (ConnectionState, ConnectionEnvironment)

ConnectionStateData Constructor (ConnectionState, ConnectionEnvironment)
Initializes a new instance of ConnectionStateData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public ConnectionStateData(
    ConnectionState state,
    ConnectionEnvironment environment
)
public:
ConnectionStateData(
    ConnectionState state,
    ConnectionEnvironment environment
)

Parameters

state
Type: InteractiveData.eSignalDesktop.TradingConnectionState
New state of the connection.
environment
Type: InteractiveData.eSignalDesktop.TradingConnectionEnvironment
Environment of the connection.
See Also

Reference

ConnectionStateData Class
ConnectionStateData Overload


ConnectionStateData Constructor (ConnectionState, String)

ConnectionStateData Constructor (ConnectionState, String)
Initializes a new instance of ConnectionStateData class. Note that the class is initialized with ConnectionEvironment set to Live.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public ConnectionStateData(
    ConnectionState state,
    string text
)
public:
ConnectionStateData(
    ConnectionState state,
    String^ text
)

Parameters

state
Type: InteractiveData.eSignalDesktop.TradingConnectionState
New state of the connection.
text
Type: SystemString
Some commentary on the state to be dislayed in Broker Manager, Connection tab of your add-in.
See Also

Reference

ConnectionStateData Class
ConnectionStateData Overload


ConnectionStateData Constructor (ConnectionState, String, ConnectionEnvironment)

ConnectionStateData Constructor (ConnectionState, String, ConnectionEnvironment)
Initializes a new instance of ConnectionStateData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public ConnectionStateData(
    ConnectionState state,
    string text,
    ConnectionEnvironment environment
)
public:
ConnectionStateData(
    ConnectionState state,
    String^ text,
    ConnectionEnvironment environment
)

Parameters

state
Type: InteractiveData.eSignalDesktop.TradingConnectionState
New state of the connection.
text
Type: SystemString
Some commentary on the state to be dislayed in Broker Manager, Connection tab of your add-in.
environment
Type: InteractiveData.eSignalDesktop.TradingConnectionEnvironment
Environment of the connection.
See Also

Reference

ConnectionStateData Class
ConnectionStateData Overload


ConnectionStateData Properties

ConnectionStateData Properties

The ConnectionStateData type exposes the following members.

Properties
 | Name | Description
Public property | Broker | Represents actual broker name that is being currently accessed via this add-in in this particular session.
Public property | DataStreamingSupported | Indicates whether the connection supports data streaming or not. 'Data streaming' includes daily quotes and market depth data.
Public property | Environment | Indicates whether the connection is in DEMO or LIVE mode, i.e. allowing to trade for real money or not.
Public property | Id | Identifier that is used in the application to recognize the connection.
Public property | State | New state of the connection.
Public property | StateText | Optional state comment.
Public property | StrategiesCanOnlyApply | Sets limitations on the usage of the Money Management system by the plugin.
Top
See Also

Reference

ConnectionStateData Class


ConnectionStateData.Broker Property

ConnectionStateDataBroker Property
Represents actual broker name that is being currently accessed via this add-in in this particular session.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Broker { get; set; }
public:
property String^ Broker {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
If available, this information must be specified only when reporting 'Connected' state of the connection.
See Also

Reference

ConnectionStateData Class


ConnectionStateData.DataStreamingSupported Property

ConnectionStateDataDataStreamingSupported Property
Indicates whether the connection supports data streaming or not. 'Data streaming' includes daily quotes and market depth data.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<bool> DataStreamingSupported { get; set; }
public:
property Nullable<bool> DataStreamingSupported {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable Boolean
Remarks
If available, this information must be specified only when reporting 'Connected' state of the connection. Note, that you can use this property only if DataStreamingSupported attribute is set to true.
See Also

Reference

ConnectionStateData Class


ConnectionStateData.Environment Property

ConnectionStateDataEnvironment Property
Indicates whether the connection is in DEMO or LIVE mode, i.e. allowing to trade for real money or not.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public ConnectionEnvironment Environment { get; set; }
public:
property ConnectionEnvironment Environment {
    ConnectionEnvironment get ();
    void set (ConnectionEnvironment value);
}

Property Value

Type: ConnectionEnvironment
Remarks
If available, this information must be specified only when reporting 'Connected' state of the connection.
See Also

Reference

ConnectionStateData Class


ConnectionStateData.Id Property

ConnectionStateDataId Property
Identifier that is used in the application to recognize the connection.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
See Also

Reference

ConnectionStateData Class


ConnectionStateData.State Property

ConnectionStateDataState Property
New state of the connection.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public ConnectionState State { get; set; }
public:
property ConnectionState State {
    ConnectionState get ();
    void set (ConnectionState value);
}

Property Value

Type: ConnectionState
See Also

Reference

ConnectionStateData Class


ConnectionStateData.StateText Property

ConnectionStateDataStateText Property
Optional state comment.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string StateText { get; set; }
public:
property String^ StateText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionStateData Class


ConnectionStateData.StrategiesCanOnlyApply Property

ConnectionStateDataStrategiesCanOnlyApply Property
Sets limitations on the usage of the Money Management system by the plugin.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<bool> StrategiesCanOnlyApply { get; set; }
public:
property Nullable<bool> StrategiesCanOnlyApply {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable Boolean
Remarks

You should set it to True if due to broker API implementation updates on positions and orders executions are recieved asynchronously.

If set to True, it will not be possible to attach Money Management strategy to an order. User will only be able to apply a Money Management strategy to an opened position in that case.

You can use this property only if SupportOfMMSShouldBeEnabled attribute is set to true.
See Also

Reference

ConnectionStateData Class


Currency Enumeration

Currency Enumeration
List of currencies available in eSignal Desktop.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum Currency
public enum class Currency
Members
Member name | Value | Description
Dollar | 0 |
Euro | 1 |
UnitedKingdomPound | 2 |
IndianRupee | 3 |
JapaneseYen | 4 |
SouthAfricanRand | 5 |
BrazilianReal | 6 |
RussianRuble | 7 |
See Also

Reference


Exchange Enumeration

Exchange Enumeration
List of available exchanges.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum Exchange
public enum class Exchange
Members
Member name | Value | Description
AMEX | 0 | American Stock Exchange (New York, USA)
ARCA | 1 | ARCA Listed (ARCX)
MYX | 2 | Bursa Malaysia Exchange (Formerly Kuala Lumpur)
BMF | 3 | Bolsa de Mercadorias e Futuros (Sao Paulo, Brazil)
CBOT | 4 | Chicago Board of Trade (USA)
CFE | 5 | Chicago Board Options Futures Exchange (USA)
CME | 6 | Chicago Mercantile Exchange (USA)
COMEX | 7 | COMEX (USA)
EUREX | 8 | Eurex (Germany/Switzerland)
ICE | 9 | ICE Futures Europe, ICE Futures US (Formerly NYBOT) (USA), ICE Futures Canada (Formerly Winnipeg), InterContinental Exchange (ICE)
KCBT | 10 | Kansas City Board of Trade (USA)
LIFFEEUR | 11 | LIFFE Interest Rate Derivatives, LIFFE Commodities Derivatives, LIFFE Equity and Index Derivatives
LIFFEUS | 12 | NYSE LIFFE U.S
LME | 13 | London Metal Exchange (UK), London Metal Exchange Minis (UK), London Metal Exchange Plastics (UK)
MGE | 14 | Minneapolis Grain Exchange (USA)
NYMEX | 15 | New York Mercantile Exchange (USA)
NYSE | 16 | New York Stock Exchange (USA)
ONE | 17 | OneChicago Single Stock Futures (USA)
ATHEX | 18 | Athens Exchange (ATHEX) (Greece)
ASX | 19 | Australian Securities Exchange (Sydney, Australia)
BATS_EUROPE | 20 | BATS Europe
BATS | 21 | BATS
BOAT | 22 | BOAT Exchange
BSE | 23 | Bombay Stock Exchange (India)
BSSE | 24 | Bratislava Stock Exchange (Slovak Republic)
BRAZIL_SOMA | 25 | Brazil SOMA
BVB | 26 | Bucharest Stock Exchange (Romania)
BUDAPEST_SE | 27 | Budapest Stock Exchange (Hungary)
BURGUNDY | 28 | Burgundy
CHIX_EUROPE | 29 | Chi-X Europe Market Data
CYPRUS_SE | 30 | Cyprus Stock Exchange
DCE | 31 | Dailian Commodity Exchange
DBAG | 32 | Deutsche Boerse Stocks and Indices (Frankfurt, XETRA)
HNX | 33 | Hanoi Stock Exchange
HKE | 34 | Hong Kong Exchanges (HKEx)
IDX | 35 | Indonesia Stock Exchange (Formerly Jakarta SE)
IRISH_SE | 36 | Ireland Stock Exchange
BORSA_ITALIANA | 37 | Italian Exchange (Borsa Italiana)
JASDAQ | 38 | JASDAQ Stock Exchange (Tokyo, Japan)
JSE | 39 | Johannesburg Stock Exchange (South Africa)
KRX | 40 | Korea Stock Exchange (Seoul, Korea)
KOSDAQ | 41 | KOSDAQ Stock Exchange (Korea)
LSE | 42 | London Stock Exchange (UK), LSE International Market Service (UK)
LUX | 43 | Luxembourg Stock Exchange (Luxembourg)
BOLSA_MADRID | 44 | Madrid Stock Exchange (Bolsa de Madrid) (Spain)
MEFF | 45 | MEFF Futures
BMV | 46 | Mexico Stock Exchange
MX | 47 | Montreal Futures Exchange (Quebec, Canada)
MTS_GROUP | 48 | MTS Group
NAGOYA_SE | 49 | Nagoya Stock Exchange (Japan)
OTCBB | 50 | NASDAQ Bulletin Board
NASDAQ | 51 | NASDAQ Stock Market (USA)
NSE | 52 | National Stock Exchange of India (Mumbai, India)
NZX | 53 | New Zealand Stock Exchange
NAE | 54 | NYSE ARCA Europe
EURONEXT | 55 | NYSE Euronext Equities
OMX_BALTIC | 56 | OMX Baltic Equities (Riga, Tallinn, Vilnius)
OMX_COMMODITIES | 57 | OMX Commodities
OMX_FUTURES | 58 | OMX Futures
OMX_NORDIC | 59 | OMX Nordic Equities (Copenhagen, Helsinki, Iceland, Stockholm)
OSE | 60 | Osaka Securities Exchange (Japan)
OSLO | 61 | Oslo Bors ASA (Oslo Børs)
PSE | 62 | Philippine Stock Exchange
OTCPINK | 63 | Pink Sheets / OTC (USA)
PLUS | 64 | PLUS Markets London (Formerly OFEX)
PRAGUE_SE | 65 | Prague Stock Exchange (Czech Republic)
FORTS | 66 | Russia SE Futures (FORTS)
RTS | 67 | Russia Stock Exchange (RTS)
BOVESPA | 68 | Sao Paulo Stock Exchange (Bovespa) (Brazil)
SSE | 69 | Shanghai Stock Exchange and Indices (China)
SZSE | 70 | Shenzhen Stock Exchange and Indices (China)
SGX | 71 | Singapore Exchange (SGX)
SIX | 72 | SIX Swiss Exchange (formerly SWX Swiss Exchange) (Zurich, Switzerland)
TAIFEX | 73 | Taiwan Futures Exchange (TAIFEX)
GTSM | 74 | Taiwan OTC (Gre Tai)
TWSE | 75 | Taiwan Stock Exchange (Taipei, Taiwan)
TASE | 76 | Tel Aviv Stock Exchange
SET | 77 | Thailand Stock Exchange
TOCOM | 78 | Tokyo Commodity Exchange (Japan)
TFX | 79 | Tokyo Financial Exchange (Japan)
TSE | 80 | Tokyo Stock Exchange (Japan)
TSX | 81 | Toronto Stock Exchange (Canada)
TURQUOISE | 82 | Turquoise
UKRAINIAN_SE | 83 | Ukrainian Stock Exchange
WBAG | 84 | Wiener Börse AG (Austria)
WSE | 85 | Warsaw Stock Exchange and Indices (Poland)
XETRA_EU | 86 | Xetra European Stars
XETRA_INTL | 87 | Xetra International
XETRA_US | 88 | Xetra US Stars
See Also

Reference


ExecutionData Class

ExecutionData Class
Designates execution data structure.
Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.TradingExecutionData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class ExecutionData : IRecordData
public ref class ExecutionData sealed : IRecordData

The ExecutionData type exposes the following members.

Constructors
 | Name | Description
Public method | ExecutionData | Initializes a new instance of the ExecutionData class.
Top
Properties
 | Name | Description
Public property | Account | Account on which the execution has been carried out.
Public property | Buy | The action of the execution. Set to 'true' for buy action.
Public property | Exchange | Exchange on which the execution has been carried out.
Public property | Id | Identifier of the execution.
Public property | Order | This field can be populated with BrokerID of an order corresponding to the execution.
Public property | Price | Price on which the execution has been carried out.
Public property | Quantity | The quantity in amount of which the execution has been carried out.
Public property | Symbol | The symbol on which the execution has been carried out.
Public property | Time | The time at which the execution has been carried out.
Top
Remarks
In eSignal Desktop application information on executions is displayed in Account Manager window in the 'Executions' tab.
See Also

Reference


ExecutionData Constructor

ExecutionData Constructor
Initializes a new instance of the ExecutionData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public ExecutionData(
    string id,
    string symbolId
)
public:
ExecutionData(
    String^ id,
    String^ symbolId
)

Parameters

id
Type: SystemString
Identifier that is used in the application to recognize the execution. This identifire is not visible to the user.
symbolId
Type: SystemString
Instrument name identifer.
See Also

Reference

ExecutionData Class


ExecutionData Properties

ExecutionData Properties

The ExecutionData type exposes the following members.

Properties
 | Name | Description
Public property | Account | Account on which the execution has been carried out.
Public property | Buy | The action of the execution. Set to 'true' for buy action.
Public property | Exchange | Exchange on which the execution has been carried out.
Public property | Id | Identifier of the execution.
Public property | Order | This field can be populated with BrokerID of an order corresponding to the execution.
Public property | Price | Price on which the execution has been carried out.
Public property | Quantity | The quantity in amount of which the execution has been carried out.
Public property | Symbol | The symbol on which the execution has been carried out.
Public property | Time | The time at which the execution has been carried out.
Top
See Also

Reference

ExecutionData Class


ExecutionData.Account Property

ExecutionDataAccount Property
Account on which the execution has been carried out.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Account { get; set; }
public:
property String^ Account {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Value is displayed in 'Account' column.
See Also

Reference

ExecutionData Class


ExecutionData.Buy Property

ExecutionDataBuy Property
The action of the execution. Set to 'true' for buy action.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool Buy { get; set; }
public:
property bool Buy {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Value is displayed in 'Buy/Sell' column.
See Also

Reference

ExecutionData Class


ExecutionData.Exchange Property

ExecutionDataExchange Property
Exchange on which the execution has been carried out.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Exchange { get; set; }
public:
property String^ Exchange {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Value is displayed in 'Exchange' column.
See Also

Reference

ExecutionData Class


ExecutionData.Id Property

ExecutionDataId Property
Identifier of the execution.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
Remarks
This value is not displayed in eSignal Desktop.
See Also

Reference

ExecutionData Class


ExecutionData.Order Property

ExecutionDataOrder Property
This field can be populated with BrokerID of an order corresponding to the execution.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Order { get; set; }
public:
property String^ Order {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Value is displayed in 'Order ID' column.
See Also

Reference

ExecutionData Class


ExecutionData.Price Property

ExecutionDataPrice Property
Price on which the execution has been carried out.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public double Price { get; set; }
public:
property double Price {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks
Value is displayed in 'Price' column.
See Also

Reference

ExecutionData Class


ExecutionData.Quantity Property

ExecutionDataQuantity Property
The quantity in amount of which the execution has been carried out.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int Quantity { get; set; }
public:
property int Quantity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Value is displayed in 'Quantity' column.
See Also

Reference

ExecutionData Class


ExecutionData.Symbol Property

ExecutionDataSymbol Property
The symbol on which the execution has been carried out.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Symbol { get; set; }
public:
property String^ Symbol {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Value is displayed in 'Symbol' column.
See Also

Reference

ExecutionData Class


ExecutionData.Time Property

ExecutionDataTime Property
The time at which the execution has been carried out.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public DateTime Time { get; set; }
public:
property DateTime Time {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
Remarks
Value is displayed in 'Time' column.
See Also

Reference

ExecutionData Class


IConnectionSettingsPage Interface

IConnectionSettingsPage Interface
Custom connection settings page creator.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IConnectionSettingsPage : ISettingsPage
public interface class IConnectionSettingsPage : ISettingsPage

The IConnectionSettingsPage type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Top
See Also

Reference


IConnectionSettingsPage Properties

IConnectionSettingsPage Properties

The IConnectionSettingsPage type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Top
See Also

Reference

IConnectionSettingsPage Interface


IConnectionSettingsPage.Data Property

IConnectionSettingsPageData Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
ConnectionSettings Data { get; set; }
property ConnectionSettings^ Data {
    ConnectionSettings^ get ();
    void set (ConnectionSettings^ value);
}

Property Value

Type: ConnectionSettings
See Also

Reference

IConnectionSettingsPage Interface


IDateTimeControl Interface

IDateTimeControl Interface
Gives access to good till date field. Should be used inside of IOrderTicket interface.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IDateTimeControl : IOrderTicketControl
public interface class IDateTimeControl : IOrderTicketControl

The IDateTimeControl type exposes the following members.

Properties
 | Name | Description
Public property | Value | Date and time value.
Top
See Also

Reference


IDateTimeControl Properties

IDateTimeControl Properties

The IDateTimeControl type exposes the following members.

Properties
 | Name | Description
Public property | Value | Date and time value.
Top
See Also

Reference

IDateTimeControl Interface


IDateTimeControl.Value Property

IDateTimeControlValue Property
Date and time value.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
Nullable<DateTime> Value { get; }
property Nullable<DateTime> Value {
    Nullable<DateTime> get ();
}

Property Value

Type: Nullable DateTime
See Also

Reference

IDateTimeControl Interface


IESignalSymbol Interface

IESignalSymbol Interface
Extended symbol information.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IESignalSymbol
public interface class IESignalSymbol

The IESignalSymbol type exposes the following members.

Properties
 | Name | Description
 | BaseCurrency | Base currency of a currency pair. Usually it is the first currency of the pair.
 | Contributor | Forex contributor. This field contains code of a single financial institute that is used as a data source for some Forex symbol, in contrast to composite Forex symbol that merges market data from different sources.
 | Description | eSignal description. This field contains code eSingal description of a symbol.
 | Exchange | Exchange of a symbol. In eSignal Desktop one exchange may have different codes depending on additional parameters such as symbol type. This field contains element with a short name of the actual exchange that is matched on the symbol's exchange code inside the API. Field can take null, if the symbol's exchange code is not matched to any member of the enumeration. Exchange. For more information see topic Symbol Mapping.
 | ExchangeName | eSignal exchange code. This field contains a string code of the symbol's exchange in the same representation like it is used in eSignal Desktop. For most, this code is not equal to the actual exchange name. You can use this value in addition to Exchange field or if Exchange = null. For more information see topic Symbol Mapping.
 | ExpirationDay | Expiration day of Future or Option. The field contains expiration day of a symbol as a number of the day in a month.
 | ExpirationMonth | Expiration month of Future or Option. The field contains expiration month of a symbol as a number of the month in an year.
 | ExpirationWeek | Expiration week of Future or Option The field contains expiration week of a symbol as a number of the week in an year.
 | ExpirationYear | Expiration year of Future or Option. The field contains expiration year of a symbol as a number.
Public property | Legs | Collection of spread legs symbols.
 | MinMovement | Minimal price movement on the price scale
 | MinMovement2 | Number of shares on which price is additionally divided.
Public property | OptionIsCall | Identifies if the option is call.
Public property | OptionIsPut | Identifies if the option is put.
Public property | OptionStrike | Strike price of an option.
 | PriceScale | Price scale of a symbol.
 | QuoteCurrency | Quote currency of a currency pair. Usually it is the second currency of the pair.
 | Root | Underlying symbol or contract.
Public property | Type | eSignal symbol type. Available symbol types are listed in the enumeration SymbolType.
Top
See Also

Reference


IESignalSymbol Properties

IESignalSymbol Properties

The IESignalSymbol type exposes the following members.

Properties
 | Name | Description
 | BaseCurrency | Base currency of a currency pair. Usually it is the first currency of the pair.
 | Contributor | Forex contributor. This field contains code of a single financial institute that is used as a data source for some Forex symbol, in contrast to composite Forex symbol that merges market data from different sources.
 | Description | eSignal description. This field contains code eSingal description of a symbol.
 | Exchange | Exchange of a symbol. In eSignal Desktop one exchange may have different codes depending on additional parameters such as symbol type. This field contains element with a short name of the actual exchange that is matched on the symbol's exchange code inside the API. Field can take null, if the symbol's exchange code is not matched to any member of the enumeration. Exchange. For more information see topic Symbol Mapping.
 | ExchangeName | eSignal exchange code. This field contains a string code of the symbol's exchange in the same representation like it is used in eSignal Desktop. For most, this code is not equal to the actual exchange name. You can use this value in addition to Exchange field or if Exchange = null. For more information see topic Symbol Mapping.
 | ExpirationDay | Expiration day of Future or Option. The field contains expiration day of a symbol as a number of the day in a month.
 | ExpirationMonth | Expiration month of Future or Option. The field contains expiration month of a symbol as a number of the month in an year.
 | ExpirationWeek | Expiration week of Future or Option The field contains expiration week of a symbol as a number of the week in an year.
 | ExpirationYear | Expiration year of Future or Option. The field contains expiration year of a symbol as a number.
Public property | Legs | Collection of spread legs symbols.
 | MinMovement | Minimal price movement on the price scale
 | MinMovement2 | Number of shares on which price is additionally divided.
Public property | OptionIsCall | Identifies if the option is call.
Public property | OptionIsPut | Identifies if the option is put.
Public property | OptionStrike | Strike price of an option.
 | PriceScale | Price scale of a symbol.
 | QuoteCurrency | Quote currency of a currency pair. Usually it is the second currency of the pair.
 | Root | Underlying symbol or contract.
Public property | Type | eSignal symbol type. Available symbol types are listed in the enumeration SymbolType.
Top
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.BaseCurrency Property

IESignalSymbolBaseCurrency Property
Base currency of a currency pair. Usually it is the first currency of the pair.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string BaseCurrency { get; }
property String^ BaseCurrency {
    String^ get ();
}

Property Value

Type: String
Remarks
Valid for Forex.
Examples
For example:

In a currency symbol "EURGBP A0-FX" BaseCurrency = "EUR" and the quote currency is GBP.

In a currency symbol "EUR A0-FX" BaseCurrency = "EUR" and the quote currency is USD.

See Also

Reference

IESignalSymbol Interface


IESignalSymbol.Contributor Property

IESignalSymbolContributor Property
Forex contributor.

This field contains code of a single financial institute that is used as a data source for some Forex symbol, in contrast to composite Forex symbol that merges market data from different sources.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string Contributor { get; }
property String^ Contributor {
    String^ get ();
}

Property Value

Type: String
Remarks
Valid for Single Forex Contributor Symbols.
Examples
For example, "EUR@GAIN A0-FX" is EUR/USD on GAIN Capital. In this case the field's value would be "GAIN". And "EUR A0-FX" is a composite Forex symbol, the field's value would be an empty string.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.Description Property

IESignalSymbolDescription Property
eSignal description.

This field contains code eSingal description of a symbol.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string Description { get; }
property String^ Description {
    String^ get ();
}

Property Value

Type: String
Remarks
Can be empty.
Examples
For example it can contain company name or contract description
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.Exchange Property

IESignalSymbolExchange Property
Exchange of a symbol.

In eSignal Desktop one exchange may have different codes depending on additional parameters such as symbol type. This field contains element with a short name of the actual exchange that is matched on the symbol's exchange code inside the API. Field can take null, if the symbol's exchange code is not matched to any member of the enumeration. Exchange.

For more information see topic Symbol Mapping.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
Nullable<Exchange> Exchange { get; }
property Nullable<Exchange> Exchange {
    Nullable<Exchange> get ();
}

Property Value

Type: Nullable Exchange
Remarks
May be null for some rare exchanges.
Examples
For example, Exchange = LSE for symbol "VOD-LON" (VODAFONE GROUP PLC), and Exchange = EUREX for symbol "SM M3-DT" (SMI Futures June 2013).
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.ExchangeName Property

IESignalSymbolExchangeName Property
eSignal exchange code.

This field contains a string code of the symbol's exchange in the same representation like it is used in eSignal Desktop. For most, this code is not equal to the actual exchange name. You can use this value in addition to Exchange field or if Exchange = null.

For more information see topic Symbol Mapping.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string ExchangeName { get; }
property String^ ExchangeName {
    String^ get ();
}

Property Value

Type: String
Remarks
Valid for Stocks, Futures, Forex.
Examples
For example, ExchangeName = "LON" for symbol "VOD-LON" (VODAFONE GROUP PLC), and ExchangeName = "EUX" for symbol "SM M3-DT" (SMI Futures June 2013).
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.ExpirationDay Property

IESignalSymbolExpirationDay Property
Expiration day of Future or Option.

The field contains expiration day of a symbol as a number of the day in a month.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
int ExpirationDay { get; }
property int ExpirationDay {
    int get ();
}

Property Value

Type: Int32
Remarks
Valid for Futures, Options.
Examples
For example, ExpirationDay would be 3 for option "O:GOOG 13E720.00D3" that is GOOG 3 May 13 720.00 Call.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.ExpirationMonth Property

IESignalSymbolExpirationMonth Property
Expiration month of Future or Option.

The field contains expiration month of a symbol as a number of the month in an year.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
int ExpirationMonth { get; }
property int ExpirationMonth {
    int get ();
}

Property Value

Type: Int32
Remarks
Valid for Futures, Options.
Examples
For example, ExpirationMonth would be 9 for future "CL U3" (Light Sweet Crude Oil (WTI) Futures Sep 2013)
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.ExpirationWeek Property

IESignalSymbolExpirationWeek Property
Expiration week of Future or Option

The field contains expiration week of a symbol as a number of the week in an year.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
int ExpirationWeek { get; }
property int ExpirationWeek {
    int get ();
}

Property Value

Type: Int32
Remarks
Valid for Futures, Options.
Examples
For example, ExpirationWeek would be 18 for future "ENO 13W18-OMC" (Nordic Electricity Base Week Future - week 18 in 2013)
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.ExpirationYear Property

IESignalSymbolExpirationYear Property
Expiration year of Future or Option.

The field contains expiration year of a symbol as a number.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
int ExpirationYear { get; }
property int ExpirationYear {
    int get ();
}

Property Value

Type: Int32
Remarks
Valid for Futures, Options.
Examples
For example, ExpirationYear would be 2013 for future "CL U3" (Light Sweet Crude Oil (WTI) Futures Sep 2013)
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.Legs Property

IESignalSymbolLegs Property
Collection of spread legs symbols.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IEnumerable<SpreadLeg> Legs { get; }
property IEnumerable<SpreadLeg>^ Legs {
    IEnumerable<SpreadLeg>^ get ();
}

Property Value

Type: IEnumerable SpreadLeg
Remarks
Valid for spreads.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.MinMovement Property

IESignalSymbolMinMovement Property
Minimal price movement on the price scale

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
int MinMovement { get; }
property int MinMovement {
    int get ();
}

Property Value

Type: Int32
Examples
For example, MinMovement would be 1 for stock "C" (Citigroup Inc.), and its PriceScale would be 100. The minimum price fluctuation (tick size) for this symbol would be MinMovement/PriceScale = 1/100.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.MinMovement2 Property

IESignalSymbolMinMovement2 Property
Number of shares on which price is additionally divided.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
int MinMovement2 { get; }
property int MinMovement2 {
    int get ();
}

Property Value

Type: Int32
Examples
For example, MinMovement2 = 8 for bond "TRE Z0-PX" (US OTR TREASURY NOTE 10 Yr), its PriceScale = 256 and MinMovement = 1. The bond's quotes are in the following format in eSignal Desktop: 102 113, 102 11+, 102 115, ..., 102 117, 102 12, ..., 102 31, 103 00, ... It means that symbol's price changes on 1/32 of a point and then on 1/8 of 1/32 of a point, i. e. the minimum fluctuation is 1/32 * 1/8 that is 1/256. In other words, Tick Size = MinMovement/PriceScale = 1/256 and tick size for upper-level fractions is MinMovement2/PriceScale = 8/256 = 1/32.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.OptionIsCall Property

IESignalSymbolOptionIsCall Property
Identifies if the option is call.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
bool OptionIsCall { get; }
property bool OptionIsCall {
    bool get ();
}

Property Value

Type: Boolean
Remarks
Valid for Options.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.OptionIsPut Property

IESignalSymbolOptionIsPut Property
Identifies if the option is put.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
bool OptionIsPut { get; }
property bool OptionIsPut {
    bool get ();
}

Property Value

Type: Boolean
Remarks
Valid for Options.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.OptionStrike Property

IESignalSymbolOptionStrike Property
Strike price of an option.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
double OptionStrike { get; }
property double OptionStrike {
    double get ();
}

Property Value

Type: Double
Remarks
Valid for Options.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.PriceScale Property

IESignalSymbolPriceScale Property
Price scale of a symbol.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
int PriceScale { get; }
property int PriceScale {
    int get ();
}

Property Value

Type: Int32
Examples
For example, PriceScale would be 100 for stock "C" (Citigroup Inc.), and its MinMovement would be 1. The minimum price fluctuation (tick size) for this symbol would be MinMovement/PriceScale = 1/100.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.QuoteCurrency Property

IESignalSymbolQuoteCurrency Property
Quote currency of a currency pair. Usually it is the second currency of the pair.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string QuoteCurrency { get; }
property String^ QuoteCurrency {
    String^ get ();
}

Property Value

Type: String
Remarks
Valid for Forex.
Examples
For example:

In a currency symbol "EURGBP A0-FX" QuoteCurrency = "GBP" and the base currency is EUR.

In a currency symbol "EUR A0-FX" QuoteCurrency = "USD" and the base currency is EUR.

See Also

Reference

IESignalSymbol Interface


IESignalSymbol.Root Property

IESignalSymbolRoot Property
Underlying symbol or contract.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string Root { get; }
property String^ Root {
    String^ get ();
}

Property Value

Type: String
Remarks
Valid for Stocks, Futures, Options, Bonds, Forex.
Examples
For example, for symbol "VOD-LON" (VODAFONE GROUP PLC) Root = "VOD", for "CL U3" (Light Sweet Crude Oil (WTI) Futures Sep 2013) Root = "CL" and so on.
See Also

Reference

IESignalSymbol Interface


IESignalSymbol.Type Property

IESignalSymbolType Property
eSignal symbol type. Available symbol types are listed in the enumeration SymbolType.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
SymbolType Type { get; }
property SymbolType Type {
    SymbolType get ();
}

Property Value

Type: SymbolType
See Also

Reference

IESignalSymbol Interface


IInputSymbol Interface

IInputSymbol Interface
Represents symbol entered by user.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IInputSymbol
public interface class IInputSymbol

The IInputSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ESignalSymbol | If the symbol is valid eSignal Desktop symbol, the field contains reference to IESignalSymbol structure, null otherwise.
Public property | Symbol | Raw string.
Top
See Also

Reference


IInputSymbol Properties

IInputSymbol Properties

The IInputSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ESignalSymbol | If the symbol is valid eSignal Desktop symbol, the field contains reference to IESignalSymbol structure, null otherwise.
Public property | Symbol | Raw string.
Top
See Also

Reference

IInputSymbol Interface


IInputSymbol.ESignalSymbol Property

IInputSymbolESignalSymbol Property
If the symbol is valid eSignal Desktop symbol, the field contains reference to IESignalSymbol structure, null otherwise.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IESignalSymbol ESignalSymbol { get; }
property IESignalSymbol^ ESignalSymbol {
    IESignalSymbol^ get ();
}

Property Value

Type: IESignalSymbol
See Also

Reference

IInputSymbol Interface


IInputSymbol.Symbol Property

IInputSymbolSymbol Property
Raw string.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string Symbol { get; }
property String^ Symbol {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IInputSymbol Interface


IIntegerNumberControl Interface

IIntegerNumberControl Interface
Gives access to quantity field. Should be used inside of IOrderTicket interface.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IIntegerNumberControl : IOrderTicketControl
public interface class IIntegerNumberControl : IOrderTicketControl

The IIntegerNumberControl type exposes the following members.

Properties
 | Name | Description
Public property | Value | The value of quantity field.
Top
See Also

Reference


IIntegerNumberControl Properties

IIntegerNumberControl Properties

The IIntegerNumberControl type exposes the following members.

Properties
 | Name | Description
Public property | Value | The value of quantity field.
Top
See Also

Reference

IIntegerNumberControl Interface


IIntegerNumberControl.Value Property

IIntegerNumberControlValue Property
The value of quantity field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
Nullable<int> Value { get; }
property Nullable<int> Value {
    Nullable<int> get ();
}

Property Value

Type: Nullable Int32
See Also

Reference

IIntegerNumberControl Interface


IMethodRequest Interface

IMethodRequest Interface
Object for reporting back operation result.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IMethodRequest
public interface class IMethodRequest

The IMethodRequest type exposes the following members.

Methods
 | Name | Description
Public method | Failed | Call to report failure, error message must be provided.
Public method | Succeeded | Call to report successful operation completion.
Top
See Also

Reference


IMethodRequest Methods

IMethodRequest Methods

The IMethodRequest type exposes the following members.

Methods
 | Name | Description
Public method | Failed | Call to report failure, error message must be provided.
Public method | Succeeded | Call to report successful operation completion.
Top
See Also

Reference

IMethodRequest Interface


IMethodRequest.Failed Method

IMethodRequestFailed Method
Call to report failure, error message must be provided.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void Failed(
    string Error
)
void Failed(
    String^ Error
)

Parameters

Error
Type: SystemString
Error message text
See Also

Reference

IMethodRequest Interface


IMethodRequest.Succeeded Method

IMethodRequestSucceeded Method
Call to report successful operation completion.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void Succeeded(
    string OrderId
)
void Succeeded(
    String^ OrderId
)

Parameters

OrderId
Type: SystemString
An ID that has been assigned to the order after processing the request
See Also

Reference

IMethodRequest Interface


IOrderActionControl Interface

IOrderActionControl Interface
Gives access to action field (Buy/Sell/Sell Short/Buy To Cover). Should be used inside of IOrderTicket interface.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IOrderActionControl : IOrderTicketControl
public interface class IOrderActionControl : IOrderTicketControl

The IOrderActionControl type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Possible values that are available in order action field.
Public property | Value | Value of action field.
Top
See Also

Reference


IOrderActionControl Properties

IOrderActionControl Properties

The IOrderActionControl type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Possible values that are available in order action field.
Public property | Value | Value of action field.
Top
See Also

Reference

IOrderActionControl Interface


IOrderActionControl.Domain Property

IOrderActionControlDomain Property
Possible values that are available in order action field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
OrderAction[] Domain { get; set; }
property array<OrderAction>^ Domain {
    array<OrderAction>^ get ();
    void set (array<OrderAction>^ value);
}

Property Value

Type: OrderAction
See Also

Reference

IOrderActionControl Interface


IOrderActionControl.Value Property

IOrderActionControlValue Property
Value of action field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
Nullable<OrderAction> Value { get; }
property Nullable<OrderAction> Value {
    Nullable<OrderAction> get ();
}

Property Value

Type: Nullable OrderAction
See Also

Reference

IOrderActionControl Interface


IOrderExpiryControl Interface

IOrderExpiryControl Interface
Gives access to order expiry field. Should be used inside of IOrderTicket interface.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IOrderExpiryControl : IOrderTicketControl
public interface class IOrderExpiryControl : IOrderTicketControl

The IOrderExpiryControl type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Possible values that are available in order expiry field.
Public property | Value | Value of expiry field.
Top
See Also

Reference


IOrderExpiryControl Properties

IOrderExpiryControl Properties

The IOrderExpiryControl type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Possible values that are available in order expiry field.
Public property | Value | Value of expiry field.
Top
See Also

Reference

IOrderExpiryControl Interface


IOrderExpiryControl.Domain Property

IOrderExpiryControlDomain Property
Possible values that are available in order expiry field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
OrderExpiry[] Domain { get; set; }
property array<OrderExpiry>^ Domain {
    array<OrderExpiry>^ get ();
    void set (array<OrderExpiry>^ value);
}

Property Value

Type: OrderExpiry
See Also

Reference

IOrderExpiryControl Interface


IOrderExpiryControl.Value Property

IOrderExpiryControlValue Property
Value of expiry field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
Nullable<OrderExpiry> Value { get; }
property Nullable<OrderExpiry> Value {
    Nullable<OrderExpiry> get ();
}

Property Value

Type: Nullable OrderExpiry
See Also

Reference

IOrderExpiryControl Interface


IOrderTicket Interface

IOrderTicket Interface
Represents order ticket window. See glossary article Order Ticket for more details.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IOrderTicket
public interface class IOrderTicket

The IOrderTicket type exposes the following members.

Methods
 | Name | Description
Public method | GetCustomControl | Gives access to custom fields defined by add-in.
Top
Properties
 | Name | Description
Public property | Account | Gives access to account field.
Public property | Action | Gives access to action field (Buy/Sell/Sell Short/Buy To Cover).
Public property | Expiry | Gives access to expiry field.
Public property | GoodTillDate | Gives access to good till date field.
Public property | LimitPrice | Gives access to limit price field.
Public property | Mode | Mode to be distinguished between place and replace.
Public property | Position | Gives access to position-id field.
Public property | Quantity | Gives access to quantity field.
Public property | StopPrice | Gives access to stop price field.
Public property | Symbol | Symbol in symbol field.
Public property | Type | Gives access to type field.
Top
See Also

Reference


IOrderTicket Methods

IOrderTicket Methods

The IOrderTicket type exposes the following members.

Methods
 | Name | Description
Public method | GetCustomControl | Gives access to custom fields defined by add-in.
Top
See Also

Reference

IOrderTicket Interface


IOrderTicket.GetCustomControl Method

IOrderTicketGetCustomControl Method
Gives access to custom fields defined by add-in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IOrderTicketControl GetCustomControl(
    string FieldId
)
IOrderTicketControl^ GetCustomControl(
    String^ FieldId
)

Parameters

FieldId
Type: SystemString
Internal identifier of the field.

Return Value

Type: IOrderTicketControl
See Also

Reference

IOrderTicket Interface


IOrderTicket Properties

IOrderTicket Properties

The IOrderTicket type exposes the following members.

Properties
 | Name | Description
Public property | Account | Gives access to account field.
Public property | Action | Gives access to action field (Buy/Sell/Sell Short/Buy To Cover).
Public property | Expiry | Gives access to expiry field.
Public property | GoodTillDate | Gives access to good till date field.
Public property | LimitPrice | Gives access to limit price field.
Public property | Mode | Mode to be distinguished between place and replace.
Public property | Position | Gives access to position-id field.
Public property | Quantity | Gives access to quantity field.
Public property | StopPrice | Gives access to stop price field.
Public property | Symbol | Symbol in symbol field.
Public property | Type | Gives access to type field.
Top
See Also

Reference

IOrderTicket Interface


IOrderTicket.Account Property

IOrderTicketAccount Property
Gives access to account field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
ITextControl Account { get; }
property ITextControl^ Account {
    ITextControl^ get ();
}

Property Value

Type: ITextControl
See Also

Reference

IOrderTicket Interface


IOrderTicket.Action Property

IOrderTicketAction Property
Gives access to action field (Buy/Sell/Sell Short/Buy To Cover).

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IOrderActionControl Action { get; }
property IOrderActionControl^ Action {
    IOrderActionControl^ get ();
}

Property Value

Type: IOrderActionControl
See Also

Reference

IOrderTicket Interface


IOrderTicket.Expiry Property

IOrderTicketExpiry Property
Gives access to expiry field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IOrderExpiryControl Expiry { get; }
property IOrderExpiryControl^ Expiry {
    IOrderExpiryControl^ get ();
}

Property Value

Type: IOrderExpiryControl
See Also

Reference

IOrderTicket Interface


IOrderTicket.GoodTillDate Property

IOrderTicketGoodTillDate Property
Gives access to good till date field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IDateTimeControl GoodTillDate { get; }
property IDateTimeControl^ GoodTillDate {
    IDateTimeControl^ get ();
}

Property Value

Type: IDateTimeControl
See Also

Reference

IOrderTicket Interface


IOrderTicket.LimitPrice Property

IOrderTicketLimitPrice Property
Gives access to limit price field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IPriceControl LimitPrice { get; }
property IPriceControl^ LimitPrice {
    IPriceControl^ get ();
}

Property Value

Type: IPriceControl
See Also

Reference

IOrderTicket Interface


IOrderTicket.Mode Property

IOrderTicketMode Property
Mode to be distinguished between place and replace.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
OrderTicketMode Mode { get; }
property OrderTicketMode Mode {
    OrderTicketMode get ();
}

Property Value

Type: OrderTicketMode
See Also

Reference

IOrderTicket Interface


IOrderTicket.Position Property

IOrderTicketPosition Property
Gives access to position-id field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
ITextControl Position { get; }
property ITextControl^ Position {
    ITextControl^ get ();
}

Property Value

Type: ITextControl
See Also

Reference

IOrderTicket Interface


IOrderTicket.Quantity Property

IOrderTicketQuantity Property
Gives access to quantity field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IIntegerNumberControl Quantity { get; }
property IIntegerNumberControl^ Quantity {
    IIntegerNumberControl^ get ();
}

Property Value

Type: IIntegerNumberControl
See Also

Reference

IOrderTicket Interface


IOrderTicket.StopPrice Property

IOrderTicketStopPrice Property
Gives access to stop price field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IPriceControl StopPrice { get; }
property IPriceControl^ StopPrice {
    IPriceControl^ get ();
}

Property Value

Type: IPriceControl
See Also

Reference

IOrderTicket Interface


IOrderTicket.Symbol Property

IOrderTicketSymbol Property
Symbol in symbol field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string Symbol { get; }
property String^ Symbol {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IOrderTicket Interface


IOrderTicket.Type Property

IOrderTicketType Property
Gives access to type field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IOrderTypeControl Type { get; }
property IOrderTypeControl^ Type {
    IOrderTypeControl^ get ();
}

Property Value

Type: IOrderTypeControl
See Also

Reference

IOrderTicket Interface


IOrderTicketControl Interface

IOrderTicketControl Interface
Gives access to custom fields in Order Ticket defined by the add-in. Should be used inside of IOrderTicket interface.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IOrderTicketControl
public interface class IOrderTicketControl

The IOrderTicketControl type exposes the following members.

Properties
 | Name | Description
Public property | Field | The field name.
Public property | IsReadonly | Designate if the custom field is read only.
Public property | Value | Value of the field.
Top
See Also

Reference


IOrderTicketControl Properties

IOrderTicketControl Properties

The IOrderTicketControl type exposes the following members.

Properties
 | Name | Description
Public property | Field | The field name.
Public property | IsReadonly | Designate if the custom field is read only.
Public property | Value | Value of the field.
Top
See Also

Reference

IOrderTicketControl Interface


IOrderTicketControl.Field Property

IOrderTicketControlField Property
The field name.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
TopicField Field { get; }
property TopicField Field {
    TopicField get ();
}

Property Value

Type: TopicField
See Also

Reference

IOrderTicketControl Interface


IOrderTicketControl.IsReadonly Property

IOrderTicketControlIsReadonly Property
Designate if the custom field is read only.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
bool IsReadonly { get; set; }
property bool IsReadonly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IOrderTicketControl Interface


IOrderTicketControl.Value Property

IOrderTicketControlValue Property
Value of the field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
Object Value { get; }
property Object^ Value {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

IOrderTicketControl Interface


IOrderTypeControl Interface

IOrderTypeControl Interface
Gives access to order type field. Should be used inside of IOrderTicket interface.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IOrderTypeControl : IOrderTicketControl
public interface class IOrderTypeControl : IOrderTicketControl

The IOrderTypeControl type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Possible values that are available in order type field.
Public property | Value | Value of order type field.
Top
See Also

Reference


IOrderTypeControl Properties

IOrderTypeControl Properties

The IOrderTypeControl type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Possible values that are available in order type field.
Public property | Value | Value of order type field.
Top
See Also

Reference

IOrderTypeControl Interface


IOrderTypeControl.Domain Property

IOrderTypeControlDomain Property
Possible values that are available in order type field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
OrderType[] Domain { get; set; }
property array<OrderType>^ Domain {
    array<OrderType>^ get ();
    void set (array<OrderType>^ value);
}

Property Value

Type: OrderType
See Also

Reference

IOrderTypeControl Interface


IOrderTypeControl.Value Property

IOrderTypeControlValue Property
Value of order type field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
OrderType Value { get; }
property OrderType Value {
    OrderType get ();
}

Property Value

Type: OrderType
See Also

Reference

IOrderTypeControl Interface


IPlugin Interface

IPlugin Interface
Main interface of the add-in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IPlugin
public interface class IPlugin

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | CancelOrder | Called when cancel order request comes to the add-in.
Public method | Connect | Directs the add-in to establish a connection.
Public method | CreateConnectionSettingsPage | Custom connection settings page creator.
Public method | CreateSymbolLookupPage | Custom symbol lookup page creator.
Public method | Disconnect | Directs the add-in to disconnect and cleanup.
Public method | GetSupportedOrderTypes | Returns list of order types that are supported by this add-in.
Public method | MapSymbolFrom | Called when it's needed to get a broker-specific symbol name for corresponding string entered by user.
Public method | OnHostAttach | Called when the add-in is to be attached to the hosting application.
Public method | OnHostDetach | Called when the add-in is to be detached from the hosting application.
Public method | PlaceOrder | Called when place order request comes to the add-in.
Public method | ReplaceOrder | Called when replace order request comes to the add-in.
Public method | UpdateControls | Update domain values and user accessibility for OrderTicket controls. The method is called when user has opened Order Ticket or changed a value in any of its controls.
Top
See Also

Reference


IPlugin Methods

IPlugin Methods

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | CancelOrder | Called when cancel order request comes to the add-in.
Public method | Connect | Directs the add-in to establish a connection.
Public method | CreateConnectionSettingsPage | Custom connection settings page creator.
Public method | CreateSymbolLookupPage | Custom symbol lookup page creator.
Public method | Disconnect | Directs the add-in to disconnect and cleanup.
Public method | GetSupportedOrderTypes | Returns list of order types that are supported by this add-in.
Public method | MapSymbolFrom | Called when it's needed to get a broker-specific symbol name for corresponding string entered by user.
Public method | OnHostAttach | Called when the add-in is to be attached to the hosting application.
Public method | OnHostDetach | Called when the add-in is to be detached from the hosting application.
Public method | PlaceOrder | Called when place order request comes to the add-in.
Public method | ReplaceOrder | Called when replace order request comes to the add-in.
Public method | UpdateControls | Update domain values and user accessibility for OrderTicket controls. The method is called when user has opened Order Ticket or changed a value in any of its controls.
Top
See Also

Reference

IPlugin Interface


IPlugin.CancelOrder Method

IPluginCancelOrder Method
Called when cancel order request comes to the add-in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void CancelOrder(
    string orderId,
    IMethodRequest request
)
void CancelOrder(
    String^ orderId,
    IMethodRequest^ request
)

Parameters

orderId
Type: SystemString
Identifier of the cancelling order.
request
Type: InteractiveData.eSignalDesktop.TradingIMethodRequest
Object for reporting back the operation result.
See Also

Reference

IPlugin Interface


IPlugin.Connect Method

IPluginConnect Method
Directs the add-in to establish a connection.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void Connect(
    ConnectionSettings Settings
)
void Connect(
    ConnectionSettings^ Settings
)

Parameters

Settings
Type: InteractiveData.eSignalDesktop.TradingConnectionSettings
Connection settings to be used in the current session.
See Also

Reference

IPlugin Interface


IPlugin.CreateConnectionSettingsPage Method

IPluginCreateConnectionSettingsPage Method
Custom connection settings page creator.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
IConnectionSettingsPage CreateConnectionSettingsPage()
IConnectionSettingsPage^ CreateConnectionSettingsPage()

Return Value

Type: IConnectionSettingsPage
See Also

Reference

IPlugin Interface


IPlugin.CreateSymbolLookupPage Method

IPluginCreateSymbolLookupPage Method
Custom symbol lookup page creator.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
ISymbolLookupPage CreateSymbolLookupPage()
ISymbolLookupPage^ CreateSymbolLookupPage()

Return Value

Type: ISymbolLookupPage
See Also

Reference

IPlugin Interface


IPlugin.Disconnect Method

IPluginDisconnect Method
Directs the add-in to disconnect and cleanup.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void Disconnect()
void Disconnect()
See Also

Reference

IPlugin Interface


IPlugin.GetSupportedOrderTypes Method

IPluginGetSupportedOrderTypes Method
Returns list of order types that are supported by this add-in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
OrderTypeDeclaration[] GetSupportedOrderTypes()
array<OrderTypeDeclaration^>^ GetSupportedOrderTypes()

Return Value

Type: OrderTypeDeclaration
Returns a list of supported order types. No order types beyound this list are accepted.
Remarks
This method is guaranteed to be called only after the add-in has reported its state as 'Connected', so if your broker can vary supported order types depending on account, time, weather, etc., it is possible to be handled here.
See Also

Reference

IPlugin Interface


IPlugin.MapSymbolFrom Method

IPluginMapSymbolFrom Method
Called when it's needed to get a broker-specific symbol name for corresponding string entered by user.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string MapSymbolFrom(
    IInputSymbol Symbol
)
String^ MapSymbolFrom(
    IInputSymbol^ Symbol
)

Parameters

Symbol
Type: InteractiveData.eSignalDesktop.TradingIInputSymbol
Structure describing the input.

Return Value

Type: String
Should return valid symbol id or null if the symbol could not be recognized.
See Also

Reference

IPlugin Interface


IPlugin.OnHostAttach Method

IPluginOnHostAttach Method
Called when the add-in is to be attached to the hosting application.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void OnHostAttach(
    IPluginHost Host
)
void OnHostAttach(
    IPluginHost^ Host
)

Parameters

Host
Type: InteractiveData.eSignalDesktop.TradingIPluginHost
An instance of the host application interface.
See Also

Reference

IPlugin Interface


IPlugin.OnHostDetach Method

IPluginOnHostDetach Method
Called when the add-in is to be detached from the hosting application.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void OnHostDetach()
void OnHostDetach()
See Also

Reference

IPlugin Interface


IPlugin.PlaceOrder Method

IPluginPlaceOrder Method
Called when place order request comes to the add-in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void PlaceOrder(
    OrderData order,
    IMethodRequest request
)
void PlaceOrder(
    OrderData^ order,
    IMethodRequest^ request
)

Parameters

order
Type: InteractiveData.eSignalDesktop.TradingOrderData
Parameters of a new order.
request
Type: InteractiveData.eSignalDesktop.TradingIMethodRequest
Object for reporting back the operation result.
See Also

Reference

IPlugin Interface


IPlugin.ReplaceOrder Method

IPluginReplaceOrder Method
Called when replace order request comes to the add-in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void ReplaceOrder(
    OrderData order,
    IMethodRequest request
)
void ReplaceOrder(
    OrderData^ order,
    IMethodRequest^ request
)

Parameters

order
Type: InteractiveData.eSignalDesktop.TradingOrderData
New parameters of existing order.
request
Type: InteractiveData.eSignalDesktop.TradingIMethodRequest
Object for reporting back the operation result.
See Also

Reference

IPlugin Interface


IPlugin.UpdateControls Method

IPluginUpdateControls Method
Update domain values and user accessibility for OrderTicket controls. The method is called when user has opened Order Ticket or changed a value in any of its controls.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void UpdateControls(
    IOrderTicket orderTicket
)
void UpdateControls(
    IOrderTicket^ orderTicket
)

Parameters

orderTicket
Type: InteractiveData.eSignalDesktop.TradingIOrderTicket
An instance of order ticket. See glossary article Order Ticket for more details.
See Also

Reference

IPlugin Interface


IPluginHost Interface

IPluginHost Interface
Interface for communication between eSignal and add-in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IPluginHost
public interface class IPluginHost

The IPluginHost type exposes the following members.

Methods
 | Name | Description
Public method | EndAccountHistory | Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical account data from its servers and ready to go real-time processing.
Public method | EndExecutionHistory | Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical execution reports from its servers and ready to go real-time processing.
Public method | EndOrderHistory | Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical orders from its servers and ready to go real-time processing.
Public method | EndPositionHistory | Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical positions from its servers and ready to go real-time processing.
Public method | SendAccount | Sends an update of account field values to eSignal.
Public method | SendConnectionState | Reports connection state of the add-in to eSignal.
Public method | SendExecution | Sends an execution update to eSignal.
Public method | SendMarketDepth | Sends Market Depth data update to eSignal.
Public method | SendMessage | Sends a text message to eSignal. User can find this message in Messages tab of Account Manager and in Connection tab of Broker Manager.
Public method | SendOrder | Sends an order update to eSignal.
Public method | SendPosition | Sends a position update to eSignal.
Public method | SendQuote | Sends Quote data update to eSignal.
Public method | SendSymbol | Sends symbol information to eSignal.
Public method | SetCustomLogsDirectory | Allows to point application to a directory where the add-in is about to store its logs. In case of any unexpected behavior, all the files that are contained in that directory are going to be packed and sent to error reporting service of eSignal.
Top
Extension Methods
 | Name | Description
Public Extension Method | EndOfAllHistory | (Defined by PluginHostExtensions.)
Public Extension Method | SendAccounts | (Defined by PluginHostExtensions.)
Public Extension Method | SendConnectionState | (Defined by PluginHostExtensions.)
Public Extension Method | SendExecutions | (Defined by PluginHostExtensions.)
Public Extension Method | SendMessage | (Defined by PluginHostExtensions.)
Public Extension Method | SendOrders | (Defined by PluginHostExtensions.)
Public Extension Method | SendPositions | (Defined by PluginHostExtensions.)
Top
Events
 | Name | Description
Public event | PumpMessages | Event occurs each 50 ms and can be used for any periodical actions that the add-in needs to perform.
Public event | SymbolMarketDepthSubscribed | Event occurs when eSignal is requesting Market Depth data from the add-in.
Public event | SymbolMarketDepthUnsubscribed | Event occurs when eSignal stops requesting Market Depth data for a symbol.
Public event | SymbolQuoteSubscribed | Event occurs when eSignal is requesting Quote data from the add-in.
Public event | SymbolQuoteUnsubscribed | Event occurs when eSignal stops requesting Quote data for a symbol.
Public event | SymbolSubscribed | Event occurs when eSignal subscribes to symbol information such as Exchange, Point Value, etc. Most often symbol information request arises when user adds a new symbol to broker dictionary.
Public event | SymbolUnsubscribed | Event occurs when eSignal unsubscribes from symbol information. For example, when process of adding a new symbol has been terminated.
Top
See Also

Reference


IPluginHost Methods

IPluginHost Methods

The IPluginHost type exposes the following members.

Methods
 | Name | Description
Public method | EndAccountHistory | Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical account data from its servers and ready to go real-time processing.
Public method | EndExecutionHistory | Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical execution reports from its servers and ready to go real-time processing.
Public method | EndOrderHistory | Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical orders from its servers and ready to go real-time processing.
Public method | EndPositionHistory | Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical positions from its servers and ready to go real-time processing.
Public method | SendAccount | Sends an update of account field values to eSignal.
Public method | SendConnectionState | Reports connection state of the add-in to eSignal.
Public method | SendExecution | Sends an execution update to eSignal.
Public method | SendMarketDepth | Sends Market Depth data update to eSignal.
Public method | SendMessage | Sends a text message to eSignal. User can find this message in Messages tab of Account Manager and in Connection tab of Broker Manager.
Public method | SendOrder | Sends an order update to eSignal.
Public method | SendPosition | Sends a position update to eSignal.
Public method | SendQuote | Sends Quote data update to eSignal.
Public method | SendSymbol | Sends symbol information to eSignal.
Public method | SetCustomLogsDirectory | Allows to point application to a directory where the add-in is about to store its logs. In case of any unexpected behavior, all the files that are contained in that directory are going to be packed and sent to error reporting service of eSignal.
Top
Extension Methods
 | Name | Description
Public Extension Method | EndOfAllHistory | (Defined by PluginHostExtensions.)
Public Extension Method | SendAccounts | (Defined by PluginHostExtensions.)
Public Extension Method | SendConnectionState | (Defined by PluginHostExtensions.)
Public Extension Method | SendExecutions | (Defined by PluginHostExtensions.)
Public Extension Method | SendMessage | (Defined by PluginHostExtensions.)
Public Extension Method | SendOrders | (Defined by PluginHostExtensions.)
Public Extension Method | SendPositions | (Defined by PluginHostExtensions.)
Top
See Also

Reference

IPluginHost Interface


IPluginHost.EndAccountHistory Method

IPluginHostEndAccountHistory Method
Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical account data from its servers and ready to go real-time processing.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void EndAccountHistory()
void EndAccountHistory()
Remarks

You need to call this method once after you have established a connection and sent account data to eSignal. If you miss this call, the add-in will never get Connected status in the application.

You can call EndOfAllHistory(IPluginHost) instead of calling each of IPluginhost.End[XXXX]History() methods.

See Also

Reference

IPluginHost Interface


IPluginHost.EndExecutionHistory Method

IPluginHostEndExecutionHistory Method
Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical execution reports from its servers and ready to go real-time processing.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void EndExecutionHistory()
void EndExecutionHistory()
Remarks

You need to call this method once after you have established a connection and sent historical execution reports to eSignal. If you miss this call, the add-in will never get Connected status in the application.

You can call EndOfAllHistory(IPluginHost) instead of calling each of IPluginhost.End[XXXX]History() methods.

See Also

Reference

IPluginHost Interface


IPluginHost.EndOrderHistory Method

IPluginHostEndOrderHistory Method
Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical orders from its servers and ready to go real-time processing.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void EndOrderHistory()
void EndOrderHistory()
Remarks

You need to call this method once after you have established a connection and sent historical orders to eSignal. If you miss this call, the add-in will never get Connected status in the application.

You can call EndOfAllHistory(IPluginHost) instead of calling each of IPluginhost.End[XXXX]History() methods.

See Also

Reference

IPluginHost Interface


IPluginHost.EndPositionHistory Method

IPluginHostEndPositionHistory Method
Used during establishing a connection for indicating to eSignal that the add-in has finished receiving historical positions from its servers and ready to go real-time processing.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void EndPositionHistory()
void EndPositionHistory()
Remarks

You need to call this method once after you have established a connection and sent historical positions to eSignal. If you miss this call, the add-in will never get Connected status in the application.

You can call EndOfAllHistory(IPluginHost) instead of calling each of IPluginhost.End[XXXX]History() methods.

See Also

Reference

IPluginHost Interface


IPluginHost.SendAccount Method

IPluginHostSendAccount Method
Sends an update of account field values to eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SendAccount(
    AccountData value
)
void SendAccount(
    AccountData^ value
)

Parameters

value
Type: InteractiveData.eSignalDesktop.TradingAccountData
Account data for sending to eSignal.
See Also

Reference

IPluginHost Interface


IPluginHost.SendConnectionState Method

IPluginHostSendConnectionState Method
Reports connection state of the add-in to eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SendConnectionState(
    ConnectionStateData value
)
void SendConnectionState(
    ConnectionStateData^ value
)

Parameters

value
Type: InteractiveData.eSignalDesktop.TradingConnectionStateData
Connection state parameters for sending to eSignal.
See Also

Reference

IPluginHost Interface


IPluginHost.SendExecution Method

IPluginHostSendExecution Method
Sends an execution update to eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SendExecution(
    ExecutionData value
)
void SendExecution(
    ExecutionData^ value
)

Parameters

value
Type: InteractiveData.eSignalDesktop.TradingExecutionData
Execution parameters for sending to eSignal.
See Also

Reference

IPluginHost Interface


IPluginHost.SendMarketDepth Method

IPluginHostSendMarketDepth Method
Sends Market Depth data update to eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SendMarketDepth(
    MarketDepthData marketDepth
)
void SendMarketDepth(
    MarketDepthData^ marketDepth
)

Parameters

marketDepth
Type: InteractiveData.eSignalDesktop.TradingMarketDepthData
Represents Market Depth data for sending to eSignal.
Remarks
Notice that you should only send data for the Symbol IDs that are subscribed on data. Otherwise you will get a data validation exception.
See Also

Reference

IPluginHost Interface


IPluginHost.SendMessage Method

IPluginHostSendMessage Method
Sends a text message to eSignal. User can find this message in Messages tab of Account Manager and in Connection tab of Broker Manager.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SendMessage(
    MessageData value
)
void SendMessage(
    MessageData^ value
)

Parameters

value
Type: InteractiveData.eSignalDesktop.TradingMessageData
Message for sending to eSignal.
See Also

Reference

IPluginHost Interface


IPluginHost.SendOrder Method

IPluginHostSendOrder Method
Sends an order update to eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SendOrder(
    OrderData value
)
void SendOrder(
    OrderData^ value
)

Parameters

value
Type: InteractiveData.eSignalDesktop.TradingOrderData
Order parameters for sending to eSignal.
See Also

Reference

IPluginHost Interface


IPluginHost.SendPosition Method

IPluginHostSendPosition Method
Sends a position update to eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SendPosition(
    PositionData value
)
void SendPosition(
    PositionData^ value
)

Parameters

value
Type: InteractiveData.eSignalDesktop.TradingPositionData
Position parameters for sending to eSignal.
See Also

Reference

IPluginHost Interface


IPluginHost.SendQuote Method

IPluginHostSendQuote Method
Sends Quote data update to eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SendQuote(
    QuoteData daily
)
void SendQuote(
    QuoteData^ daily
)

Parameters

daily
Type: InteractiveData.eSignalDesktop.TradingQuoteData
Represents data for sending to eSignal.
Remarks
Notice that you should only send data for the Symbol IDs that are subscribed on data. Otherwise you will get a data validation exception.
See Also

Reference

IPluginHost Interface


IPluginHost.SendSymbol Method

IPluginHostSendSymbol Method
Sends symbol information to eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SendSymbol(
    string OriginalSymbolId,
    SymbolData symbol
)
void SendSymbol(
    String^ OriginalSymbolId,
    SymbolData^ symbol
)

Parameters

OriginalSymbolId
Type: SystemString
Original symbol name entered by user.
symbol
Type: InteractiveData.eSignalDesktop.TradingSymbolData
Symbol information for requested symbol that will be sent to eSignal.
See Also

Reference

IPluginHost Interface


IPluginHost.SetCustomLogsDirectory Method

IPluginHostSetCustomLogsDirectory Method
Allows to point application to a directory where the add-in is about to store its logs. In case of any unexpected behavior, all the files that are contained in that directory are going to be packed and sent to error reporting service of eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
void SetCustomLogsDirectory(
    string Value
)
void SetCustomLogsDirectory(
    String^ Value
)

Parameters

Value
Type: SystemString
Path to custom log directory.
See Also

Reference

IPluginHost Interface


IPluginHost Events

IPluginHost Events

The IPluginHost type exposes the following members.

Events
 | Name | Description
Public event | PumpMessages | Event occurs each 50 ms and can be used for any periodical actions that the add-in needs to perform.
Public event | SymbolMarketDepthSubscribed | Event occurs when eSignal is requesting Market Depth data from the add-in.
Public event | SymbolMarketDepthUnsubscribed | Event occurs when eSignal stops requesting Market Depth data for a symbol.
Public event | SymbolQuoteSubscribed | Event occurs when eSignal is requesting Quote data from the add-in.
Public event | SymbolQuoteUnsubscribed | Event occurs when eSignal stops requesting Quote data for a symbol.
Public event | SymbolSubscribed | Event occurs when eSignal subscribes to symbol information such as Exchange, Point Value, etc. Most often symbol information request arises when user adds a new symbol to broker dictionary.
Public event | SymbolUnsubscribed | Event occurs when eSignal unsubscribes from symbol information. For example, when process of adding a new symbol has been terminated.
Top
See Also

Reference

IPluginHost Interface


IPluginHost.PumpMessages Event

IPluginHostPumpMessages Event
Event occurs each 50 ms and can be used for any periodical actions that the add-in needs to perform.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
event PumpMessagesEventHandler PumpMessages
 event PumpMessagesEventHandler^ PumpMessages {
    void add (PumpMessagesEventHandler^ value);
    void remove (PumpMessagesEventHandler^ value);
}

Value

Type: InteractiveData.eSignalDesktop.TradingPumpMessagesEventHandler
See Also

Reference

IPluginHost Interface


IPluginHost.SymbolMarketDepthSubscribed Event

IPluginHostSymbolMarketDepthSubscribed Event
Event occurs when eSignal is requesting Market Depth data from the add-in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
event SymbolEventHandler SymbolMarketDepthSubscribed
 event SymbolEventHandler^ SymbolMarketDepthSubscribed {
    void add (SymbolEventHandler^ value);
    void remove (SymbolEventHandler^ value);
}

Value

Type: InteractiveData.eSignalDesktop.TradingSymbolEventHandler
See Also

Reference

IPluginHost Interface


IPluginHost.SymbolMarketDepthUnsubscribed Event

IPluginHostSymbolMarketDepthUnsubscribed Event
Event occurs when eSignal stops requesting Market Depth data for a symbol.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
event SymbolEventHandler SymbolMarketDepthUnsubscribed
 event SymbolEventHandler^ SymbolMarketDepthUnsubscribed {
    void add (SymbolEventHandler^ value);
    void remove (SymbolEventHandler^ value);
}

Value

Type: InteractiveData.eSignalDesktop.TradingSymbolEventHandler
See Also

Reference

IPluginHost Interface


IPluginHost.SymbolQuoteSubscribed Event

IPluginHostSymbolQuoteSubscribed Event
Event occurs when eSignal is requesting Quote data from the add-in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
event SymbolEventHandler SymbolQuoteSubscribed
 event SymbolEventHandler^ SymbolQuoteSubscribed {
    void add (SymbolEventHandler^ value);
    void remove (SymbolEventHandler^ value);
}

Value

Type: InteractiveData.eSignalDesktop.TradingSymbolEventHandler
See Also

Reference

IPluginHost Interface


IPluginHost.SymbolQuoteUnsubscribed Event

IPluginHostSymbolQuoteUnsubscribed Event
Event occurs when eSignal stops requesting Quote data for a symbol.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
event SymbolEventHandler SymbolQuoteUnsubscribed
 event SymbolEventHandler^ SymbolQuoteUnsubscribed {
    void add (SymbolEventHandler^ value);
    void remove (SymbolEventHandler^ value);
}

Value

Type: InteractiveData.eSignalDesktop.TradingSymbolEventHandler
See Also

Reference

IPluginHost Interface


IPluginHost.SymbolSubscribed Event

IPluginHostSymbolSubscribed Event
Event occurs when eSignal subscribes to symbol information such as Exchange, Point Value, etc. Most often symbol information request arises when user adds a new symbol to broker dictionary.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
event SymbolEventHandler SymbolSubscribed
 event SymbolEventHandler^ SymbolSubscribed {
    void add (SymbolEventHandler^ value);
    void remove (SymbolEventHandler^ value);
}

Value

Type: InteractiveData.eSignalDesktop.TradingSymbolEventHandler
See Also

Reference

IPluginHost Interface


IPluginHost.SymbolUnsubscribed Event

IPluginHostSymbolUnsubscribed Event
Event occurs when eSignal unsubscribes from symbol information. For example, when process of adding a new symbol has been terminated.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
event SymbolEventHandler SymbolUnsubscribed
 event SymbolEventHandler^ SymbolUnsubscribed {
    void add (SymbolEventHandler^ value);
    void remove (SymbolEventHandler^ value);
}

Value

Type: InteractiveData.eSignalDesktop.TradingSymbolEventHandler
See Also

Reference

IPluginHost Interface


IPriceControl Interface

IPriceControl Interface
Gives access to limit and stop price field. Should be used inside of IOrderTicket interface.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface IPriceControl : IOrderTicketControl
public interface class IPriceControl : IOrderTicketControl

The IPriceControl type exposes the following members.

Properties
 | Name | Description
Public property | Value | Value of price field.
Top
See Also

Reference


IPriceControl Properties

IPriceControl Properties

The IPriceControl type exposes the following members.

Properties
 | Name | Description
Public property | Value | Value of price field.
Top
See Also

Reference

IPriceControl Interface


IPriceControl.Value Property

IPriceControlValue Property
Value of price field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
Nullable<double> Value { get; }
property Nullable<double> Value {
    Nullable<double> get ();
}

Property Value

Type: Nullable Double
See Also

Reference

IPriceControl Interface


ISettingsPage Interface

ISettingsPage Interface
Base interface for creating settings pages, such as Symbol Lookup dialog, Connection Settings dialog.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface ISettingsPage
public interface class ISettingsPage

The ISettingsPage type exposes the following members.

Methods
 | Name | Description
Public method | OnApply | Validate values and tell if the dialog can be closed or not.
Top
Properties
 | Name | Description
Public property | Form |
Top
See Also

Reference


ISettingsPage Methods

ISettingsPage Methods

The ISettingsPage type exposes the following members.

Methods
 | Name | Description
Public method | OnApply | Validate values and tell if the dialog can be closed or not.
Top
See Also

Reference

ISettingsPage Interface


ISettingsPage.OnApply Method

ISettingsPageOnApply Method
Validate values and tell if the dialog can be closed or not.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
bool OnApply()
bool OnApply()

Return Value

Type: Boolean
See Also

Reference

ISettingsPage Interface


ISettingsPage Properties

ISettingsPage Properties

The ISettingsPage type exposes the following members.

Properties
 | Name | Description
Public property | Form |
Top
See Also

Reference

ISettingsPage Interface


ISettingsPage.Form Property

ISettingsPageForm Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
Form Form { get; }
property Form^ Form {
    Form^ get ();
}

Property Value

Type: Form
See Also

Reference

ISettingsPage Interface


ISymbolLookupPage Interface

ISymbolLookupPage Interface
Custom connection settings page creator.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface ISymbolLookupPage : ISettingsPage
public interface class ISymbolLookupPage : ISettingsPage

The ISymbolLookupPage type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Top
See Also

Reference


ISymbolLookupPage Properties

ISymbolLookupPage Properties

The ISymbolLookupPage type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Top
See Also

Reference

ISymbolLookupPage Interface


ISymbolLookupPage.Data Property

ISymbolLookupPageData Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string Data { get; set; }
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISymbolLookupPage Interface


ITextControl Interface

ITextControl Interface
Gives access to account or position field. Should be used inside of IOrderTicket interface.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public interface ITextControl : IOrderTicketControl
public interface class ITextControl : IOrderTicketControl

The ITextControl type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Possible values that are available in field control.
Public property | Value | The value of field.
Top
See Also

Reference


ITextControl Properties

ITextControl Properties

The ITextControl type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Possible values that are available in field control.
Public property | Value | The value of field.
Top
See Also

Reference

ITextControl Interface


ITextControl.Domain Property

ITextControlDomain Property
Possible values that are available in field control.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string[] Domain { get; set; }
property array<String^>^ Domain {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
See Also

Reference

ITextControl Interface


ITextControl.Value Property

ITextControlValue Property
The value of field.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
string Value { get; }
property String^ Value {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ITextControl Interface


MarketDepthData Class

MarketDepthData Class
Structure for providing 'depth of market' data.
Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.TradingMarketDepthData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class MarketDepthData : IRecordData
public ref class MarketDepthData sealed : IRecordData

The MarketDepthData type exposes the following members.

Constructors
 | Name | Description
Public method | MarketDepthData | Initializes a new instance of the MarketDepthData class.
Top
Properties
 | Name | Description
Public property | Asks | A collection of ask entries.
Public property | Bids | A collection of bid entries.
Public property | Id | Unique identifier.
Top
See Also

Reference


MarketDepthData Constructor

MarketDepthData Constructor
Initializes a new instance of the MarketDepthData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public MarketDepthData(
    string symbol
)
public:
MarketDepthData(
    String^ symbol
)

Parameters

symbol
Type: SystemString
Instrument name.
See Also

Reference

MarketDepthData Class


MarketDepthData Properties

MarketDepthData Properties

The MarketDepthData type exposes the following members.

Properties
 | Name | Description
Public property | Asks | A collection of ask entries.
Public property | Bids | A collection of bid entries.
Public property | Id | Unique identifier.
Top
See Also

Reference

MarketDepthData Class


MarketDepthData.Asks Property

MarketDepthDataAsks Property
A collection of ask entries.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public MarketDepthDataEntry[] Asks { get; set; }
public:
property array<MarketDepthDataEntry>^ Asks {
    array<MarketDepthDataEntry>^ get ();
    void set (array<MarketDepthDataEntry>^ value);
}

Property Value

Type: MarketDepthDataEntry
See Also

Reference

MarketDepthData Class


MarketDepthData.Bids Property

MarketDepthDataBids Property
A collection of bid entries.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public MarketDepthDataEntry[] Bids { get; set; }
public:
property array<MarketDepthDataEntry>^ Bids {
    array<MarketDepthDataEntry>^ get ();
    void set (array<MarketDepthDataEntry>^ value);
}

Property Value

Type: MarketDepthDataEntry
See Also

Reference

MarketDepthData Class


MarketDepthData.Id Property

MarketDepthDataId Property
Unique identifier.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Id { get; }
public:
virtual property String^ Id {
    String^ get () sealed;
}

Property Value

Type: String
See Also

Reference

MarketDepthData Class


MarketDepthData.Entry Structure

MarketDepthDataEntry Structure
Represents single ladder level.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public struct Entry
public value class Entry

The MarketDepthDataEntry type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ValueTypeToString.)
Top
Fields
 | Name | Description
Public field | MarketMakerID | Optional parameter representing market participant.
Public field | Price | Price value of this entry.
Public field | Size | Ask or bid quantity at this level.
Top
See Also

Reference


Entry Fields

Entry Fields

The MarketDepthDataEntry type exposes the following members.

Fields
 | Name | Description
Public field | MarketMakerID | Optional parameter representing market participant.
Public field | Price | Price value of this entry.
Public field | Size | Ask or bid quantity at this level.
Top
See Also

Reference

MarketDepthDataEntry Structure


MarketDepthData.Entry.MarketMakerID Field

MarketDepthDataEntryMarketMakerID Field
Optional parameter representing market participant.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string MarketMakerID
public:
String^ MarketMakerID

Field Value

Type: String
See Also

Reference

MarketDepthDataEntry Structure


MarketDepthData.Entry.Price Field

MarketDepthDataEntryPrice Field
Price value of this entry.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public double Price
public:
double Price

Field Value

Type: Double
See Also

Reference

MarketDepthDataEntry Structure


MarketDepthData.Entry.Size Field

MarketDepthDataEntrySize Field
Ask or bid quantity at this level.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int Size
public:
int Size

Field Value

Type: Int32
See Also

Reference

MarketDepthDataEntry Structure


Entry Methods

Entry Methods

The MarketDepthDataEntry type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ValueTypeToString.)
Top
See Also

Reference

MarketDepthDataEntry Structure


MarketDepthData.Entry.ToString Method

MarketDepthDataEntryToString Method

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
Checks if MarketMarkerID has been defined and returns string in format 'Size @ Price' or 'Size @ Price, MarketMakerID'.
See Also

Reference

MarketDepthDataEntry Structure


MessageData Class

MessageData Class
Designates message data structure.
Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.TradingMessageData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class MessageData : IRecordData
public ref class MessageData sealed : IRecordData

The MessageData type exposes the following members.

Constructors
 | Name | Description
Public method | MessageData | Initializes a new instance of the MessageData class.
Top
Properties
 | Name | Description
Public property | Id | Identifier that is used in the application to recognize the message.
Public property | Text |
Top
See Also

Reference


MessageData Constructor

MessageData Constructor
Initializes a new instance of the MessageData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public MessageData(
    string text
)
public:
MessageData(
    String^ text
)

Parameters

text
Type: SystemString
The text of a message.
See Also

Reference

MessageData Class


MessageData Properties

MessageData Properties

The MessageData type exposes the following members.

Properties
 | Name | Description
Public property | Id | Identifier that is used in the application to recognize the message.
Public property | Text |
Top
See Also

Reference

MessageData Class


MessageData.Id Property

MessageDataId Property
Identifier that is used in the application to recognize the message.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
See Also

Reference

MessageData Class


MessageData.Text Property

MessageDataText Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MessageData Class


OrderAction Enumeration

OrderAction Enumeration
Represents action of an order.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum OrderAction
public enum class OrderAction
Members
Member name | Value | Description
Buy | 0 | Buy to add to a long position.
Sell | 1 | Sell to reduce a long position.
SellShort | 2 | Sell to add to a short position.
BuyToCover | 3 | Buy to reduce a short position.
Remarks
Having four order actions allows you to distinguish orders which open a position and orders which close a position. If you do not need to make difference between them, you can use just Buy and Sell.
See Also

Reference


OrderData Class

OrderData Class
Designates order data structure.
Inheritance Hierarchy
SystemObject
RecordData
InteractiveData.eSignalDesktop.TradingSymbolBasedData
InteractiveData.eSignalDesktop.TradingOrderData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public class OrderData : SymbolBasedData
public ref class OrderData : public SymbolBasedData

The OrderData type exposes the following members.

Constructors
 | Name | Description
Public method | OrderData | Initializes a new instance of the OrderData class.
Top
Properties
 | Name | Description
Public property | Account | Name of user account at the Broker where the order is placed.
Public property | Action | Action of the order.
Public property | AveragePrice | Average fill price of the order. If order is filled, this field must have proper value. Otherwise it should be empty.
Public property | BrokerID | This field allows to pass to the application order identifier, that should be visible to user. For example, one, that later can be used by user to reference this order on a phone with broker representative.
Public property | FilledQuantity | Filled quantity of the order. If order is partially or completely filled, this field must have proper value.
Public property | IsMultilegOrder | Returns true if LegSymbols value is not null.
Public property | LegActions | Actions of legs that are to be part of a multileg order.
Public property | LegQuantities | Quantity of legs that are to be part of a multileg order.
Public property | LegSymbols | Symbols of legs that are to be part of a multileg order.
Public property | LimitPrice | Limit price of the order.
Public property | State | Actual order status.
Public property | StateText | Name of the order state in UI. If not set, it coincides with order state name from State property.
Public property | StopPrice | Stop price of the order.
Public property | TotalQuantity | Quantity of the order.
Public property | Type | Type of the order. For example, Market, Limit, etc.
Top
See Also

Reference


OrderData Constructor

OrderData Constructor
Initializes a new instance of the OrderData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderData(
    string Id,
    string Symbol
)
public:
OrderData(
    String^ Id,
    String^ Symbol
)

Parameters

Id
Type: SystemString
Identifier that is used in the application to recognize the order. This identifire is not visible to the user.
Symbol
Type: SystemString
Instrument name.
See Also

Reference

OrderData Class


OrderData Properties

OrderData Properties

The OrderData type exposes the following members.

Properties
 | Name | Description
Public property | Account | Name of user account at the Broker where the order is placed.
Public property | Action | Action of the order.
Public property | AveragePrice | Average fill price of the order. If order is filled, this field must have proper value. Otherwise it should be empty.
Public property | BrokerID | This field allows to pass to the application order identifier, that should be visible to user. For example, one, that later can be used by user to reference this order on a phone with broker representative.
Public property | FilledQuantity | Filled quantity of the order. If order is partially or completely filled, this field must have proper value.
Public property | IsMultilegOrder | Returns true if LegSymbols value is not null.
Public property | LegActions | Actions of legs that are to be part of a multileg order.
Public property | LegQuantities | Quantity of legs that are to be part of a multileg order.
Public property | LegSymbols | Symbols of legs that are to be part of a multileg order.
Public property | LimitPrice | Limit price of the order.
Public property | State | Actual order status.
Public property | StateText | Name of the order state in UI. If not set, it coincides with order state name from State property.
Public property | StopPrice | Stop price of the order.
Public property | TotalQuantity | Quantity of the order.
Public property | Type | Type of the order. For example, Market, Limit, etc.
Top
See Also

Reference

OrderData Class


OrderData.Account Property

OrderDataAccount Property
Name of user account at the Broker where the order is placed.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[OrderAccountAttribute]
public string Account { get; set; }
public:
[OrderAccountAttribute]
property String^ Account {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OrderData Class


OrderData.Action Property

OrderDataAction Property
Action of the order.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[OrderActionAttribute]
public Nullable<OrderAction> Action { get; set; }
public:
[OrderActionAttribute]
property Nullable<OrderAction> Action {
    Nullable<OrderAction> get ();
    void set (Nullable<OrderAction> value);
}

Property Value

Type: Nullable OrderAction
See Also

Reference

OrderData Class


OrderData.AveragePrice Property

OrderDataAveragePrice Property
Average fill price of the order. If order is filled, this field must have proper value. Otherwise it should be empty.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<double> AveragePrice { get; set; }
public:
property Nullable<double> AveragePrice {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
See Also

Reference

OrderData Class


OrderData.BrokerID Property

OrderDataBrokerID Property
This field allows to pass to the application order identifier, that should be visible to user. For example, one, that later can be used by user to reference this order on a phone with broker representative.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string BrokerID { get; set; }
public:
property String^ BrokerID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OrderData Class


OrderData.FilledQuantity Property

OrderDataFilledQuantity Property
Filled quantity of the order. If order is partially or completely filled, this field must have proper value.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int FilledQuantity { get; set; }
public:
property int FilledQuantity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

OrderData Class


OrderData.IsMultilegOrder Property

OrderDataIsMultilegOrder Property
Returns true if LegSymbols value is not null.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool IsMultilegOrder { get; }
public:
property bool IsMultilegOrder {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

OrderData Class


OrderData.LegActions Property

OrderDataLegActions Property
Actions of legs that are to be part of a multileg order.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderAction[] LegActions { get; set; }
public:
property array<OrderAction>^ LegActions {
    array<OrderAction>^ get ();
    void set (array<OrderAction>^ value);
}

Property Value

Type: OrderAction
See Also

Reference

OrderData Class


OrderData.LegQuantities Property

OrderDataLegQuantities Property
Quantity of legs that are to be part of a multileg order.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int[] LegQuantities { get; set; }
public:
property array<int>^ LegQuantities {
    array<int>^ get ();
    void set (array<int>^ value);
}

Property Value

Type: Int32
See Also

Reference

OrderData Class


OrderData.LegSymbols Property

OrderDataLegSymbols Property
Symbols of legs that are to be part of a multileg order.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string[] LegSymbols { get; set; }
public:
property array<String^>^ LegSymbols {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
See Also

Reference

OrderData Class


OrderData.LimitPrice Property

OrderDataLimitPrice Property
Limit price of the order.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[OrderLimitPriceAttribute]
public Nullable<double> LimitPrice { get; set; }
public:
[OrderLimitPriceAttribute]
property Nullable<double> LimitPrice {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
Remarks
Should contain value only for order types that require this type of price. Otherwise it should be empty.
See Also

Reference

OrderData Class


OrderData.State Property

OrderDataState Property
Actual order status.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderState State { get; set; }
public:
property OrderState State {
    OrderState get ();
    void set (OrderState value);
}

Property Value

Type: OrderState
See Also

Reference

OrderData Class


OrderData.StateText Property

OrderDataStateText Property
Name of the order state in UI. If not set, it coincides with order state name from State property.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string StateText { get; set; }
public:
property String^ StateText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OrderData Class


OrderData.StopPrice Property

OrderDataStopPrice Property
Stop price of the order.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[OrderStopPriceAttribute]
public Nullable<double> StopPrice { get; set; }
public:
[OrderStopPriceAttribute]
property Nullable<double> StopPrice {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
Remarks
Should contain value only for order types that require this type of price. Otherwise it should be empty.
See Also

Reference

OrderData Class


OrderData.TotalQuantity Property

OrderDataTotalQuantity Property
Quantity of the order.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[OrderQuantityAttribute]
public int TotalQuantity { get; set; }
public:
[OrderQuantityAttribute]
property int TotalQuantity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

OrderData Class


OrderData.Type Property

OrderDataType Property
Type of the order. For example, Market, Limit, etc.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[OrderTypeAttribute]
public OrderType Type { get; set; }
public:
[OrderTypeAttribute]
property OrderType Type {
    OrderType get ();
    void set (OrderType value);
}

Property Value

Type: OrderType
See Also

Reference

OrderData Class


OrderExpiry Enumeration

OrderExpiry Enumeration
Represents order expiration types (time-in-force).

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum OrderExpiry
public enum class OrderExpiry
Members
Member name | Value | Description
GoodTillCancel | 0 |
GoodTillCancelExt | 1 |
GoodTillDate | 2 |
DayOrder | 3 |
DayOrderExt | 4 |
Am | 5 |
Pm | 6 |
MarketOnClose | 7 |
MarketOnOpen | 8 |
ImmediateOrCancel | 9 |
DayNB | 10 |
ExtendedHours | 11 |
AtTheOpening | 12 |
FillOrKill | 13 |
OPG | 14 |
See Also

Reference


OrderState Enumeration

OrderState Enumeration
Represents state of an order.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum OrderState
public enum class OrderState
Members
Member name | Value | Description
Queue | 0 | Order is in a queue for placing or modification.
Working | 1 | Order is active at the Broker.
Rejected | 2 | Order is rejected at the Broker.
Canceled | 3 | Order is canceled.
Filled | 4 | Order is completely filled.
See Also

Reference


OrderTicketMode Enumeration

OrderTicketMode Enumeration
A mode that the order ticket can be in.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum OrderTicketMode
public enum class OrderTicketMode
Members
Member name | Value | Description
PlaceOrder | 0 | Order ticket was opened to create new order.
ReplaceOrder | 1 | Order ticket was opened to modify existing order.
PlaceMultilegOrder | 2 | Order ticket was opened to create new multileg order.
See Also

Reference


OrderType Structure

OrderType Structure
Specifies order type.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public struct OrderType
public value class OrderType

The OrderType type exposes the following members.

Constructors
 | Name | Description
Public method | OrderType | Initializes a new instance of the OrderType class
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ValueTypeToString.)
Top
Properties
 | Name | Description
Public property | IsValid | Tells if this object has valid value.
Public property | Value | Value for referencing this order type internally, in the add-in code.
Top
See Also

Reference


OrderType Constructor

OrderType Constructor
Initializes a new instance of the OrderType class

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderType(
    Object Value
)
public:
OrderType(
    Object^ Value
)

Parameters

Value
Type: SystemObject
See Also

Reference

OrderType Structure


OrderType Methods

OrderType Methods

The OrderType type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ValueTypeToString.)
Top
See Also

Reference

OrderType Structure


OrderType.ToString Method

OrderTypeToString Method

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
Returns empty if value is not valid.
See Also

Reference

OrderType Structure


OrderType Properties

OrderType Properties

The OrderType type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Tells if this object has valid value.
Public property | Value | Value for referencing this order type internally, in the add-in code.
Top
See Also

Reference

OrderType Structure


OrderType.IsValid Property

OrderTypeIsValid Property
Tells if this object has valid value.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool IsValid { get; }
public:
property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

OrderType Structure


OrderType.Value Property

OrderTypeValue Property
Value for referencing this order type internally, in the add-in code.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Object Value { get; }
public:
property Object^ Value {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

OrderType Structure


OrderTypeDeclaration Class

OrderTypeDeclaration Class
Describes single order type supported by the broker.
Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.TradingOrderTypeDeclaration

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderTypeDeclaration
public ref class OrderTypeDeclaration sealed

The OrderTypeDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | OrderTypeDeclaration(StandardOrderType) | Initializes a new instance of the OrderTypeDeclaration class
Public method | OrderTypeDeclaration(String, OrderType) | Initializes a new instance of the OrderTypeDeclaration class
Public method | OrderTypeDeclaration(StandardOrderType, OrderType) | Initializes a new instance of the OrderTypeDeclaration class
Public method | OrderTypeDeclaration(StandardOrderType, String) | Initializes a new instance of the OrderTypeDeclaration class
Public method | OrderTypeDeclaration(StandardOrderType, String, OrderType) | Initializes a new instance of the OrderTypeDeclaration class
Top
Properties
 | Name | Description
Public property | DisplayName | This is how your order type is going to be named in UI.
Public property | Type | Standard order type to be used.
Public property | UserType | Actual order type to be used.
Top
See Also

Reference


OrderTypeDeclaration Constructor

OrderTypeDeclaration Constructor
Overload List
 | Name | Description
Public method | OrderTypeDeclaration(StandardOrderType) | Initializes a new instance of the OrderTypeDeclaration class
Public method | OrderTypeDeclaration(String, OrderType) | Initializes a new instance of the OrderTypeDeclaration class
Public method | OrderTypeDeclaration(StandardOrderType, OrderType) | Initializes a new instance of the OrderTypeDeclaration class
Public method | OrderTypeDeclaration(StandardOrderType, String) | Initializes a new instance of the OrderTypeDeclaration class
Public method | OrderTypeDeclaration(StandardOrderType, String, OrderType) | Initializes a new instance of the OrderTypeDeclaration class
Top
See Also

Reference

OrderTypeDeclaration Class


OrderTypeDeclaration Constructor (StandardOrderType)

OrderTypeDeclaration Constructor (StandardOrderType)
Initializes a new instance of the OrderTypeDeclaration class

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderTypeDeclaration(
    StandardOrderType Type
)
public:
OrderTypeDeclaration(
    StandardOrderType Type
)

Parameters

Type
Type: InteractiveData.eSignalDesktop.TradingStandardOrderType
See Also

Reference

OrderTypeDeclaration Class
OrderTypeDeclaration Overload


OrderTypeDeclaration Constructor (String, OrderType)

OrderTypeDeclaration Constructor (String, OrderType)
Initializes a new instance of the OrderTypeDeclaration class

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderTypeDeclaration(
    string DisplayName,
    OrderType UserType
)
public:
OrderTypeDeclaration(
    String^ DisplayName,
    OrderType UserType
)

Parameters

DisplayName
Type: SystemString
UserType
Type: InteractiveData.eSignalDesktop.TradingOrderType
See Also

Reference

OrderTypeDeclaration Class
OrderTypeDeclaration Overload


OrderTypeDeclaration Constructor (StandardOrderType, OrderType)

OrderTypeDeclaration Constructor (StandardOrderType, OrderType)
Initializes a new instance of the OrderTypeDeclaration class

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderTypeDeclaration(
    StandardOrderType Type,
    OrderType UserType
)
public:
OrderTypeDeclaration(
    StandardOrderType Type,
    OrderType UserType
)

Parameters

Type
Type: InteractiveData.eSignalDesktop.TradingStandardOrderType
UserType
Type: InteractiveData.eSignalDesktop.TradingOrderType
See Also

Reference

OrderTypeDeclaration Class
OrderTypeDeclaration Overload


OrderTypeDeclaration Constructor (StandardOrderType, String)

OrderTypeDeclaration Constructor (StandardOrderType, String)
Initializes a new instance of the OrderTypeDeclaration class

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderTypeDeclaration(
    StandardOrderType Type,
    string DisplayName
)
public:
OrderTypeDeclaration(
    StandardOrderType Type,
    String^ DisplayName
)

Parameters

Type
Type: InteractiveData.eSignalDesktop.TradingStandardOrderType
DisplayName
Type: SystemString
See Also

Reference

OrderTypeDeclaration Class
OrderTypeDeclaration Overload


OrderTypeDeclaration Constructor (StandardOrderType, String, OrderType)

OrderTypeDeclaration Constructor (StandardOrderType, String, OrderType)
Initializes a new instance of the OrderTypeDeclaration class

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderTypeDeclaration(
    StandardOrderType Type,
    string DisplayName,
    OrderType UserType
)
public:
OrderTypeDeclaration(
    StandardOrderType Type,
    String^ DisplayName,
    OrderType UserType
)

Parameters

Type
Type: InteractiveData.eSignalDesktop.TradingStandardOrderType
DisplayName
Type: SystemString
UserType
Type: InteractiveData.eSignalDesktop.TradingOrderType
See Also

Reference

OrderTypeDeclaration Class
OrderTypeDeclaration Overload


OrderTypeDeclaration Properties

OrderTypeDeclaration Properties

The OrderTypeDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | This is how your order type is going to be named in UI.
Public property | Type | Standard order type to be used.
Public property | UserType | Actual order type to be used.
Top
See Also

Reference

OrderTypeDeclaration Class


OrderTypeDeclaration.DisplayName Property

OrderTypeDeclarationDisplayName Property
This is how your order type is going to be named in UI.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string DisplayName { get; }
public:
property String^ DisplayName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

OrderTypeDeclaration Class


OrderTypeDeclaration.Type Property

OrderTypeDeclarationType Property
Standard order type to be used.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<StandardOrderType> Type { get; }
public:
property Nullable<StandardOrderType> Type {
    Nullable<StandardOrderType> get ();
}

Property Value

Type: Nullable StandardOrderType
See Also

Reference

OrderTypeDeclaration Class


OrderTypeDeclaration.UserType Property

OrderTypeDeclarationUserType Property
Actual order type to be used.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderType UserType { get; }
public:
property OrderType UserType {
    OrderType get ();
}

Property Value

Type: OrderType
See Also

Reference

OrderTypeDeclaration Class


PluginHostExtensions Class

PluginHostExtensions Class
Class contains extensions of some IPluginHost methods for processing multiple objects in one command.
Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.TradingPluginHostExtensions

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public static class PluginHostExtensions
[ExtensionAttribute]
public ref class PluginHostExtensions abstract sealed

The PluginHostExtensions type exposes the following members.

Methods
Name | Description
EndOfAllHistory |
SendAccounts |
SendConnectionState |
SendExecutions |
SendMessage |
SendOrders |
SendPositions |
Top
See Also

Reference


PluginHostExtensions Methods

PluginHostExtensions Methods

The PluginHostExtensions type exposes the following members.

Methods
Name | Description
EndOfAllHistory |
SendAccounts |
SendConnectionState |
SendExecutions |
SendMessage |
SendOrders |
SendPositions |
Top
See Also

Reference

PluginHostExtensions Class


PluginHostExtensions.EndOfAllHistory Method

PluginHostExtensionsEndOfAllHistory Method

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public static void EndOfAllHistory(
    this IPluginHost Host
)
public:
[ExtensionAttribute]
static void EndOfAllHistory(
    IPluginHost^ Host
)

Parameters

Host
Type: InteractiveData.eSignalDesktop.TradingIPluginHost

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPluginHost. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PluginHostExtensions Class


PluginHostExtensions.SendAccounts Method

PluginHostExtensionsSendAccounts Method

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public static void SendAccounts(
    this IPluginHost Host,
    IEnumerable<AccountData> Accounts
)
public:
[ExtensionAttribute]
static void SendAccounts(
    IPluginHost^ Host,
    IEnumerable<AccountData^>^ Accounts
)

Parameters

Host
Type: InteractiveData.eSignalDesktop.TradingIPluginHost
Accounts
Type: System.Collections.GenericIEnumerable AccountData

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPluginHost. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PluginHostExtensions Class


PluginHostExtensions.SendConnectionState Method

PluginHostExtensionsSendConnectionState Method

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public static void SendConnectionState(
    this IPluginHost Host,
    ConnectionState State
)
public:
[ExtensionAttribute]
static void SendConnectionState(
    IPluginHost^ Host,
    ConnectionState State
)

Parameters

Host
Type: InteractiveData.eSignalDesktop.TradingIPluginHost
State
Type: InteractiveData.eSignalDesktop.TradingConnectionState

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPluginHost. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PluginHostExtensions Class


PluginHostExtensions.SendExecutions Method

PluginHostExtensionsSendExecutions Method

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public static void SendExecutions(
    this IPluginHost Host,
    IEnumerable<ExecutionData> Executions
)
public:
[ExtensionAttribute]
static void SendExecutions(
    IPluginHost^ Host,
    IEnumerable<ExecutionData^>^ Executions
)

Parameters

Host
Type: InteractiveData.eSignalDesktop.TradingIPluginHost
Executions
Type: System.Collections.GenericIEnumerable ExecutionData

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPluginHost. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PluginHostExtensions Class


PluginHostExtensions.SendMessage Method

PluginHostExtensionsSendMessage Method

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public static void SendMessage(
    this IPluginHost Host,
    string Message,
    params Object[] Args
)
public:
[ExtensionAttribute]
static void SendMessage(
    IPluginHost^ Host,
    String^ Message,
    ... array<Object^>^ Args
)

Parameters

Host
Type: InteractiveData.eSignalDesktop.TradingIPluginHost
Message
Type: SystemString
Args
Type: SystemObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPluginHost. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PluginHostExtensions Class


PluginHostExtensions.SendOrders Method

PluginHostExtensionsSendOrders Method

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public static void SendOrders(
    this IPluginHost Host,
    IEnumerable<OrderData> Orders
)
public:
[ExtensionAttribute]
static void SendOrders(
    IPluginHost^ Host,
    IEnumerable<OrderData^>^ Orders
)

Parameters

Host
Type: InteractiveData.eSignalDesktop.TradingIPluginHost
Orders
Type: System.Collections.GenericIEnumerable OrderData

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPluginHost. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PluginHostExtensions Class


PluginHostExtensions.SendPositions Method

PluginHostExtensionsSendPositions Method

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public static void SendPositions(
    this IPluginHost Host,
    IEnumerable<PositionData> Positions
)
public:
[ExtensionAttribute]
static void SendPositions(
    IPluginHost^ Host,
    IEnumerable<PositionData^>^ Positions
)

Parameters

Host
Type: InteractiveData.eSignalDesktop.TradingIPluginHost
Positions
Type: System.Collections.GenericIEnumerable PositionData

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPluginHost. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PluginHostExtensions Class


PositionData Class

PositionData Class
Designates position data structure.
Inheritance Hierarchy
SystemObject
RecordData
InteractiveData.eSignalDesktop.TradingSymbolBasedData
InteractiveData.eSignalDesktop.TradingPositionData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public class PositionData : SymbolBasedData
public ref class PositionData : public SymbolBasedData

The PositionData type exposes the following members.

Constructors
 | Name | Description
Public method | PositionData | Initializes a new instance of the PositionData class.
Top
Properties
 | Name | Description
Public property | Account | Account on which the position is opened.
Public property | AveragePrice | Average price of the position.
Public property | Quantity | Quantity of the open position.
Public property | RealizedProfitLoss | Profit or Loss for the closed position.
Top
See Also

Reference


PositionData Constructor

PositionData Constructor
Initializes a new instance of the PositionData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public PositionData(
    string id,
    string symbolId
)
public:
PositionData(
    String^ id,
    String^ symbolId
)

Parameters

id
Type: SystemString
Identifier that is used in the application to recognize the position. This identifier is not visible to the user.
symbolId
Type: SystemString
Instrument Id.
See Also

Reference

PositionData Class


PositionData Properties

PositionData Properties

The PositionData type exposes the following members.

Properties
 | Name | Description
Public property | Account | Account on which the position is opened.
Public property | AveragePrice | Average price of the position.
Public property | Quantity | Quantity of the open position.
Public property | RealizedProfitLoss | Profit or Loss for the closed position.
Top
See Also

Reference

PositionData Class


PositionData.Account Property

PositionDataAccount Property
Account on which the position is opened.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Account { get; set; }
public:
property String^ Account {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PositionData Class


PositionData.AveragePrice Property

PositionDataAveragePrice Property
Average price of the position.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public double AveragePrice { get; set; }
public:
property double AveragePrice {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks
Should contain a valid value for calculation of Open PL for the position in application and for functioning of MMS feature.
See Also

Reference

PositionData Class


PositionData.Quantity Property

PositionDataQuantity Property
Quantity of the open position.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int Quantity { get; set; }
public:
property int Quantity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PositionData Class


PositionData.RealizedProfitLoss Property

PositionDataRealizedProfitLoss Property
Profit or Loss for the closed position.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public double RealizedProfitLoss { get; set; }
public:
property double RealizedProfitLoss {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionData Class


PumpMessagesEventHandler Delegate

PumpMessagesEventHandler Delegate

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public delegate void PumpMessagesEventHandler()
public delegate void PumpMessagesEventHandler()
See Also

Reference


QuoteData Class

QuoteData Class
Represents quote data (or 'daily data') to be provided by the add-in.
Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.TradingQuoteData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class QuoteData : IRecordData
public ref class QuoteData sealed : IRecordData

The QuoteData type exposes the following members.

Constructors
 | Name | Description
Public method | QuoteData | Initializes a new instance of QuoteData class.
Top
Properties
 | Name | Description
Public property | AskPrice |
Public property | AskSize |
Public property | BidPrice |
Public property | BidSize |
Public property | High |
Public property | Id |
Public property | Low |
Public property | TradePrice | Last traded price.
Public property | TradeSize | Last traded size.
Top
See Also

Reference


QuoteData Constructor

QuoteData Constructor
Initializes a new instance of QuoteData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public QuoteData(
    string Symbol
)
public:
QuoteData(
    String^ Symbol
)

Parameters

Symbol
Type: SystemString
Instrument name.
See Also

Reference

QuoteData Class


QuoteData Properties

QuoteData Properties

The QuoteData type exposes the following members.

Properties
 | Name | Description
Public property | AskPrice |
Public property | AskSize |
Public property | BidPrice |
Public property | BidSize |
Public property | High |
Public property | Id |
Public property | Low |
Public property | TradePrice | Last traded price.
Public property | TradeSize | Last traded size.
Top
See Also

Reference

QuoteData Class


QuoteData.AskPrice Property

QuoteDataAskPrice Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<double> AskPrice { get; set; }
public:
property Nullable<double> AskPrice {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
See Also

Reference

QuoteData Class


QuoteData.AskSize Property

QuoteDataAskSize Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<int> AskSize { get; set; }
public:
property Nullable<int> AskSize {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable Int32
See Also

Reference

QuoteData Class


QuoteData.BidPrice Property

QuoteDataBidPrice Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<double> BidPrice { get; set; }
public:
property Nullable<double> BidPrice {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
See Also

Reference

QuoteData Class


QuoteData.BidSize Property

QuoteDataBidSize Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<int> BidSize { get; set; }
public:
property Nullable<int> BidSize {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable Int32
See Also

Reference

QuoteData Class


QuoteData.High Property

QuoteDataHigh Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<double> High { get; set; }
public:
property Nullable<double> High {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
See Also

Reference

QuoteData Class


QuoteData.Id Property

QuoteDataId Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Id { get; }
public:
virtual property String^ Id {
    String^ get () sealed;
}

Property Value

Type: String
See Also

Reference

QuoteData Class


QuoteData.Low Property

QuoteDataLow Property

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<double> Low { get; set; }
public:
property Nullable<double> Low {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
See Also

Reference

QuoteData Class


QuoteData.TradePrice Property

QuoteDataTradePrice Property
Last traded price.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<double> TradePrice { get; set; }
public:
property Nullable<double> TradePrice {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
See Also

Reference

QuoteData Class


QuoteData.TradeSize Property

QuoteDataTradeSize Property
Last traded size.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<int> TradeSize { get; set; }
public:
property Nullable<int> TradeSize {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable Int32
See Also

Reference

QuoteData Class


SpreadLeg Structure

SpreadLeg Structure
Contains properties of legs for spead symbols.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public struct SpreadLeg
public value class SpreadLeg

The SpreadLeg type exposes the following members.

Properties
 | Name | Description
Public property | ExpirationDay | Expiration day of Future or Option. The field contains expiration day of a symbol as a number of the day in a month.
Public property | ExpirationMonth | Expiration month of Future or Option. The field contains expiration month of a symbol as a number of the month in an year.
Public property | ExpirationWeek | Expiration week of Future or Option The field contains expiration week of a symbol as a number of the week in an year.
Public property | ExpirationYear | Expiration year of Future or Option. The field contains expiration year of a symbol as a number.
Public property | Root | Underlying symbol or contract.
Top
See Also

Reference


SpreadLeg Properties

SpreadLeg Properties

The SpreadLeg type exposes the following members.

Properties
 | Name | Description
Public property | ExpirationDay | Expiration day of Future or Option. The field contains expiration day of a symbol as a number of the day in a month.
Public property | ExpirationMonth | Expiration month of Future or Option. The field contains expiration month of a symbol as a number of the month in an year.
Public property | ExpirationWeek | Expiration week of Future or Option The field contains expiration week of a symbol as a number of the week in an year.
Public property | ExpirationYear | Expiration year of Future or Option. The field contains expiration year of a symbol as a number.
Public property | Root | Underlying symbol or contract.
Top
See Also

Reference

SpreadLeg Structure


SpreadLeg.ExpirationDay Property

SpreadLegExpirationDay Property
Expiration day of Future or Option.

The field contains expiration day of a symbol as a number of the day in a month.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int ExpirationDay { get; set; }
public:
property int ExpirationDay {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Valid for Futures, Options.
See Also

Reference

SpreadLeg Structure


SpreadLeg.ExpirationMonth Property

SpreadLegExpirationMonth Property
Expiration month of Future or Option.

The field contains expiration month of a symbol as a number of the month in an year.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int ExpirationMonth { get; set; }
public:
property int ExpirationMonth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Valid for Futures, Options.
See Also

Reference

SpreadLeg Structure


SpreadLeg.ExpirationWeek Property

SpreadLegExpirationWeek Property
Expiration week of Future or Option

The field contains expiration week of a symbol as a number of the week in an year.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int ExpirationWeek { get; set; }
public:
property int ExpirationWeek {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Valid for Futures, Options.
See Also

Reference

SpreadLeg Structure


SpreadLeg.ExpirationYear Property

SpreadLegExpirationYear Property
Expiration year of Future or Option.

The field contains expiration year of a symbol as a number.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int ExpirationYear { get; set; }
public:
property int ExpirationYear {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Valid for Futures, Options.
See Also

Reference

SpreadLeg Structure


SpreadLeg.Root Property

SpreadLegRoot Property
Underlying symbol or contract.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Root { get; set; }
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SpreadLeg Structure


StandardOrderType Enumeration

StandardOrderType Enumeration
Enumeration representing standard order types.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum StandardOrderType
public enum class StandardOrderType
Members
Member name | Value | Description
Market | 4026531856 | Designates market order.
Limit | 4026531857 | Designates limit order.
Stop | 4026531858 | Designates stop order.
StopLimit | 4026531859 | Designates stop-limit order.
See Also

Reference


SymbolBasedData Class

SymbolBasedData Class
Base class that is inherited by symbol data based classes.
Inheritance Hierarchy
SystemObject
RecordData
InteractiveData.eSignalDesktop.TradingSymbolBasedData
InteractiveData.eSignalDesktop.TradingOrderData
InteractiveData.eSignalDesktop.TradingPositionData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public abstract class SymbolBasedData : RecordData
public ref class SymbolBasedData abstract : public RecordData

The SymbolBasedData type exposes the following members.

Properties
 | Name | Description
Public property | Symbol | Symbol identifier.
Top
See Also

Reference


SymbolBasedData Properties

SymbolBasedData Properties

The SymbolBasedData type exposes the following members.

Properties
 | Name | Description
Public property | Symbol | Symbol identifier.
Top
See Also

Reference

SymbolBasedData Class


SymbolBasedData.Symbol Property

SymbolBasedDataSymbol Property
Symbol identifier.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Symbol { get; set; }
public:
property String^ Symbol {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SymbolBasedData Class


SymbolData Class

SymbolData Class
Designates symbol data structure.
Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.TradingSymbolData

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class SymbolData : IRecordData
public ref class SymbolData sealed : IRecordData

The SymbolData type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolData | Initializes a new instance of the SymbolData class.
Top
Properties
 | Name | Description
Public property | BaseCurrency | Base currency of the currency pair.
Public property | Description | Description of the instrument, usually a full name of the underlying asset.
Public property | Exchange | Source of the quotes.
Public property | Id | Identifier of the instrument.
Public property | MinMovement | Numerator of the price fraction. This is used for any type of price.
Public property | MinMovement2 | A number of fractions that each of the price's fraction can be split into additionally. This is used only for Fractional price type.
 | PointValue | Cost of the whole price point in real-world money.
Public property | PriceScale | Denominator of the price fraction. This is used for any type of price.
Public property | PriceType | Affects price formatting. See SymbolPriceType for available price types.
Public property | QuoteCurrency | Quote currency of the currency pair.
Public property | Type | Type of the instrument.
Public property | Valid | This field must be set to designate if the information is valid or not. Objects with this field value of 'false' can be used to report back that the symbol information is not available.
Top
See Also

Reference


SymbolData Constructor

SymbolData Constructor
Initializes a new instance of the SymbolData class.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SymbolData(
    string Symbol
)
public:
SymbolData(
    String^ Symbol
)

Parameters

Symbol
Type: SystemString
Instrument name.
See Also

Reference

SymbolData Class


SymbolData Properties

SymbolData Properties

The SymbolData type exposes the following members.

Properties
 | Name | Description
Public property | BaseCurrency | Base currency of the currency pair.
Public property | Description | Description of the instrument, usually a full name of the underlying asset.
Public property | Exchange | Source of the quotes.
Public property | Id | Identifier of the instrument.
Public property | MinMovement | Numerator of the price fraction. This is used for any type of price.
Public property | MinMovement2 | A number of fractions that each of the price's fraction can be split into additionally. This is used only for Fractional price type.
 | PointValue | Cost of the whole price point in real-world money.
Public property | PriceScale | Denominator of the price fraction. This is used for any type of price.
Public property | PriceType | Affects price formatting. See SymbolPriceType for available price types.
Public property | QuoteCurrency | Quote currency of the currency pair.
Public property | Type | Type of the instrument.
Public property | Valid | This field must be set to designate if the information is valid or not. Objects with this field value of 'false' can be used to report back that the symbol information is not available.
Top
See Also

Reference

SymbolData Class


SymbolData.BaseCurrency Property

SymbolDataBaseCurrency Property
Base currency of the currency pair.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string BaseCurrency { get; set; }
public:
property String^ BaseCurrency {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SymbolData Class


SymbolData.Description Property

SymbolDataDescription Property
Description of the instrument, usually a full name of the underlying asset.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SymbolData Class


SymbolData.Exchange Property

SymbolDataExchange Property
Source of the quotes.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Exchange { get; set; }
public:
property String^ Exchange {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SymbolData Class


SymbolData.Id Property

SymbolDataId Property
Identifier of the instrument.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
Remarks
This value is not displayed in eSignal Desktop.
See Also

Reference

SymbolData Class


SymbolData.MinMovement Property

SymbolDataMinMovement Property
Numerator of the price fraction. This is used for any type of price.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int MinMovement { get; set; }
public:
property int MinMovement {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SymbolData Class


SymbolData.MinMovement2 Property

SymbolDataMinMovement2 Property
A number of fractions that each of the price's fraction can be split into additionally. This is used only for Fractional price type.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<int> MinMovement2 { get; set; }
public:
property Nullable<int> MinMovement2 {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable Int32
See Also

Reference

SymbolData Class


SymbolData.PointValue Property

SymbolDataPointValue Property
Cost of the whole price point in real-world money.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public double PointValue { get; set; }
public:
property double PointValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Examples
Point value is '1.0' for the most stocks, meaning 1 cent per minimum price tick (1$ / 100 minimum ticks).
See Also

Reference

SymbolData Class


SymbolData.PriceScale Property

SymbolDataPriceScale Property
Denominator of the price fraction. This is used for any type of price.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int PriceScale { get; set; }
public:
property int PriceScale {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SymbolData Class


SymbolData.PriceType Property

SymbolDataPriceType Property
Affects price formatting. See SymbolPriceType for available price types.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SymbolPriceType PriceType { get; set; }
public:
property SymbolPriceType PriceType {
    SymbolPriceType get ();
    void set (SymbolPriceType value);
}

Property Value

Type: SymbolPriceType
See Also

Reference

SymbolData Class


SymbolData.QuoteCurrency Property

SymbolDataQuoteCurrency Property
Quote currency of the currency pair.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string QuoteCurrency { get; set; }
public:
property String^ QuoteCurrency {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SymbolData Class


SymbolData.Type Property

SymbolDataType Property
Type of the instrument.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Nullable<SymbolType> Type { get; set; }
public:
property Nullable<SymbolType> Type {
    Nullable<SymbolType> get ();
    void set (Nullable<SymbolType> value);
}

Property Value

Type: Nullable SymbolType
See Also

Reference

SymbolData Class


SymbolData.Valid Property

SymbolDataValid Property
This field must be set to designate if the information is valid or not. Objects with this field value of 'false' can be used to report back that the symbol information is not available.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool Valid { get; set; }
public:
property bool Valid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SymbolData Class


SymbolEventHandler Delegate

SymbolEventHandler Delegate

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public delegate void SymbolEventHandler(
    string SymbolId
)
public delegate void SymbolEventHandler(
    String^ SymbolId
)

Parameters

SymbolId
Type: SystemString
See Also

Reference


SymbolOptionPutCall Enumeration

SymbolOptionPutCall Enumeration
Enumeration of available options types.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum SymbolOptionPutCall
public enum class SymbolOptionPutCall
Members
Member name | Value | Description
Put | 0 |
Call | 1 |
See Also

Reference


SymbolPriceType Enumeration

SymbolPriceType Enumeration
Enumeration of all the symbol price formatting methods available.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum SymbolPriceType
public enum class SymbolPriceType
Members
Member name | Value | Description
Neutral | 0 | SymbolPriceType.Neutral is treated depending on the actual price fraction: 8ths, 32nds, 64nds and so forth are treated as fractional numbers and formatted accordingly, others are considered to be decimal.
Decimal | 1 | SymbolPriceType.Decimal always means decimal xxx.yyy formatting style.
Fractional | 2 | SymbolPriceType.Fractional always means "xxx'yyz" (or sometimes "xxxyyz") formatting style, where "xxx" is integer part, "yy" is fractional and "z" is additional digit.
See Also

Reference


SymbolType Enumeration

SymbolType Enumeration
Enumeration of all the symbol types that eSignal supports.

Namespace: InteractiveData.eSignalDesktop.Trading
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum SymbolType
public enum class SymbolType
Members
Member name | Value | Description
Future | 0 |
Stock | 1 |
Index | 2 |
Forex | 3 |
StockOption | 4 |
FutureOption | 5 |
IndexOption | 6 |
MutualFund | 7 |
MoneyMktFund | 8 |
Bond | 9 |
Spread | 10 |
UserDefinedSpread | 11 |
FutureSpot | 12 |
Other | 13 | This type can contain some specific instruments such as CFD, Binary options, etc. No eSignal symbols exist in this category.
See Also

Reference


InteractiveData.eSignalDesktop.Trading.Attributes Namespace

InteractiveData.eSignalDesktop.Trading.Attributes Namespace
Classes
 | Class | Description
Public class | CustomFieldAttribute | Marks custom field that can be provided by the add-in and displayed in eSignal application.
Public class | DependencyAttribute | This attribute should be applied to the add-in so as to set its dependency on some component.
Public class | HostComponents | Lists all available components on which a dependency could be set.
Public class | MultilegOrderInputsAttribute | Marks fields that should be available in Multileg Order Ticket.
Public class | OrderAccountAttribute | This attribute should not be used in plugin. The appropriate fields are populated by OrderData.Account property.
Public class | OrderActionAttribute | This attribute should not be used in plugin. The appropriate fields are populated by OrderData.Action property.
Public class | OrderDefaultsAttribute | Marks fields that should be stored in Order Defaults.
Public class | OrderExpiryAttribute | Marks a field with type of order's expiration (time-in-force).
Public class | OrderGoodTillDateAttribute | Marks a field with the date of order's expiration. Valid and necessary for Good Till Data expiration.
Public class | OrderInputsAttribute | Marks fields that should be available in Order Ticket.
Public class | OrderLimitPriceAttribute | This attribute should not be used in plugin. The appropriate fields are populated by OrderData.LimitPrice property.
Public class | OrderPositionIdAttribute | Marks a field with the position id. Valid and necessary for positions opened on accounts which allow hedging.
Public class | OrderQuantityAttribute | This attribute should not be used in plugin. The appropriate fields are populated by OrderData.TotalQuantity property.
Public class | OrderStopPriceAttribute | This attribute should not be used in plugin. The appropriate fields are populated by OrderData.StopPrice property.
Public class | OrderTimeAttribute | Marks a field with the time of order.
Public class | OrderTypeAttribute | This attribute should not be used in plugin. The appropriate fields are populated by OrderData.Type property.
Public class | PluginAttribute | Marks an 'entry point' of add-in - its IPlugin interface implementation.
Public class | PositionClosingPriceAttribute | Marks a field containing price value where currently opened position will close (see glossary for details).
Public class | PositionDisplayedIdAttribute | Marks a field with position identificator which shall visible to the user. Usually is the same as the PositionId field value.
Public class | PositionUnrealizedProfitLossAttribute | Marks a field with Unrealized (Open) Profit/Loss value in currency.
Public class | PositionUnrealizedProfitLossInPointsAttribute | Marks a field with Unrealized (Open) Profit/Loss value in min points.
Public class | SupportedMultilegOrderActionsAttribute | This attribute should be applied to the add-in if it supports multileg orders.
Public class | SupportedSymbolTypesAttribute | This attribute should be applied to the add-in so as to designate instrument types that add-in supports.
Enumerations
 | Enumeration | Description
Public enumeration | FormatType | Controls the way in which field value is presented in UI, validated and edited.


CustomFieldAttribute Class

CustomFieldAttribute Class
Marks custom field that can be provided by the add-in and displayed in eSignal application.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesCustomFieldAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class CustomFieldAttribute : FieldAttribute
public ref class CustomFieldAttribute sealed : public FieldAttribute

The CustomFieldAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | CustomFieldAttribute(String) | Initializes a new instance of CustomFieldAttribute class.
Public method | CustomFieldAttribute(String, String) | Initializes a new instance of CustomFieldAttribute class.
Top
Properties
 | Name | Description
Public property | DecimalPlaces |
Public property | DefaultColumnWidth | The default width of the column in pixels.
Public property | DisplayName | The name of the field under which it will be displayed in the eSignal application. This will be the name of the column.
Public property | Format | Designates how the value dispalyed in this column should be formatted.
Public property | IsColumnAutoSized | Marks if the column is autosized.
Public property | IsColumnVisibleByDefault | Marks if the field is visible by default in eSignal application.
Public property | IsOptional |
Public property | OrderDefaultValue |
Top
Remarks
The field marked with the attribute can be made available for user to input in Order Ticket. Specify them in OrderInputsAttribute and access through GetCustomControl(String) method.
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute Constructor

CustomFieldAttribute Constructor
Overload List
 | Name | Description
Public method | CustomFieldAttribute(String) | Initializes a new instance of CustomFieldAttribute class.
Public method | CustomFieldAttribute(String, String) | Initializes a new instance of CustomFieldAttribute class.
Top
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute Constructor (String)

CustomFieldAttribute Constructor (String)
Initializes a new instance of CustomFieldAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public CustomFieldAttribute(
    string Id
)
public:
CustomFieldAttribute(
    String^ Id
)

Parameters

Id
Type: SystemString
Unique identifier of the custom attribute.
See Also

Reference

CustomFieldAttribute Class
CustomFieldAttribute Overload
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute Constructor (String, String)

CustomFieldAttribute Constructor (String, String)
Initializes a new instance of CustomFieldAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public CustomFieldAttribute(
    string Id,
    string DisplayName
)
public:
CustomFieldAttribute(
    String^ Id,
    String^ DisplayName
)

Parameters

Id
Type: SystemString
Unique identifier of the custom attribute.
DisplayName
Type: SystemString
The name of the field under which it will be displayed in the eSignal application.
See Also

Reference

CustomFieldAttribute Class
CustomFieldAttribute Overload
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute Properties

CustomFieldAttribute Properties

The CustomFieldAttribute type exposes the following members.

Properties
 | Name | Description
Public property | DecimalPlaces |
Public property | DefaultColumnWidth | The default width of the column in pixels.
Public property | DisplayName | The name of the field under which it will be displayed in the eSignal application. This will be the name of the column.
Public property | Format | Designates how the value dispalyed in this column should be formatted.
Public property | IsColumnAutoSized | Marks if the column is autosized.
Public property | IsColumnVisibleByDefault | Marks if the field is visible by default in eSignal application.
Public property | IsOptional |
Public property | OrderDefaultValue |
Top
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute.DecimalPlaces Property

CustomFieldAttributeDecimalPlaces Property

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int DecimalPlaces { get; set; }
public:
property int DecimalPlaces {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute.DefaultColumnWidth Property

CustomFieldAttributeDefaultColumnWidth Property
The default width of the column in pixels.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public int DefaultColumnWidth { get; set; }
public:
property int DefaultColumnWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute.DisplayName Property

CustomFieldAttributeDisplayName Property
The name of the field under which it will be displayed in the eSignal application. This will be the name of the column.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string DisplayName { get; set; }
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute.Format Property

CustomFieldAttributeFormat Property
Designates how the value dispalyed in this column should be formatted.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public FormatType Format { get; set; }
public:
property FormatType Format {
    FormatType get ();
    void set (FormatType value);
}

Property Value

Type: FormatType
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute.IsColumnAutoSized Property

CustomFieldAttributeIsColumnAutoSized Property
Marks if the column is autosized.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool IsColumnAutoSized { get; set; }
public:
property bool IsColumnAutoSized {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute.IsColumnVisibleByDefault Property

CustomFieldAttributeIsColumnVisibleByDefault Property
Marks if the field is visible by default in eSignal application.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool IsColumnVisibleByDefault { get; set; }
public:
property bool IsColumnVisibleByDefault {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute.IsOptional Property

CustomFieldAttributeIsOptional Property

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool IsOptional { get; set; }
public:
property bool IsOptional {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


CustomFieldAttribute.OrderDefaultValue Property

CustomFieldAttributeOrderDefaultValue Property

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Object OrderDefaultValue { get; set; }
public:
property Object^ OrderDefaultValue {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

CustomFieldAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


DependencyAttribute Class

DependencyAttribute Class
This attribute should be applied to the add-in so as to set its dependency on some component.
Inheritance Hierarchy
SystemObject
SystemAttribute
InteractiveData.eSignalDesktop.Trading.AttributesDependencyAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true)]
public class DependencyAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = true)]
public ref class DependencyAttribute : public Attribute

The DependencyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DependencyAttribute | Initializes a new instance of the DependencyAttribute class.
Top
Properties
 | Name | Description
Public property | ComponentName | Component name add-in has to depend on. Currently, all possible choices can be found in HostComponents class. By setting a dependency from HostComponents.EsignalDesktop of particular version, you can limit host versions that can load your add-in.
Public property | MinimumVersion | Version of the component in the following form: (major version).(minor version).(major build).(minor build)
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


DependencyAttribute Constructor

DependencyAttribute Constructor
Initializes a new instance of the DependencyAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public DependencyAttribute(
    string ComponentName,
    string MinimumVersion
)
public:
DependencyAttribute(
    String^ ComponentName,
    String^ MinimumVersion
)

Parameters

ComponentName
Type: SystemString
ComponentName
MinimumVersion
Type: SystemString
MinimumVersion
See Also

Reference

DependencyAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


DependencyAttribute Properties

DependencyAttribute Properties

The DependencyAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ComponentName | Component name add-in has to depend on. Currently, all possible choices can be found in HostComponents class. By setting a dependency from HostComponents.EsignalDesktop of particular version, you can limit host versions that can load your add-in.
Public property | MinimumVersion | Version of the component in the following form: (major version).(minor version).(major build).(minor build)
Top
See Also

Reference

DependencyAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


DependencyAttribute.ComponentName Property

DependencyAttributeComponentName Property
Component name add-in has to depend on. Currently, all possible choices can be found in HostComponents class. By setting a dependency from HostComponents.EsignalDesktop of particular version, you can limit host versions that can load your add-in.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string ComponentName { get; }
public:
property String^ ComponentName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DependencyAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


DependencyAttribute.MinimumVersion Property

DependencyAttributeMinimumVersion Property
Version of the component in the following form: (major version).(minor version).(major build).(minor build)

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string MinimumVersion { get; }
public:
property String^ MinimumVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DependencyAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


FormatType Enumeration

FormatType Enumeration
Controls the way in which field value is presented in UI, validated and edited.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public enum FormatType
public enum class FormatType
Members
Member name | Value | Description
None | 0 | Default
Percent | 1 | Percentage
Price | 2 | Follow price formatting rules. When editing, special control is provided.
Quantity | 3 | Follow quantity formatting rules. When editing, special control is provided.
Currency | 4 | Fixed point formatting, plus currency code.
Date | 5 | Applicable to fields of System.DateTime type only. Designates that only 'date' part of the value should be displayed.
Double | 6 |
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


HostComponents Class

HostComponents Class
Lists all available components on which a dependency could be set.
Inheritance Hierarchy
SystemObject
InteractiveData.eSignalDesktop.Trading.AttributesHostComponents

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public static class HostComponents
public ref class HostComponents abstract sealed

The HostComponents type exposes the following members.

Fields
Name | Description
EsignalDesktop | Represents eSignal Desktop application component.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


HostComponents Fields

HostComponents Fields

The HostComponents type exposes the following members.

Fields
Name | Description
EsignalDesktop | Represents eSignal Desktop application component.
Top
See Also

Reference

HostComponents Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


HostComponents.EsignalDesktop Field

HostComponentsEsignalDesktop Field
Represents eSignal Desktop application component.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string EsignalDesktop
public:
literal String^ EsignalDesktop

Field Value

Type: String
See Also

Reference

HostComponents Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


MultilegOrderInputsAttribute Class

MultilegOrderInputsAttribute Class
Marks fields that should be available in Multileg Order Ticket.
Inheritance Hierarchy
SystemObject
SystemAttribute
AbstractFieldListAttribute
InteractiveData.eSignalDesktop.Trading.AttributesMultilegOrderInputsAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public class MultilegOrderInputsAttribute : AbstractFieldListAttribute
public ref class MultilegOrderInputsAttribute : public AbstractFieldListAttribute

The MultilegOrderInputsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MultilegOrderInputsAttribute | Initializes a new instance of the MultilegOrderInputsAttribute class
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


MultilegOrderInputsAttribute Constructor

MultilegOrderInputsAttribute Constructor
Initializes a new instance of the MultilegOrderInputsAttribute class

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public MultilegOrderInputsAttribute(
    params string[] Fields
)
public:
MultilegOrderInputsAttribute(
    ... array<String^>^ Fields
)

Parameters

Fields
Type: SystemString
See Also

Reference

MultilegOrderInputsAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderAccountAttribute Class

OrderAccountAttribute Class
This attribute should not be used in plugin. The appropriate fields are populated by OrderData.Account property.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderAccountAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderAccountAttribute : FieldAttribute
public ref class OrderAccountAttribute sealed : public FieldAttribute

The OrderAccountAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderAccountAttribute | Initializes a new instance of the OrderAccountAttribute class
Top
Fields
Name | Description
Id |
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderAccountAttribute Constructor

OrderAccountAttribute Constructor
Initializes a new instance of the OrderAccountAttribute class

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderAccountAttribute()
public:
OrderAccountAttribute()
See Also

Reference

OrderAccountAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderAccountAttribute Fields

OrderAccountAttribute Fields

The OrderAccountAttribute type exposes the following members.

Fields
Name | Description
Id |
Top
See Also

Reference

OrderAccountAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderAccountAttribute.Id Field

OrderAccountAttributeId Field

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderAccountAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderActionAttribute Class

OrderActionAttribute Class
This attribute should not be used in plugin. The appropriate fields are populated by OrderData.Action property.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderActionAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderActionAttribute : FieldAttribute
public ref class OrderActionAttribute sealed : public FieldAttribute

The OrderActionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderActionAttribute | Initializes a new instance of the OrderActionAttribute class
Top
Fields
Name | Description
Id |
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderActionAttribute Constructor

OrderActionAttribute Constructor
Initializes a new instance of the OrderActionAttribute class

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderActionAttribute()
public:
OrderActionAttribute()
See Also

Reference

OrderActionAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderActionAttribute Fields

OrderActionAttribute Fields

The OrderActionAttribute type exposes the following members.

Fields
Name | Description
Id |
Top
See Also

Reference

OrderActionAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderActionAttribute.Id Field

OrderActionAttributeId Field

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderActionAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderDefaultsAttribute Class

OrderDefaultsAttribute Class
Marks fields that should be stored in Order Defaults.
Inheritance Hierarchy
SystemObject
SystemAttribute
AbstractFieldListAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderDefaultsAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderDefaultsAttribute : AbstractFieldListAttribute
public ref class OrderDefaultsAttribute sealed : public AbstractFieldListAttribute

The OrderDefaultsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderDefaultsAttribute | Initializes a new instance of the OrderDefaultsAttribute class.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderDefaultsAttribute Constructor

OrderDefaultsAttribute Constructor
Initializes a new instance of the OrderDefaultsAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderDefaultsAttribute(
    params string[] Fields
)
public:
OrderDefaultsAttribute(
    ... array<String^>^ Fields
)

Parameters

Fields
Type: SystemString
Specify Ids of the attributes which you want to be available in Order Defaults.
See Also

Reference

OrderDefaultsAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderExpiryAttribute Class

OrderExpiryAttribute Class
Marks a field with type of order's expiration (time-in-force).
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderExpiryAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderExpiryAttribute : FieldAttribute
public ref class OrderExpiryAttribute sealed : public FieldAttribute

The OrderExpiryAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderExpiryAttribute | Initializes a new instance of the OrderExpiryAttribute class.
Top
Fields
Name | Description
Id | Identifier associated with this attribute.
Top
Remarks
This attribute is to be specified so that the appropriate value is displayed in the existing fields in eSignal application (e.g. in appropriate column in Account Manager: TIF in Orders tab).
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderExpiryAttribute Constructor

OrderExpiryAttribute Constructor
Initializes a new instance of the OrderExpiryAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderExpiryAttribute()
public:
OrderExpiryAttribute()
See Also

Reference

OrderExpiryAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderExpiryAttribute Fields

OrderExpiryAttribute Fields

The OrderExpiryAttribute type exposes the following members.

Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

OrderExpiryAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderExpiryAttribute.Id Field

OrderExpiryAttributeId Field
Identifier associated with this attribute.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderExpiryAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderGoodTillDateAttribute Class

OrderGoodTillDateAttribute Class
Marks a field with the date of order's expiration. Valid and necessary for Good Till Data expiration.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderGoodTillDateAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderGoodTillDateAttribute : FieldAttribute
public ref class OrderGoodTillDateAttribute sealed : public FieldAttribute

The OrderGoodTillDateAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderGoodTillDateAttribute | Initializes a new instance of the OrderGoodTillDateAttribute class.
Top
Fields
Name | Description
Id | Identifier associated with this attribute.
Top
Remarks
This attribute is to be specified so that the appropriate value is displayed in the existing fields in eSignal application.
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderGoodTillDateAttribute Constructor

OrderGoodTillDateAttribute Constructor
Initializes a new instance of the OrderGoodTillDateAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderGoodTillDateAttribute()
public:
OrderGoodTillDateAttribute()
See Also

Reference

OrderGoodTillDateAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderGoodTillDateAttribute Fields

OrderGoodTillDateAttribute Fields

The OrderGoodTillDateAttribute type exposes the following members.

Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

OrderGoodTillDateAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderGoodTillDateAttribute.Id Field

OrderGoodTillDateAttributeId Field
Identifier associated with this attribute.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderGoodTillDateAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderInputsAttribute Class

OrderInputsAttribute Class
Marks fields that should be available in Order Ticket.
Inheritance Hierarchy
SystemObject
SystemAttribute
AbstractFieldListAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderInputsAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public class OrderInputsAttribute : AbstractFieldListAttribute
public ref class OrderInputsAttribute : public AbstractFieldListAttribute

The OrderInputsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderInputsAttribute | Initializes a new instance of the OrderInputsAttribute class.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderInputsAttribute Constructor

OrderInputsAttribute Constructor
Initializes a new instance of the OrderInputsAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderInputsAttribute(
    params string[] Fields
)
public:
OrderInputsAttribute(
    ... array<String^>^ Fields
)

Parameters

Fields
Type: SystemString
Specify Ids of the attributes which you want to be available in Order Inputs of Order Ticket.

To make them visible for a certain Order Ticket you should specify them using IOrderTicket, IOrderTicketControl interface.

See Also

Reference

OrderInputsAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderLimitPriceAttribute Class

OrderLimitPriceAttribute Class
This attribute should not be used in plugin. The appropriate fields are populated by OrderData.LimitPrice property.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderLimitPriceAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderLimitPriceAttribute : FieldAttribute
public ref class OrderLimitPriceAttribute sealed : public FieldAttribute

The OrderLimitPriceAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderLimitPriceAttribute | Initializes a new instance of the OrderLimitPriceAttribute class
Top
Fields
Name | Description
Id |
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderLimitPriceAttribute Constructor

OrderLimitPriceAttribute Constructor
Initializes a new instance of the OrderLimitPriceAttribute class

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderLimitPriceAttribute()
public:
OrderLimitPriceAttribute()
See Also

Reference

OrderLimitPriceAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderLimitPriceAttribute Fields

OrderLimitPriceAttribute Fields

The OrderLimitPriceAttribute type exposes the following members.

Fields
Name | Description
Id |
Top
See Also

Reference

OrderLimitPriceAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderLimitPriceAttribute.Id Field

OrderLimitPriceAttributeId Field

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderLimitPriceAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderPositionIdAttribute Class

OrderPositionIdAttribute Class
Marks a field with the position id. Valid and necessary for positions opened on accounts which allow hedging.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderPositionIdAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderPositionIdAttribute : FieldAttribute
public ref class OrderPositionIdAttribute sealed : public FieldAttribute

The OrderPositionIdAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderPositionIdAttribute | Initializes a new instance of the OrderPositionIdAttribute class
Top
Fields
Name | Description
Id |
Top
Remarks
This attribute is to be specified so that the appropriate value is displayed in the existing fields in eSignal application.
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderPositionIdAttribute Constructor

OrderPositionIdAttribute Constructor
Initializes a new instance of the OrderPositionIdAttribute class

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderPositionIdAttribute()
public:
OrderPositionIdAttribute()
See Also

Reference

OrderPositionIdAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderPositionIdAttribute Fields

OrderPositionIdAttribute Fields

The OrderPositionIdAttribute type exposes the following members.

Fields
Name | Description
Id |
Top
See Also

Reference

OrderPositionIdAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderPositionIdAttribute.Id Field

OrderPositionIdAttributeId Field

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderPositionIdAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderQuantityAttribute Class

OrderQuantityAttribute Class
This attribute should not be used in plugin. The appropriate fields are populated by OrderData.TotalQuantity property.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderQuantityAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderQuantityAttribute : FieldAttribute
public ref class OrderQuantityAttribute sealed : public FieldAttribute

The OrderQuantityAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderQuantityAttribute | Initializes a new instance of the OrderQuantityAttribute class
Top
Fields
Name | Description
Id |
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderQuantityAttribute Constructor

OrderQuantityAttribute Constructor
Initializes a new instance of the OrderQuantityAttribute class

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderQuantityAttribute()
public:
OrderQuantityAttribute()
See Also

Reference

OrderQuantityAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderQuantityAttribute Fields

OrderQuantityAttribute Fields

The OrderQuantityAttribute type exposes the following members.

Fields
Name | Description
Id |
Top
See Also

Reference

OrderQuantityAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderQuantityAttribute.Id Field

OrderQuantityAttributeId Field

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderQuantityAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderStopPriceAttribute Class

OrderStopPriceAttribute Class
This attribute should not be used in plugin. The appropriate fields are populated by OrderData.StopPrice property.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderStopPriceAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderStopPriceAttribute : FieldAttribute
public ref class OrderStopPriceAttribute sealed : public FieldAttribute

The OrderStopPriceAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderStopPriceAttribute | Initializes a new instance of the OrderStopPriceAttribute class
Top
Fields
Name | Description
Id |
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderStopPriceAttribute Constructor

OrderStopPriceAttribute Constructor
Initializes a new instance of the OrderStopPriceAttribute class

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderStopPriceAttribute()
public:
OrderStopPriceAttribute()
See Also

Reference

OrderStopPriceAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderStopPriceAttribute Fields

OrderStopPriceAttribute Fields

The OrderStopPriceAttribute type exposes the following members.

Fields
Name | Description
Id |
Top
See Also

Reference

OrderStopPriceAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderStopPriceAttribute.Id Field

OrderStopPriceAttributeId Field

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderStopPriceAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderTimeAttribute Class

OrderTimeAttribute Class
Marks a field with the time of order.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderTimeAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderTimeAttribute : FieldAttribute
public ref class OrderTimeAttribute sealed : public FieldAttribute

The OrderTimeAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderTimeAttribute | Initializes a new instance of the OrderTimeAttribute class.
Top
Fields
Name | Description
Id | Identifier associated with this attribute.
Top
Remarks
This attribute is to be specified so that the appropriate value is displayed in the existing fields in eSignal application.
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderTimeAttribute Constructor

OrderTimeAttribute Constructor
Initializes a new instance of the OrderTimeAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderTimeAttribute()
public:
OrderTimeAttribute()
See Also

Reference

OrderTimeAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderTimeAttribute Fields

OrderTimeAttribute Fields

The OrderTimeAttribute type exposes the following members.

Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

OrderTimeAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderTimeAttribute.Id Field

OrderTimeAttributeId Field
Identifier associated with this attribute.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderTimeAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderTypeAttribute Class

OrderTypeAttribute Class
This attribute should not be used in plugin. The appropriate fields are populated by OrderData.Type property.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesOrderTypeAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class OrderTypeAttribute : FieldAttribute
public ref class OrderTypeAttribute sealed : public FieldAttribute

The OrderTypeAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OrderTypeAttribute | Initializes a new instance of the OrderTypeAttribute class
Top
Fields
Name | Description
Id |
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderTypeAttribute Constructor

OrderTypeAttribute Constructor
Initializes a new instance of the OrderTypeAttribute class

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderTypeAttribute()
public:
OrderTypeAttribute()
See Also

Reference

OrderTypeAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderTypeAttribute Fields

OrderTypeAttribute Fields

The OrderTypeAttribute type exposes the following members.

Fields
Name | Description
Id |
Top
See Also

Reference

OrderTypeAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


OrderTypeAttribute.Id Field

OrderTypeAttributeId Field

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

OrderTypeAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PluginAttribute Class

PluginAttribute Class
Marks an 'entry point' of add-in - its IPlugin interface implementation.
Inheritance Hierarchy
SystemObject
SystemAttribute
InteractiveData.eSignalDesktop.Trading.AttributesPluginAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public class PluginAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class PluginAttribute : public Attribute

The PluginAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PluginAttribute | Initializes a new instance of the PluginAttribute class.
Top
Properties
 | Name | Description
Public property | AreOrderIDsPermanent | Denotes if order IDs persist their values between sessions. Is true by default.
Public property | DataStreamingSupported | Denotes if data streaming support is enabled for this add-in. Is true by default.
Public property | EntitlementBit | A codename that permits usage of the add-in in eSignal application. Issued to you by eSignal.
Public property | MultilegOrdersSupported | Denotes if multileg orders are supported by this add-in. Is false by default.
Public property | SupportOfMMSShouldBeEnabled | Denotes if Money Management Strategies support should be enabled for this add-in. Is false by default.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PluginAttribute Constructor

PluginAttribute Constructor
Initializes a new instance of the PluginAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public PluginAttribute()
public:
PluginAttribute()
See Also

Reference

PluginAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PluginAttribute Properties

PluginAttribute Properties

The PluginAttribute type exposes the following members.

Properties
 | Name | Description
Public property | AreOrderIDsPermanent | Denotes if order IDs persist their values between sessions. Is true by default.
Public property | DataStreamingSupported | Denotes if data streaming support is enabled for this add-in. Is true by default.
Public property | EntitlementBit | A codename that permits usage of the add-in in eSignal application. Issued to you by eSignal.
Public property | MultilegOrdersSupported | Denotes if multileg orders are supported by this add-in. Is false by default.
Public property | SupportOfMMSShouldBeEnabled | Denotes if Money Management Strategies support should be enabled for this add-in. Is false by default.
Top
See Also

Reference

PluginAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PluginAttribute.AreOrderIDsPermanent Property

PluginAttributeAreOrderIDsPermanent Property
Denotes if order IDs persist their values between sessions.

Is true by default.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool AreOrderIDsPermanent { get; set; }
public:
property bool AreOrderIDsPermanent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PluginAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PluginAttribute.DataStreamingSupported Property

PluginAttributeDataStreamingSupported Property
Denotes if data streaming support is enabled for this add-in.

Is true by default.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool DataStreamingSupported { get; set; }
public:
property bool DataStreamingSupported {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PluginAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PluginAttribute.EntitlementBit Property

PluginAttributeEntitlementBit Property
A codename that permits usage of the add-in in eSignal application.

Issued to you by eSignal.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string EntitlementBit { get; set; }
public:
property String^ EntitlementBit {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PluginAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PluginAttribute.MultilegOrdersSupported Property

PluginAttributeMultilegOrdersSupported Property
Denotes if multileg orders are supported by this add-in.

Is false by default.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool MultilegOrdersSupported { get; set; }
public:
property bool MultilegOrdersSupported {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PluginAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PluginAttribute.SupportOfMMSShouldBeEnabled Property

PluginAttributeSupportOfMMSShouldBeEnabled Property
Denotes if Money Management Strategies support should be enabled for this add-in.

Is false by default.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public bool SupportOfMMSShouldBeEnabled { get; set; }
public:
property bool SupportOfMMSShouldBeEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PluginAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionClosingPriceAttribute Class

PositionClosingPriceAttribute Class
Marks a field containing price value where currently opened position will close (see glossary for details).
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesPositionClosingPriceAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class PositionClosingPriceAttribute : FieldAttribute
public ref class PositionClosingPriceAttribute sealed : public FieldAttribute

The PositionClosingPriceAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PositionClosingPriceAttribute | Initializes a new instance of the PositionClosingPriceAttribute class.
Top
Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionClosingPriceAttribute Constructor

PositionClosingPriceAttribute Constructor
Initializes a new instance of the PositionClosingPriceAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public PositionClosingPriceAttribute()
public:
PositionClosingPriceAttribute()
See Also

Reference

PositionClosingPriceAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionClosingPriceAttribute Fields

PositionClosingPriceAttribute Fields

The PositionClosingPriceAttribute type exposes the following members.

Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

PositionClosingPriceAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionClosingPriceAttribute.Id Field

PositionClosingPriceAttributeId Field
Identifier associated with this attribute.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

PositionClosingPriceAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionDisplayedIdAttribute Class

PositionDisplayedIdAttribute Class
Marks a field with position identificator which shall visible to the user. Usually is the same as the PositionId field value.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesPositionDisplayedIdAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class PositionDisplayedIdAttribute : FieldAttribute
public ref class PositionDisplayedIdAttribute sealed : public FieldAttribute

The PositionDisplayedIdAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PositionDisplayedIdAttribute | Initializes a new instance of the PositionDisplayedIdAttribute class.
Top
Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionDisplayedIdAttribute Constructor

PositionDisplayedIdAttribute Constructor
Initializes a new instance of the PositionDisplayedIdAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public PositionDisplayedIdAttribute()
public:
PositionDisplayedIdAttribute()
See Also

Reference

PositionDisplayedIdAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionDisplayedIdAttribute Fields

PositionDisplayedIdAttribute Fields

The PositionDisplayedIdAttribute type exposes the following members.

Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

PositionDisplayedIdAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionDisplayedIdAttribute.Id Field

PositionDisplayedIdAttributeId Field
Identifier associated with this attribute.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

PositionDisplayedIdAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionUnrealizedProfitLossAttribute Class

PositionUnrealizedProfitLossAttribute Class
Marks a field with Unrealized (Open) Profit/Loss value in currency.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesPositionUnrealizedProfitLossAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class PositionUnrealizedProfitLossAttribute : FieldAttribute
public ref class PositionUnrealizedProfitLossAttribute sealed : public FieldAttribute

The PositionUnrealizedProfitLossAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PositionUnrealizedProfitLossAttribute | Initializes a new instance of the PositionUnrealizedProfitLossAttribute class.
Top
Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionUnrealizedProfitLossAttribute Constructor

PositionUnrealizedProfitLossAttribute Constructor
Initializes a new instance of the PositionUnrealizedProfitLossAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public PositionUnrealizedProfitLossAttribute()
public:
PositionUnrealizedProfitLossAttribute()
See Also

Reference

PositionUnrealizedProfitLossAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionUnrealizedProfitLossAttribute Fields

PositionUnrealizedProfitLossAttribute Fields

The PositionUnrealizedProfitLossAttribute type exposes the following members.

Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

PositionUnrealizedProfitLossAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionUnrealizedProfitLossAttribute.Id Field

PositionUnrealizedProfitLossAttributeId Field
Identifier associated with this attribute.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

PositionUnrealizedProfitLossAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionUnrealizedProfitLossInPointsAttribute Class

PositionUnrealizedProfitLossInPointsAttribute Class
Marks a field with Unrealized (Open) Profit/Loss value in min points.
Inheritance Hierarchy
SystemObject
SystemAttribute
FieldAttribute
InteractiveData.eSignalDesktop.Trading.AttributesPositionUnrealizedProfitLossInPointsAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public sealed class PositionUnrealizedProfitLossInPointsAttribute : FieldAttribute
public ref class PositionUnrealizedProfitLossInPointsAttribute sealed : public FieldAttribute

The PositionUnrealizedProfitLossInPointsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PositionUnrealizedProfitLossInPointsAttribute | Initializes a new instance of the PositionUnrealizedProfitLossInPointsAttribute class.
Top
Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionUnrealizedProfitLossInPointsAttribute Constructor

PositionUnrealizedProfitLossInPointsAttribute Constructor
Initializes a new instance of the PositionUnrealizedProfitLossInPointsAttribute class.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public PositionUnrealizedProfitLossInPointsAttribute()
public:
PositionUnrealizedProfitLossInPointsAttribute()
See Also

Reference

PositionUnrealizedProfitLossInPointsAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionUnrealizedProfitLossInPointsAttribute Fields

PositionUnrealizedProfitLossInPointsAttribute Fields

The PositionUnrealizedProfitLossInPointsAttribute type exposes the following members.

Fields
Name | Description
Id | Identifier associated with this attribute.
Top
See Also

Reference

PositionUnrealizedProfitLossInPointsAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


PositionUnrealizedProfitLossInPointsAttribute.Id Field

PositionUnrealizedProfitLossInPointsAttributeId Field
Identifier associated with this attribute.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public const string Id
public:
literal String^ Id

Field Value

Type: String
See Also

Reference

PositionUnrealizedProfitLossInPointsAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


SupportedMultilegOrderActionsAttribute Class

SupportedMultilegOrderActionsAttribute Class
This attribute should be applied to the add-in if it supports multileg orders.
Inheritance Hierarchy
SystemObject
SystemAttribute
InteractiveData.eSignalDesktop.Trading.AttributesSupportedMultilegOrderActionsAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class SupportedMultilegOrderActionsAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false)]
public ref class SupportedMultilegOrderActionsAttribute : public Attribute

The SupportedMultilegOrderActionsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SupportedMultilegOrderActionsAttribute | Initializes a new instance of the SupportedMultilegOrderActionsAttribute class
Top
Properties
 | Name | Description
Public property | OrderActions |
Top
Remarks
The supported order actions for leg symbols should be properly chosen. Unsupported order actions for leg symbols should not be added so that they would not be displayed in Action controls for legs in Multileg Order Ticket.
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


SupportedMultilegOrderActionsAttribute Constructor

SupportedMultilegOrderActionsAttribute Constructor
Initializes a new instance of the SupportedMultilegOrderActionsAttribute class

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SupportedMultilegOrderActionsAttribute(
    params OrderAction[] Actions
)
public:
SupportedMultilegOrderActionsAttribute(
    ... array<OrderAction>^ Actions
)

Parameters

Actions
Type: InteractiveData.eSignalDesktop.TradingOrderAction
See Also

Reference

SupportedMultilegOrderActionsAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


SupportedMultilegOrderActionsAttribute Properties

SupportedMultilegOrderActionsAttribute Properties

The SupportedMultilegOrderActionsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | OrderActions |
Top
See Also

Reference

SupportedMultilegOrderActionsAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


SupportedMultilegOrderActionsAttribute.OrderActions Property

SupportedMultilegOrderActionsAttributeOrderActions Property

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public OrderAction[] OrderActions { get; set; }
public:
property array<OrderAction>^ OrderActions {
    array<OrderAction>^ get ();
    void set (array<OrderAction>^ value);
}

Property Value

Type: OrderAction
See Also

Reference

SupportedMultilegOrderActionsAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


SupportedSymbolTypesAttribute Class

SupportedSymbolTypesAttribute Class
This attribute should be applied to the add-in so as to designate instrument types that add-in supports.
Inheritance Hierarchy
SystemObject
SystemAttribute
InteractiveData.eSignalDesktop.Trading.AttributesSupportedSymbolTypesAttribute

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class SupportedSymbolTypesAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false)]
public ref class SupportedSymbolTypesAttribute : public Attribute

The SupportedSymbolTypesAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SupportedSymbolTypesAttribute | Marks types of symbols that add-in supports.
Top
Properties
 | Name | Description
Public property | SymbolTypes | See SymbolType for the list of symbol types that eSignal supports.
Top
Remarks
The supported symbol types should be properly chosen. Unsupported types should not be added so that they would not be displayed in Dictionary in Broker Manager.
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Attributes Namespace


SupportedSymbolTypesAttribute Constructor

SupportedSymbolTypesAttribute Constructor
Marks types of symbols that add-in supports.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SupportedSymbolTypesAttribute(
    params SymbolType[] Types
)
public:
SupportedSymbolTypesAttribute(
    ... array<SymbolType>^ Types
)

Parameters

Types
Type: InteractiveData.eSignalDesktop.TradingSymbolType
See Also

Reference

SupportedSymbolTypesAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


SupportedSymbolTypesAttribute Properties

SupportedSymbolTypesAttribute Properties

The SupportedSymbolTypesAttribute type exposes the following members.

Properties
 | Name | Description
Public property | SymbolTypes | See SymbolType for the list of symbol types that eSignal supports.
Top
See Also

Reference

SupportedSymbolTypesAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


SupportedSymbolTypesAttribute.SymbolTypes Property

SupportedSymbolTypesAttributeSymbolTypes Property
See SymbolType for the list of symbol types that eSignal supports.

Namespace: InteractiveData.eSignalDesktop.Trading.Attributes
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SymbolType[] SymbolTypes { get; set; }
public:
property array<SymbolType>^ SymbolTypes {
    array<SymbolType>^ get ();
    void set (array<SymbolType>^ value);
}

Property Value

Type: SymbolType
See Also

Reference

SupportedSymbolTypesAttribute Class
InteractiveData.eSignalDesktop.Trading.Attributes Namespace


InteractiveData.eSignalDesktop.Trading.Exceptions Namespace

InteractiveData.eSignalDesktop.Trading.Exceptions Namespace
Classes
 | Class | Description
Public class | AddInException | This type of exception should be used in case of any errors in add-in.
Public class | AddInLoaderException |
Public class | DataValidationException |
Public class | Exception | Base class for exception types.
Public class | InvalidFieldValueException | This type of exception is used when processing order inputs to designate that field value is inappropriate.
Public class | ObjectFieldValidationException |
Public class | SupportedMultilegOrderActionsValidationException |
Public class | SupportedOrderTypesValidationException |


AddInException Class

AddInException Class
This type of exception should be used in case of any errors in add-in.
Inheritance Hierarchy
SystemObject
SystemException
InteractiveData.eSignalDesktop.Trading.ExceptionsException
InteractiveData.eSignalDesktop.Trading.ExceptionsAddInException
InteractiveData.eSignalDesktop.Trading.ExceptionsInvalidFieldValueException

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[SerializableAttribute]
public class AddInException : Exception
[SerializableAttribute]
public ref class AddInException : public Exception
Constructors
 | Name | Description
Public method | AddInException | Initializes a new instance of the AddInException class
Public method | AddInException(String) | Initializes a new instance of the AddInException class
Protected method | AddInException(SerializationInfo, StreamingContext) | Initializes a new instance of the AddInException class
Public method | AddInException(String, Exception) | Initializes a new instance of the AddInException class
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInException Constructor

AddInException Constructor
Overload List
 | Name | Description
Public method | AddInException | Initializes a new instance of the AddInException class
Public method | AddInException(String) | Initializes a new instance of the AddInException class
Protected method | AddInException(SerializationInfo, StreamingContext) | Initializes a new instance of the AddInException class
Public method | AddInException(String, Exception) | Initializes a new instance of the AddInException class
Top
See Also

Reference

AddInException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInException Constructor

AddInException Constructor
Initializes a new instance of the AddInException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public AddInException()
public:
AddInException()
See Also

Reference

AddInException Class
AddInException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInException Constructor (String)

AddInException Constructor (String)
Initializes a new instance of the AddInException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public AddInException(
    string message
)
public:
AddInException(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

AddInException Class
AddInException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInException Constructor (SerializationInfo, StreamingContext)

AddInException Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the AddInException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
protected AddInException(
    SerializationInfo info,
    StreamingContext context
)
protected:
AddInException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AddInException Class
AddInException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInException Constructor (String, Exception)

AddInException Constructor (String, Exception)
Initializes a new instance of the AddInException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public AddInException(
    string message,
    Exception inner
)
public:
AddInException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

AddInException Class
AddInException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInLoaderException Class

AddInLoaderException Class
Inheritance Hierarchy
SystemObject
SystemException
InteractiveData.eSignalDesktop.Trading.ExceptionsException
InteractiveData.eSignalDesktop.Trading.ExceptionsAddInLoaderException

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[SerializableAttribute]
public class AddInLoaderException : Exception
[SerializableAttribute]
public ref class AddInLoaderException : public Exception
Constructors
 | Name | Description
Public method | AddInLoaderException | Initializes a new instance of the AddInLoaderException class
Public method | AddInLoaderException(String) | Initializes a new instance of the AddInLoaderException class
Protected method | AddInLoaderException(SerializationInfo, StreamingContext) | Initializes a new instance of the AddInLoaderException class
Public method | AddInLoaderException(String, Exception) | Initializes a new instance of the AddInLoaderException class
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInLoaderException Constructor

AddInLoaderException Constructor
Overload List
 | Name | Description
Public method | AddInLoaderException | Initializes a new instance of the AddInLoaderException class
Public method | AddInLoaderException(String) | Initializes a new instance of the AddInLoaderException class
Protected method | AddInLoaderException(SerializationInfo, StreamingContext) | Initializes a new instance of the AddInLoaderException class
Public method | AddInLoaderException(String, Exception) | Initializes a new instance of the AddInLoaderException class
Top
See Also

Reference

AddInLoaderException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInLoaderException Constructor

AddInLoaderException Constructor
Initializes a new instance of the AddInLoaderException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public AddInLoaderException()
public:
AddInLoaderException()
See Also

Reference

AddInLoaderException Class
AddInLoaderException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInLoaderException Constructor (String)

AddInLoaderException Constructor (String)
Initializes a new instance of the AddInLoaderException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public AddInLoaderException(
    string message
)
public:
AddInLoaderException(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

AddInLoaderException Class
AddInLoaderException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInLoaderException Constructor (SerializationInfo, StreamingContext)

AddInLoaderException Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the AddInLoaderException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
protected AddInLoaderException(
    SerializationInfo info,
    StreamingContext context
)
protected:
AddInLoaderException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AddInLoaderException Class
AddInLoaderException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


AddInLoaderException Constructor (String, Exception)

AddInLoaderException Constructor (String, Exception)
Initializes a new instance of the AddInLoaderException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public AddInLoaderException(
    string message,
    Exception inner
)
public:
AddInLoaderException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

AddInLoaderException Class
AddInLoaderException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


DataValidationException Class

DataValidationException Class
Inheritance Hierarchy
SystemObject
SystemException
InteractiveData.eSignalDesktop.Trading.ExceptionsException
InteractiveData.eSignalDesktop.Trading.ExceptionsDataValidationException
InteractiveData.eSignalDesktop.Trading.ExceptionsObjectFieldValidationException
InteractiveData.eSignalDesktop.Trading.ExceptionsSupportedMultilegOrderActionsValidationException
InteractiveData.eSignalDesktop.Trading.ExceptionsSupportedOrderTypesValidationException

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[SerializableAttribute]
public class DataValidationException : Exception
[SerializableAttribute]
public ref class DataValidationException : public Exception
Constructors
 | Name | Description
Public method | DataValidationException | Initializes a new instance of the DataValidationException class
Public method | DataValidationException(String) | Initializes a new instance of the DataValidationException class
Protected method | DataValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DataValidationException class
Public method | DataValidationException(String, Exception) | Initializes a new instance of the DataValidationException class
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


DataValidationException Constructor

DataValidationException Constructor
Overload List
 | Name | Description
Public method | DataValidationException | Initializes a new instance of the DataValidationException class
Public method | DataValidationException(String) | Initializes a new instance of the DataValidationException class
Protected method | DataValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DataValidationException class
Public method | DataValidationException(String, Exception) | Initializes a new instance of the DataValidationException class
Top
See Also

Reference

DataValidationException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


DataValidationException Constructor

DataValidationException Constructor
Initializes a new instance of the DataValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public DataValidationException()
public:
DataValidationException()
See Also

Reference

DataValidationException Class
DataValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


DataValidationException Constructor (String)

DataValidationException Constructor (String)
Initializes a new instance of the DataValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public DataValidationException(
    string message
)
public:
DataValidationException(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

DataValidationException Class
DataValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


DataValidationException Constructor (SerializationInfo, StreamingContext)

DataValidationException Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the DataValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
protected DataValidationException(
    SerializationInfo info,
    StreamingContext context
)
protected:
DataValidationException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

DataValidationException Class
DataValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


DataValidationException Constructor (String, Exception)

DataValidationException Constructor (String, Exception)
Initializes a new instance of the DataValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public DataValidationException(
    string message,
    Exception inner
)
public:
DataValidationException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

DataValidationException Class
DataValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


Exception Class

Exception Class
Base class for exception types.
Inheritance Hierarchy
SystemObject
SystemException
InteractiveData.eSignalDesktop.Trading.ExceptionsException
InteractiveData.eSignalDesktop.Trading.ExceptionsAddInException
InteractiveData.eSignalDesktop.Trading.ExceptionsAddInLoaderException
InteractiveData.eSignalDesktop.Trading.ExceptionsDataValidationException

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[SerializableAttribute]
public class Exception : Exception
[SerializableAttribute]
public ref class Exception : public Exception
Constructors
 | Name | Description
Public method | Exception | Initializes a new instance of the Exception class
Public method | Exception(String) | Initializes a new instance of the Exception class
Protected method | Exception(SerializationInfo, StreamingContext) | Initializes a new instance of the Exception class
Public method | Exception(String, Exception) | Initializes a new instance of the Exception class
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


Exception Constructor

Exception Constructor
Overload List
 | Name | Description
Public method | Exception | Initializes a new instance of the Exception class
Public method | Exception(String) | Initializes a new instance of the Exception class
Protected method | Exception(SerializationInfo, StreamingContext) | Initializes a new instance of the Exception class
Public method | Exception(String, Exception) | Initializes a new instance of the Exception class
Top
See Also

Reference

Exception Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


Exception Constructor

Exception Constructor
Initializes a new instance of the Exception class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Exception()
public:
Exception()
See Also

Reference

Exception Class
Exception Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


Exception Constructor (String)

Exception Constructor (String)
Initializes a new instance of the Exception class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Exception(
    string message
)
public:
Exception(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

Exception Class
Exception Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


Exception Constructor (SerializationInfo, StreamingContext)

Exception Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the Exception class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
protected Exception(
    SerializationInfo info,
    StreamingContext context
)
protected:
Exception(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

Exception Class
Exception Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


Exception Constructor (String, Exception)

Exception Constructor (String, Exception)
Initializes a new instance of the Exception class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Exception(
    string message,
    Exception inner
)
public:
Exception(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

Exception Class
Exception Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


InvalidFieldValueException Class

InvalidFieldValueException Class
This type of exception is used when processing order inputs to designate that field value is inappropriate.
Inheritance Hierarchy
SystemObject
SystemException
InteractiveData.eSignalDesktop.Trading.ExceptionsException
InteractiveData.eSignalDesktop.Trading.ExceptionsAddInException
InteractiveData.eSignalDesktop.Trading.ExceptionsInvalidFieldValueException

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[SerializableAttribute]
public class InvalidFieldValueException : AddInException
[SerializableAttribute]
public ref class InvalidFieldValueException : public AddInException

The InvalidFieldValueException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidFieldValueException | Initializes a new instance of the InvalidFieldValueException class
Protected method | InvalidFieldValueException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidFieldValueException class
Public method | InvalidFieldValueException(String, String) | Initializes a new instance of the InvalidFieldValueException class
Public method | InvalidFieldValueException(String, String, Exception) | Initializes a new instance of the InvalidFieldValueException class
Top
Properties
 | Name | Description
Public property | Field | Short ID of the order input field.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


InvalidFieldValueException Constructor

InvalidFieldValueException Constructor
Overload List
 | Name | Description
Public method | InvalidFieldValueException | Initializes a new instance of the InvalidFieldValueException class
Protected method | InvalidFieldValueException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidFieldValueException class
Public method | InvalidFieldValueException(String, String) | Initializes a new instance of the InvalidFieldValueException class
Public method | InvalidFieldValueException(String, String, Exception) | Initializes a new instance of the InvalidFieldValueException class
Top
See Also

Reference

InvalidFieldValueException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


InvalidFieldValueException Constructor

InvalidFieldValueException Constructor
Initializes a new instance of the InvalidFieldValueException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public InvalidFieldValueException()
public:
InvalidFieldValueException()
See Also

Reference

InvalidFieldValueException Class
InvalidFieldValueException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


InvalidFieldValueException Constructor (SerializationInfo, StreamingContext)

InvalidFieldValueException Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the InvalidFieldValueException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
protected InvalidFieldValueException(
    SerializationInfo info,
    StreamingContext context
)
protected:
InvalidFieldValueException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

InvalidFieldValueException Class
InvalidFieldValueException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


InvalidFieldValueException Constructor (String, String)

InvalidFieldValueException Constructor (String, String)
Initializes a new instance of the InvalidFieldValueException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public InvalidFieldValueException(
    string field,
    string message
)
public:
InvalidFieldValueException(
    String^ field,
    String^ message
)

Parameters

field
Type: SystemString
message
Type: SystemString
See Also

Reference

InvalidFieldValueException Class
InvalidFieldValueException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


InvalidFieldValueException Constructor (String, String, Exception)

InvalidFieldValueException Constructor (String, String, Exception)
Initializes a new instance of the InvalidFieldValueException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public InvalidFieldValueException(
    string field,
    string message,
    Exception inner
)
public:
InvalidFieldValueException(
    String^ field,
    String^ message,
    Exception^ inner
)

Parameters

field
Type: SystemString
message
Type: SystemString
inner
Type: SystemException
See Also

Reference

InvalidFieldValueException Class
InvalidFieldValueException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


InvalidFieldValueException Properties

InvalidFieldValueException Properties

The InvalidFieldValueException type exposes the following members.

Properties
 | Name | Description
Public property | Field | Short ID of the order input field.
Top
See Also

Reference

InvalidFieldValueException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


InvalidFieldValueException.Field Property

InvalidFieldValueExceptionField Property
Short ID of the order input field.

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Field { get; set; }
public:
property String^ Field {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

InvalidFieldValueException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException Class

ObjectFieldValidationException Class
Inheritance Hierarchy
SystemObject
SystemException
InteractiveData.eSignalDesktop.Trading.ExceptionsException
InteractiveData.eSignalDesktop.Trading.ExceptionsDataValidationException
InteractiveData.eSignalDesktop.Trading.ExceptionsObjectFieldValidationException

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[SerializableAttribute]
public class ObjectFieldValidationException : DataValidationException
[SerializableAttribute]
public ref class ObjectFieldValidationException : public DataValidationException

The ObjectFieldValidationException type exposes the following members.

Constructors
 | Name | Description
Protected method | ObjectFieldValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ObjectFieldValidationException class
Public method | ObjectFieldValidationException(Type, String) | Initializes a new instance of the ObjectFieldValidationException class
Public method | ObjectFieldValidationException(Type, String, String) | Initializes a new instance of the ObjectFieldValidationException class
Top
Methods
 | Name | Description
Public method | GetObjectData | (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Top
Properties
 | Name | Description
Public property | Field | Short ID of the field that has inappropriate value.
Public property | ObjectType | Type of object that caused exception.
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException Constructor

ObjectFieldValidationException Constructor
Overload List
 | Name | Description
Protected method | ObjectFieldValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ObjectFieldValidationException class
Public method | ObjectFieldValidationException(Type, String) | Initializes a new instance of the ObjectFieldValidationException class
Public method | ObjectFieldValidationException(Type, String, String) | Initializes a new instance of the ObjectFieldValidationException class
Top
See Also

Reference

ObjectFieldValidationException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException Constructor (SerializationInfo, StreamingContext)

ObjectFieldValidationException Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the ObjectFieldValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
protected ObjectFieldValidationException(
    SerializationInfo info,
    StreamingContext context
)
protected:
ObjectFieldValidationException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ObjectFieldValidationException Class
ObjectFieldValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException Constructor (Type, String)

ObjectFieldValidationException Constructor (Type, String)
Initializes a new instance of the ObjectFieldValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public ObjectFieldValidationException(
    Type ObjectType,
    string Message
)
public:
ObjectFieldValidationException(
    Type^ ObjectType,
    String^ Message
)

Parameters

ObjectType
Type: SystemType
Message
Type: SystemString
See Also

Reference

ObjectFieldValidationException Class
ObjectFieldValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException Constructor (Type, String, String)

ObjectFieldValidationException Constructor (Type, String, String)
Initializes a new instance of the ObjectFieldValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public ObjectFieldValidationException(
    Type ObjectType,
    string Field,
    string Message
)
public:
ObjectFieldValidationException(
    Type^ ObjectType,
    String^ Field,
    String^ Message
)

Parameters

ObjectType
Type: SystemType
Field
Type: SystemString
Message
Type: SystemString
See Also

Reference

ObjectFieldValidationException Class
ObjectFieldValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException Methods

ObjectFieldValidationException Methods

The ObjectFieldValidationException type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

ObjectFieldValidationException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException.GetObjectData Method

ObjectFieldValidationExceptionGetObjectData Method

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ObjectFieldValidationException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException Properties

ObjectFieldValidationException Properties

The ObjectFieldValidationException type exposes the following members.

Properties
 | Name | Description
Public property | Field | Short ID of the field that has inappropriate value.
Public property | ObjectType | Type of object that caused exception.
Top
See Also

Reference

ObjectFieldValidationException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException.Field Property

ObjectFieldValidationExceptionField Property
Short ID of the field that has inappropriate value.

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public string Field { get; set; }
public:
property String^ Field {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ObjectFieldValidationException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


ObjectFieldValidationException.ObjectType Property

ObjectFieldValidationExceptionObjectType Property
Type of object that caused exception.

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public Type ObjectType { get; set; }
public:
property Type^ ObjectType {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

ObjectFieldValidationException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedMultilegOrderActionsValidationException Class

SupportedMultilegOrderActionsValidationException Class
Inheritance Hierarchy
SystemObject
SystemException
InteractiveData.eSignalDesktop.Trading.ExceptionsException
InteractiveData.eSignalDesktop.Trading.ExceptionsDataValidationException
InteractiveData.eSignalDesktop.Trading.ExceptionsSupportedMultilegOrderActionsValidationException

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[SerializableAttribute]
public class SupportedMultilegOrderActionsValidationException : DataValidationException
[SerializableAttribute]
public ref class SupportedMultilegOrderActionsValidationException : public DataValidationException
Constructors
 | Name | Description
Public method | SupportedMultilegOrderActionsValidationException | Initializes a new instance of the SupportedMultilegOrderActionsValidationException class
Public method | SupportedMultilegOrderActionsValidationException(String) | Initializes a new instance of the SupportedMultilegOrderActionsValidationException class
Protected method | SupportedMultilegOrderActionsValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SupportedMultilegOrderActionsValidationException class
Public method | SupportedMultilegOrderActionsValidationException(String, Exception) | Initializes a new instance of the SupportedMultilegOrderActionsValidationException class
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedMultilegOrderActionsValidationException Constructor

SupportedMultilegOrderActionsValidationException Constructor
Overload List
 | Name | Description
Public method | SupportedMultilegOrderActionsValidationException | Initializes a new instance of the SupportedMultilegOrderActionsValidationException class
Public method | SupportedMultilegOrderActionsValidationException(String) | Initializes a new instance of the SupportedMultilegOrderActionsValidationException class
Protected method | SupportedMultilegOrderActionsValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SupportedMultilegOrderActionsValidationException class
Public method | SupportedMultilegOrderActionsValidationException(String, Exception) | Initializes a new instance of the SupportedMultilegOrderActionsValidationException class
Top
See Also

Reference

SupportedMultilegOrderActionsValidationException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedMultilegOrderActionsValidationException Constructor

SupportedMultilegOrderActionsValidationException Constructor
Initializes a new instance of the SupportedMultilegOrderActionsValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SupportedMultilegOrderActionsValidationException()
public:
SupportedMultilegOrderActionsValidationException()
See Also

Reference

SupportedMultilegOrderActionsValidationException Class
SupportedMultilegOrderActionsValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedMultilegOrderActionsValidationException Constructor (String)

SupportedMultilegOrderActionsValidationException Constructor (String)
Initializes a new instance of the SupportedMultilegOrderActionsValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SupportedMultilegOrderActionsValidationException(
    string message
)
public:
SupportedMultilegOrderActionsValidationException(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

SupportedMultilegOrderActionsValidationException Class
SupportedMultilegOrderActionsValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedMultilegOrderActionsValidationException Constructor (SerializationInfo, StreamingContext)

SupportedMultilegOrderActionsValidationException Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the SupportedMultilegOrderActionsValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
protected SupportedMultilegOrderActionsValidationException(
    SerializationInfo info,
    StreamingContext context
)
protected:
SupportedMultilegOrderActionsValidationException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

SupportedMultilegOrderActionsValidationException Class
SupportedMultilegOrderActionsValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedMultilegOrderActionsValidationException Constructor (String, Exception)

SupportedMultilegOrderActionsValidationException Constructor (String, Exception)
Initializes a new instance of the SupportedMultilegOrderActionsValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SupportedMultilegOrderActionsValidationException(
    string message,
    Exception inner
)
public:
SupportedMultilegOrderActionsValidationException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

SupportedMultilegOrderActionsValidationException Class
SupportedMultilegOrderActionsValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedOrderTypesValidationException Class

SupportedOrderTypesValidationException Class
Inheritance Hierarchy
SystemObject
SystemException
InteractiveData.eSignalDesktop.Trading.ExceptionsException
InteractiveData.eSignalDesktop.Trading.ExceptionsDataValidationException
InteractiveData.eSignalDesktop.Trading.ExceptionsSupportedOrderTypesValidationException

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
[SerializableAttribute]
public class SupportedOrderTypesValidationException : DataValidationException
[SerializableAttribute]
public ref class SupportedOrderTypesValidationException : public DataValidationException
Constructors
 | Name | Description
Public method | SupportedOrderTypesValidationException | Initializes a new instance of the SupportedOrderTypesValidationException class
Public method | SupportedOrderTypesValidationException(String) | Initializes a new instance of the SupportedOrderTypesValidationException class
Protected method | SupportedOrderTypesValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SupportedOrderTypesValidationException class
Public method | SupportedOrderTypesValidationException(String, Exception) | Initializes a new instance of the SupportedOrderTypesValidationException class
Top
See Also

Reference

InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedOrderTypesValidationException Constructor

SupportedOrderTypesValidationException Constructor
Overload List
 | Name | Description
Public method | SupportedOrderTypesValidationException | Initializes a new instance of the SupportedOrderTypesValidationException class
Public method | SupportedOrderTypesValidationException(String) | Initializes a new instance of the SupportedOrderTypesValidationException class
Protected method | SupportedOrderTypesValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SupportedOrderTypesValidationException class
Public method | SupportedOrderTypesValidationException(String, Exception) | Initializes a new instance of the SupportedOrderTypesValidationException class
Top
See Also

Reference

SupportedOrderTypesValidationException Class
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedOrderTypesValidationException Constructor

SupportedOrderTypesValidationException Constructor
Initializes a new instance of the SupportedOrderTypesValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SupportedOrderTypesValidationException()
public:
SupportedOrderTypesValidationException()
See Also

Reference

SupportedOrderTypesValidationException Class
SupportedOrderTypesValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedOrderTypesValidationException Constructor (String)

SupportedOrderTypesValidationException Constructor (String)
Initializes a new instance of the SupportedOrderTypesValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SupportedOrderTypesValidationException(
    string message
)
public:
SupportedOrderTypesValidationException(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

SupportedOrderTypesValidationException Class
SupportedOrderTypesValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedOrderTypesValidationException Constructor (SerializationInfo, StreamingContext)

SupportedOrderTypesValidationException Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the SupportedOrderTypesValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
protected SupportedOrderTypesValidationException(
    SerializationInfo info,
    StreamingContext context
)
protected:
SupportedOrderTypesValidationException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

SupportedOrderTypesValidationException Class
SupportedOrderTypesValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace


SupportedOrderTypesValidationException Constructor (String, Exception)

SupportedOrderTypesValidationException Constructor (String, Exception)
Initializes a new instance of the SupportedOrderTypesValidationException class

Namespace: InteractiveData.eSignalDesktop.Trading.Exceptions
Assembly: InteractiveData.EsignalDesktop.Trading (in InteractiveData.EsignalDesktop.Trading.dll) Version: 1.0.4879.920 (1.0.4879.920)
Syntax
C#
C++
Copy
public SupportedOrderTypesValidationException(
    string message,
    Exception inner
)
public:
SupportedOrderTypesValidationException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

SupportedOrderTypesValidationException Class
SupportedOrderTypesValidationException Overload
InteractiveData.eSignalDesktop.Trading.Exceptions Namespace